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Below you will find the different conventions used in the manual and their use within the user guide. 

   

Menu: Application Menu > Open Raster Image 

 

 

Used to present a command. On the left is the icon of choice as it appears in the application, i.e. on the 

toolbar. On the right are the options for that command. 

 

 

Attention!!! This icon indicates a warning or caution for the proper 

operation in order to obtain the desired results.  

 

 

 

Information!!! This icon signifies a tip, suggestion, or general note for a 

command in order to be better explained and described.  
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IŶtroduĐtioŶ 

 

Target – Work ProĐess 
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 RaVe is a high quality, stand-alone, software application for digitizing scanned drawings to vector files 

and saving them in vector (.dwg) format. The process is simple and involves two steps: 

a) Image processing 

and 

b) Conversion settings 

 

Image Processing 

 Image alignment and setup. 

 Fill process. 

 Image enhancement and clean up. 

 Line thickness adjustment (thinning/thickening). 

 

Conversion Settings 

 Setting minimum values. 

 Replacement of scanned vectors. 

 Arc and curve replacement. 

 File digitization. 
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RiďďoŶ 

 

AppliĐatioŶ MeŶu 
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Opening Raster Image 

 This command opens the raster image to be converted. 

   

Ribbon: Application Menu > Open raster image 

 

 Clicking on the icon opens a dialog box to locate the raster image to be converted. 

 

 

Open Select the file and click Open 

Cancel Cancels the command 
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Saving Raster Image 

 This command saves the converted raster image. 

   

Ribbon: Application Menu > Save raster image 

 

 Clicking on the icon opens a dialog box to select the location for the raster image to be saved. 

 

 

Save Saves the raster image. 

Cancel Cancels the command. 
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Saving as DWG-DXF 

 This command saves the vectorized file in Dwg or Dxf format. 

   

Ribbon: Application Menu > Save as DWG-DXF 

 

 Clicking on the icon opens a dialog box to select the location for the vectorized file to be saved in Dwg or 

Dxf format. 

 

 

File name Type the desired name of the file. 

Save as type Select the type of the file to be saved. The following types are supported: 

AutoCAD 2013 Drawing (*.dwg) 

AutoCAD 2010 Drawing (*.dwg) 

AutoCAD 2007 Drawing (*.dwg) 

AutoCAD 2004 Drawing (*.dwg) 

AutoCAD 2000 Drawing (*.dwg) 
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AutoCAD R14 Drawing (*.dwg) 

AutoCAD R13 Drawing (*.dwg) 

AutoCAD 2013 DXF (*.dxf) 

AutoCAD 2010 DXF (*.dxf) 

AutoCAD 2007 DXF (*.dxf) 

AutoCAD 2004 DXF  (*.dxf) 

AutoCAD 2000 DXF (*.dxf) 

AutoCAD R14 DXF (*.dxf) 

AutoCAD R13 DXF (*.dxf) 

Save Saves the file. 

Cancel Cancels the command. 
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Exit 

 This command exits from the application. 

   

Ribbon: Application Menu > Exit 
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RiďďoŶ 

 

Hoŵe 
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Parameters 

Scale 

 This command defines the scale for the file conversion. 

   

Ribbon: Home > Parameters > Scale 

 

 Clicking on the icon opens the dialog box below. 

 

 

Automatic calculation by 

pick (pixel) 

Checking this box, the application automatically uses an optimized scale 

based on the image resolution. 

 If the checkbox is cleared, then manual calculations can be applied. How; See below.  

 A distance in pixels needs to be defined in meters. Click on Pick, in Point 1 (Pic.1) and then select the 

first point between the distance on the image (Pic.2). 
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 Pic.1      Pic.2 

 

Next, select Pick, in Point 2 (Pic.3) and then select the second pint between the distance in the image (Pic.4). 

 Pic.3      Pic.4 

Since the distance has been set in Pixels, then enter the actual value of the distance in meters (Pic.5). 

 Pic.5 

Click ΟΚ, to save all values. 
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Modify 

Crop 

 This command crops the image. 

   

Ribbon: Home > Modify > Crop 

 

 If from an image such as an architectural plan (see below), room 2 needs to be isolated (Pic.1) 
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 Pic.1 

Select the command and pick two diametrically opposite points. For example, lelf click on the upper left corner 

of the part that needs to be isolated and then left click on the lower right corner. (Pic.2). 
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 Pic.1 

The result is in Pic.3 

 Pic.3 

 

Rotate Left 

 The command rotates the raster image counterclockwise 90ο. 

   
Ribbon: Home > Modify > Rotate Left 
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 Before 
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 After 
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Rotate Right 

 The command rotates the raster image clockwise 90ο. 

   

Ribbon: Home > Modify > Rotate Right 

 

 

 Before 
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 After 

  

Horizontal Mirror 

 The command creates a mirrored copy of the raster according to the horizontal axis. 

   

Ribbon: Home > Modify > Horizontal Mirror 
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 Before 

 

 

 After 
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Negative 

 This command reverses the blacks and whites of the raster. Works the same way negatives work on 

photographs. 

   

Ribbon: Home > Modify > Negative 

 

 

 Before 

 



RaVe                                                                  Index 

 

Pg. | 31  

 

 

 After 

  



RaVe                                                                  Index 

 

Pg. | 32  

 

 

Edit Raster 

Fill Small Holes 

   

Ribbon: Home > Edit Raster > Fill Small Holes 

 

  

 This function performed before vectorization, significantly, improves the vectorization outcome. It fills 

small gaps which would otherwise impact the vectorized result. For example, a line accidentally cut in the 

middle will be corrected to a continuous line. Clicking on this icon, repeatedly, replicates the process. 

 

ȳέʅισʅα οʋώʆ 

   

Ribbon: Home > Edit Raster > Fill Holes 

 

  

 This function is used for filling larger gaps. Clicking on this icon, repeatedly, replicates the process. 

Both functions make minor corrections. As a result, they can be performed multiple times on the raster image 

for filling up the gaps.  

Connect 

   

Ribbon: Home > Edit Raster > Connect 
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 Clicking on this icon connects all the points (pixels) which are 1pixel apart. This function is used only 

when absolutely necessary. Usually, before the cleaning function (Clean), which can cause gaps larger than 1 

pixel, leading to disconnected pixels. 

 This function result in ĐoŶŶeĐtiŶg poiŶts that hadŶ’t ďeeŶ iŶitiallǇ ĐoŶŶeĐted. Thus, clicking Fill Holes 

must always follow. 

 Alternatively, clicking on Thin Lines before clicking Connect would reduce the number of undesired 

connections. 

Clean  

   

Ribbon: Home > Edit Raster > Clean 

 

  

 Clean is an essential step before any vectorization. It improves the entire raster image, reduces noise, 

improves raster quality, and fills small gaps. It can also be repeated many times if necessary. 

Thin Lines 

   

Ribbon: Home > Edit Raster > Thin Lines 

 

  

 Clicking on this icon reduces the width of the lines on the raster image. Each click on this icon reduces 

the width of the lines of the raster. 
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Thicken Lines 

   

Ribbon: Home > Edit Raster > Thicken Lines 

 

  

 Clicking on this icon increases the width of the lines on the raster image. Each click on this icon increases 

the lines of the raster. The thicker the lines the better the vectorization result. 
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Contour creation 

1 pixel 

   

Ribbon: Home > Contour Creation > 1 pixel 

 

  

 Clicking on this icon creates a contour of 1 pixel width. If the width of the existing line is greater than 1 

pixel then this command will create a new outline for this line with 1 pixel width. 

 

2 pixel 

   

Ribbon: Home > Contour Creation > 2 pixel 

 

  

 Clicking on this icon creates a contour of 2 pixel width. If the width of the existing line is greater than 2 

pixel then this command will create a new outline for this line with 2 pixel width. 

 

3 pixel 

   

Ribbon: Home > Contour Creation > 3 pixel 
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 Clicking on this icon creates a contour of 3 pixel width. If the width of the existing line is greater than 3 

pixel then this command will create a new outline for this line with 3 pixel width. 

Undo 

Undo 

   

Ribbon: Home > Undo > Undo 

 

  

 Reverses the most recent action. It can roll back multiple times. 

 

Redo 

   

Ribbon: Ȳασικό > Undo > Redo 

 

  

 Reverses the most recent Undo command. It can roll forward multiple times. 
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RiďďoŶ 

 

View 
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Zoom 

Zoom All 

   

Ribbon: View > Zoom > Zoom All 

 

 Zooms to display all visible objects. 
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Zoom In 

   

Ribbon: View > Zoom > Zoom In 

 

 Zooms to increase the magnification of the current view with constant step at the position of the cursor. 

 

Zoom Out 

   

Ribbon: View > Zoom > Zoom Out 

 

 Zooms to decrease the magnification of the current view with constant step at the position of the 

cursor. 

 

Pan 

Pan 

   

Ribbon: View > Pan > Pan 

 



RaVe                                                                  Index 

 

Pg. | 41  

 

 

 Moves the view in realtime. 

 

Zoom 100% 

Zoom 1:1 

   

Ribbon: View > Zoom 100% > Zoom 1:1 

 

 Zooms the raster at scale 1:1. 

 

 

Zoom Upper Left 1:1 

   

Ribbon: View > Zoom 100% > Zoom Upper Left 1:1 
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 Zooms the raster at 1:1, with base point at the upper left corner of the raster. 

 

 

Zoom Center 1:1 

   

Ribbon: View > Zoom 100% >  Zoom Center 1:1 

 

 Zooms the raster at 1:1, with base point at the center of the raster. 
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RiďďoŶ 

 

Eǆport 
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Conversion 

Settings 

 Displays a dialog box which offers the necessary arrangements for proper digitization of the image. Let's 

see them detail. 

   

Ribbon: Export > Settings 

 

 Executing the command displays the following dialog box. 
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 This taď is diǀided iŶto fiǀe ;5Ϳ ŵaiŶ Đategories. Let’s see theŵ iŶ detail: 
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Centerlines Choosing this option will take an AutoCAD file in which the line will have the form of 

centerlines AutoCAD 

Outlines Choosing this option will take an AutoCAD file in which the line will have the form 

Outlines. 

Min pixel length Allows removal of lines, which are combined with other lines at only one point and 

length in pixels is less than the value of the field. Introducing greater values in this 

field can have line losses in the results. 

Gap jump Specifies the length of the gap in pixels, that RaVe can override during the digitization 

process. 

 

Then the following options determine how to recognize elements of the image. The recognition is done either 

with lines or arcs, or curves. 

 

Lines Activating the field, allows the identification of lines. 

Horizontal and 

vertical 

Enables the ability to recognize horizontal and vertical lines. For example, a line in 

the drawing which is in fact vertical, it might show up with a small angle. If this is 

enabled then the line will be converted as vertical. 

45 degrees When this is selected, Rave will do a special test for lines with an angle of 45 degrees. 

 

 

Curves Enables the of recognition curved objects. During digitizing the recognition of cycles 

is made by individual arcs. 
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Curves 

 

There are many ways of recognizing the curves of the image. The digitization will be made either by smoothing 

curves or replacing them by something else. 

Smoother 

Smoothing is an important piece in the amplification mechanism of curves. In each iteration of this operation, 

we improve the normalization of the curves . The number of repetitions determines the depth of the redesign. 

Each iteration can slightly turn the curve. So it may be adversely impacted by the accuracy with respect to 

smoothness . When you need precision, we proposed a few iterations (1-2). When you want to achieve the 

effect of a perfect curve you may need 10 to 20 reps, but you will lose in accuracy . 

Shift constrained Sets the limit on the curve changes. It is directly related to the option Shift 

Tolerance Changes. By activating this option will need to define a number in 

the field Shift Tolerance. 

Iteration number Sets the number of repetitions. 

Shift tolerance Sets the tolerance in converting a curve. 

1. If you set 0, then the curve will stay as is. 

 2. If Ǉou set a ǀalue ;e.g. ǆͿ theŶ it ǁill alloǁ to ĐhaŶge the Đurǀe ďǇ ͞ǆ͟ 
pixels. 

 

The conclusion is that the enabling Shift constrained it affect smoothness. So it is better not to use it when we 

want to achieve perfect curves. 

Represented by 

Replaces the curves in three different ways. Replace curves with Limes, Splines or Polylines (Splines – Poly 

lines/arcs). 

Lines Replaces curves with straight lines.  

Splines Replaces curves with splines. Splines are smooth curves that are drawn with 

the NURBS method (Non Uniform Rational Bazer Splines). There are two 

options: 
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Tolerance in pixels: Sets the precision of replacing curves with Splines. 

Greater tolerance (higher number field), fewer points in Spline. The 

difference between  checkpoints and endpoints is marked with different 

color.  

Spilnes-Polylines/arcs Replaces curves with Polylines (polylines). A polyline can be composed of 

several segments or arcs which form an object. The conversion of curves to 

lines and arcs is controlled by the field Poly arc. Setting a greater value in the 

field will yield fewer arcs. The value you set in the field is actually the 

tolerance with arcs. 

 

 

Angle sensitivity Setting a higher value in the field will detect more angles 

Intersect along tangents When this is turned off there is a different algorithm used to detect 

intersected lines. It is suggested to have this off when you have a lot of 

intersected lines e.g. when you have maps with a lot of intersected curves.  

Default Loads default settings. 

Load Template Loads a template that you have created from a file. 

Save Template Saves the current settings to a file.  
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Vectorize 

 Vectorize will start the conversion process of raster (images) files to vector (DWG/DXF) according to the 

settings you have selected. 

   

Ribbon: Export > Vectorize 
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Dwg-Dxf 

Save 

 With this command we save our digitized file as DWG or DXF in any AutoCAD version. 

   

Ribbon: Export > Dwg-Dxf > Save 

 

 Selecting Save you get the window to choose the location of where you will save your file.  

 

 

File name Set a File name. 
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Save as type Set the File Type. You have the following options: 

AutoCAD 2013 Drawing (*.dwg) 

AutoCAD 2010 Drawing (*.dwg) 

AutoCAD 2007 Drawing (*.dwg) 

AutoCAD 2004 Drawing (*.dwg) 

AutoCAD 2000 Drawing (*.dwg) 

AutoCAD R14 Drawing (*.dwg) 

AutoCAD R13 Drawing (*.dwg) 

AutoCAD 2013 DXF (*.dxf) 

AutoCAD 2010 DXF (*.dxf) 

AutoCAD 2007 DXF (*.dxf) 

AutoCAD 2004 DXF  (*.dxf) 

AutoCAD 2000 DXF (*.dxf) 

AutoCAD R14 DXF (*.dxf) 

AutoCAD R13 DXF (*.dxf) 

Save Saves the file.  

Cancel Cancels the command. 
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Καθαʌισʅός 

   

Ribbon: Export > Dwg-Dxf > Clear all 

 

This command reset the software to it’s startup state so ǁe ŵoǀe oŶ to ĐoŶǀert a Ŷeǁ file. Please ďe 
careful as this will clear everything on the screen and your current work. Make sure you have saved your file 

before selecting this.  
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RiďďoŶ 

 

LaŶguage 
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RiďďoŶ 

 

GeŶeral 
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RaVe                                                                  Index 

 

Pg. | 59  

 

 

Style 

   

Ribbon: Style 

 

 This commands sets the style of your interface. You have the following options: 

Office 2007 (Blue Style) 

 

 

Office 2007 (Black Style) 
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Office 2007 (Silver Style) 

 

 

Office 2007 (Aqua Style) 
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Windows 7 
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About 

   

Ribbon: About 

 

 You select this option to get the about screen and activate the software. 

 Choosing this command you get the following dialog: 
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QuiĐk LauŶĐh Bar 

 

MeŶus 
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 At the Quick Launch Bar, we can create shortcuts for faster execution of commands. The defaults 

commands are: 

 Open Raster File 

 Save Vector File 

 Exit 

 Undo 

 Redo 

 Reference to the mentioned commands can be found in previous chapters. 

Customize Quick Access Toolbar 

 With the following command we can customize the tool bar. 

   

Quick Access Toolbar: Customize Quick Access Toolbar 

 

 Selecting it you get the following commands: 

 

 Let’s see iŶ detail ǁhat we can do: 

Enabled Commands area 
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 At this toolbar you will see the commands that have been inserted into the Quick Access Toolbar. 

Selecting or Disabling each command will show it or hide it. For Example:  

    

 

    

Show Below the Ribbon 

 Shows the Quick Access Toolbar below the Ribbon.  

   

Quick Access Toolbar: Customize Quick Access Toolbar > Show Below the Ribbon 

 

 Executing the command you get the following Toolbar: 

 

Minimize the Ribbon 
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 Minimizes the Ribbon 

   

Quick Access Toolbar: Customize Quick Access Toolbar > Minimize Ribbon 
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More commands 

 This command customizes the Toolbar. Using this command we can add or remove commands from the 

toolbar. 

   

Quick Access Toolbar: Customize Quick Access Toolbar > More commands 

 

 Selecting the command you get the following prompt: 

 

 Let’s see the ĐoŵŵaŶds iŶ detail:: 

Choose commands from: 

We choose the group of commands we want to. You will get the following options:: File, Print Preview, Basic, 

View, Export, Language. After we select one group of commands we will see the commands that are included 

in the group. 
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Commands 

 Shows the list of commands that belong to this group. Selecting one command from the group and 

clicking Add will add it to the right column which is the list of active commands on the toolbar.  

Add 

Adds a command to the toolbar. 

Remove 

Removes a command from the toolbar. 

Reset 

Resets the default settings for the toolbars. 

Show Quick Access Toolbar below the Ribbon 

Moves the quick access toolbar below the Ribbon area. 

Customize 

Creates the shortcuts of the commands. Executing this command you will get the following prompt: 
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Categories Shows the Categories of the commands. 

Commands Shows the Commands that belong to each category.  

Current Keys Shows the shortcut of each command. 

Press new shortcut 

key 

Setup a new shortcut key 

Set Accelerator for Set up the accelerator 

Assign Assigns the shortcut to the command 

Remove Removes the shortcut from the command.  

Reset All Resets defaults 

Close Closes the dialog.  

 

 


