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GstarCAD8 Introduction

GstarCADS is a brand new platform thought to satisfy user’s needs. GstarCAD8 adopts a new engine more agile and compatible
with a number of innovative technologies that work bonded to make its graphic speed 3-5 times faster, accelerating operation
performance and reaching less memory usage than previous versions. Not only the speed and performance are guaranteed but
also the stability concept has changed radically through a new modular architecture software. These three links empower
GstarCADS to boost speed and performance beyond complex tasks on huge drawings supported by outstanding stability than
any other CAD platform.

This section helps you get started using GstarCAD8 software by explaining how to install it and providing basic information
about how to use it.

System Requirements

Before installing GstarCAD, please confirm whether the specifications of your PC meet the
following requirements:

Windows XP Home and Professional Edition SP2 or later
0S (Operating System) Microsoft Windows Vista SP1 or later

Windows 7(32 bit,64 bit)

Windows 8(32 bit,64 bit)

Windows XP - Intel Pentium 4 or AMD
Windows Vista - Intel Pentium 4 or AMD

CPU Athlon™ Dual Core processor, 1.6 GHz or higher with SSE2 technology
Athlon™ Dual Core processor, 3.0 GHz or higher with SSE2 technology

Windows XP - 512 MB RAM
Windows Vista - 1 GB RAM

RAM Windows 7 - 1 GB RAM
Windows 8 - 1 GB RAM

DISPLAY 1024 x 768 VGA with True Color (minimum)

HARD DISK 512MB or higher
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GstarCADS8 Installation

Users can visit www.gstarcad.net to download GstarCAD8 to your computer or server.

GstarCADS installshield wizard will guide the user to complete successfully the installation of the software in the operating
system. GstarCAD8 standard and professional versions are not the same. The software will automatically distinguish according
to the user when registering dongle or serial number. The installation steps are as follow:

1.- Double-click the executable file downloaded | % GstarCADE 4 the "Gstarcad-InstallShield Wizard" dialog box will pop
up. Click the "Next" button to continue the installation. See figure 1-1.

2.- The “License Agreement” dialog box is displayed. If you agree, check “I accept the terms of license agreement” and click
the "Next" button to continue the installation. See figure 1-2.

Shield Wiz

GstarcaD

Welcome to GstarCADS InstaliShield Wizard.

SrccEo

rFor Your DesIGr

Next>

Figure 1-1

GstarcAp 8

License Agreement
Plea

Gstarsoft Software License Agreement o
Xi'an Gstarsoft Ltd. (“Gstarsoft”) licenses the software to you only upon the

wndiﬁon that you accept all of the terms in this SOFTWARE LICENSE
AGREEMENT.

IATTENTION:
Read the terms and conditions of this license agreement carefully. Use of the

|
Jsoftware is subject to the Gstarsoft’ s terms set forth below. Use of the software

oo indicates your acceptance of the license terms. If you do not accept the lcense
terms, you should select "Cancel” to quit the install. Within 30 days of trial using or
[ before the ficense cods is provided from your purchase, retum the software, the

ired it for a full refund. If the software ins bundled with another product, you
or a full efund.

Figure 1-2

3.- The "User Information" dialog box pops up, enter your user information and click the "Next" button. See figure 1-3.

4 - Then choose the destination path where setup will install the files and click the "Next" button as shown in Figure 1-4.

[GetarCAD -

GstarcAD 8

Customer Information

GstarcAD ( =

SrcEo

Cancel

Figure 1-3

Gstarcap 8

Choose Destination Location

Change.

GstarcAD ( =

Cancel

Figure 1-4
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5.- Then "The install option" dialog box pops up, you can choose between uncheck or check the VBA option. To continue with
the installation just click the "Next" button. See figure 1-5.

6.- Then the wizard is ready to begin the program installation. If you want to review or change any of your installation settings
just click the "Back" button. Click the "Install" button to continue with the installation. See figure 1-6.

7.- Then "The GstarCAD wizard" dialog box pops up. The GstarCAD wizard has successfully installed the program. Click the
"Finish" button to exit the wizard. See figure 1-7.

GstarcAD 8 GstarcaD 8

Install option Ready to Install the Pi
Th

A 7
GstarcAD ( GstarciD (

Srcco

[(GstarCAD - InstalShield W iza
GstarcaD 8

GstarCAD Wizard Complet

GstarcaD ( =

SrccEo

Figure 1-7
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Starting up GstarCAD8

The User Interface

You can enjoy working at GstarCAD8 environment in different ways. You can display and rearrange elements like the toolbars,
display the command bar, switch between workspaces, change the interface themes and enable the status bar. The toolbars and
command bar can also be floated anywhere on the screen or docked as well.

g
q I 2D Drafting -
Home , T 8 -
e R
Line Polyline Chde Au hju é
Clipboard
7|1
Z|%
@
12 e
o|®
Vel Bl
o®
olh
7_).’\J e
r=y=s
Crex | 725171 A
Center Y 1834.8047 +
Center Z 0 2
Height 4988 8504 N7 8 o |
Widh 19245633 | / @|®
e . o
UCS icon On Yes X © 4
UCS icon at orig. \: 1 9 6 A 2
B ol
Z,

1.- Quick Access Toolbar: N = < 42D Drafting

[v] hew...
[V] open..

Display the frequently used tools like: New, Open, Save, Undo, Redo, Save As, Plot, Plot Preview and ~ |v] see

| ] save as...

Help. Moreover you can customize it (adding more commands from the drop-down button) or [V] prnt..

[ V] unde

showing it bellow/above the ribbon. [V] reao

[¥] workspaces

More Commands...

42 show Below the Ribbon

¥, Minimize the Ribbon

2.- Workspace Switching: Switch between two workspaces (2D Drafting and GstarCAD Classic).

@ F=EEBz2 - ‘I -
R R R 2D Drafting

] Gstarcap Classic ——f———p

Insert Annotation

0!10'-”5-‘- B =0 0|
Eie Edit Yiew [oet

Fgmat Took Diaw Dinegsion Wodly Window Heo Epeess

FEEEEEE Y e L L A v 4 50 B/ /208700 M008R - EODA
fecoramo Y - —bBae v — b H2BAaBSOER--DO T T &
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3.- Menu Bar: The menu bar is used for selecting commands by mouse instead of inputting commands by keyboard. In it you
can find the follow menu tabs: File, Edit, View, Insert, Format, Tools, Draw, Dimension, Modify, Window, Help and Express.

" THEEE

o 20 Drafting - =

5| Edit View Insert Format Tools Draw Dimepsion Modify Window Help Express

Insert

S DO

Line Polyline Circle Arc

Annotation 30 Layout View

&rmove T Revolve == Trim ~ J S 2 g ¥ g 8 @ =
Wcopy MiMiror [ Filet -3, |7 <L WO -
[3 Extrude :| Scale & é? Q @ @ g a g

Manage Export  Help  Express

EE Array

Menus and Shortcut Menus

20 Edit

You can use any of the option on the Menus from the menu bar at the top of the drawing
area. Choose one of the following methods to use a menu:
- On the menu bar, click a menu name to choose the menu or to expand a list of options.
- Press Alt and the key for the underlined letter in the menu name to open the

corresponding menu item list, and then choose menu items from it. For example, to edit
the drawing file, press <Alt+E> to open the Edit menu.

Shortcut menus provide quick access to specific commands. A shortcut menu displays
when you right click an object, status bar, the Model tab name, or a Layout tab name. The selections presented in the shortcut
menu depend on what you clicked.

Shortcuts Customize

existing one.

View Insert Format Tools Draw Dimension Modi
CTRL+Z

- CTRL+Y

% Cut CTRL+X

@ Copy CTRL+C
Copy with Base Point SHIFT+CTRL+C

[Ty Paste CTRL+V

5] Paste as Black SHIFT+CTRL+V

J3]  Paste to Original Coordinates

[ Paste Special...

7 Delete Del

ol Select All CTRL+A
OLE Links..

@, Find...

- 777 == Temporary track point Repeat MOVE
RepeatCRIEESIREIRL - w7 From Recent Input MOVE
-I RsED ' . r;:::x::n 2Foints ) Clipboard CEESIREIUS
L | CIRCLE
o Clipboard 4 20 Osnap 3 e Undo OPTIONS
4 Redo CTRL+Y
&2 Frase 7 Endpoint o TG
& s == e e
Apparent Intersect [ Quick Select..
Bl Scale 2< Bimsn D QuickCale
) Rotate @ [[caie @, Find..
Draw Order 4 & | Quadiant [ oOptions...
i Group © Tangent
Deselect All i :E"’:"“"‘“‘”
[ Quick Select... = MNode
2 QuickCale & il
@, Find.. =
;E P @ Osnap Settings...
rd Shorteuts Customize @1
A faster way to invoke a command is customize its shortcut. The CUSTACC e e —
. . e Copy Clip CTRL4C GCAD
command allows you to customize, delete or modify existing command o e SHETACT G0
shortcuts. To access this command go through the menu bar, under tools, o SR |
X Exit CTRL+Q GCAD
select customize and choose Shortcuts Customize. After that, the shortcut Dypetter TR0
2 open. CTRL+0 GCAD

customize window will pop up. As you can see, there is a list of shortcuts [ B S |
. . Plat... CTRL4P GCAD
command that you can easily modify, delete or even make a new one over an Frowe  cma oo
B g

- i B
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If you want to create a new one, just click the New button and the B == — L]
customize command window will pop up. Then you can search the :m" = 9@:'““: ” — 2
command or select one from the command list. For example, you can mmm §| E"m"’“ ;omm
input “command ling” and then select the requested command. Notice 7 Z“‘?ﬁ“ 10 Gl

that by selecting the requested command, at the right side of the window, | | e S Romoew
will display the command properties. After selecting the command, press ”E%'Tﬁnfmfﬁgggg{vg | -

the OK button.
Then the set shortcut window will pop up. You can T |

input the desire keyword(s). For example, you can o S—

input the number 1. If you want to delete a created g e EE M
shortcut command, invoke the command CUSTACC Comy winBaseF... SHFTACT... GCAD (ode ]

and then select the delete button from the Shortcut
Customize window.

4.- The Ribbon: The ribbon consists of several panels, which are organized into each tab according to their task label. The tools
and controls in each panel are also available in toolbars and dialog boxes.

Insert Annotation ED Layout View Manage Export Help Express Appearance - g X
1 - | 4 Move  TD)Revolve -{Tim - (2 | & % F 8 8B @ Z 2 | @ Weyave M o [ 18 %
/D OIS e & ATTIES 25 —_—
Line  Polyline (vrv(le Avr( . [:X&tmde :ls:a\e EArray & g Q .? § % 8 g TS lﬁr Insert [ = ByLeyer - Mnavsureq’ Pﬂjte é
— Panel Tab Expandable panel Expandable tools button
Tab: The ribbon is structure by tabs. Every tab displays a Hf 'n et
. . . . Standard - 150-25 - EI
series of panels with its own tools (commands or thumbnails) | wee 2= MT M N R ﬁ wmgs
[ ustiy SoEaEESH Gm Cloud

easier to select or pick.

Insert

v - G e

Line Polyline Circle Arc
HnESIERS -

Annotation 3D layout  View Express

@ Move 1) Revolve =f=Trim ~ (2
Bcopy  MhMiror {7 Fillet ~ 3

\ [\ Extrude ©]Scale SSAmay &

Manage  Export

9%@9%9@@

§§§gg

Help

Panel: The panel shows the most used tools. Some

thumbnails has an expandable tools button that can be
expanded in a drop-down method. In addition, most of
panels at home tab have an expandable panel that show up more commands related.

Expandable Panel: The expandable panel is located at the bottom of the panel. If you k
click at the bottom of the panel, more commands related will be displayed. el Sl

ks Extrude Scale Arn
88

Expandable Tools Button: Some thumbnails (tools or commands at the panel) have an expandable
tools button that can be expanded in a drop-down method. If you click this button, all related tools will
be displayed.

Tan, Tan, Radius

000000

Tan, Tan, Tan
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b.- Appearance: You can manage the interface’s theme plus show/display toolbars, menu bar, file tabs and status bar.

Windows 7

Office 2007 Blue

Appearance ~ [ [5] [

o--e U @ %
o 7 7|
o Paste 4 gl Menu Bar
Utilities Clipboard v || File Tabs
El Status Bar

B1 B2
Ly [

TFEY  TFEEA e —\/F4 Z2XX
5 X @,@

Y

= =

+ '\ Model (Layoutl / Layoutd |/

d:_COMMANDLINE

7.- Toolbars: Toolbars partially contain buttons that start commands. When you move your mouse or pointing device over a

toolbar button, the tooltip displays the name of the button.

@ L - R GstarCAD Classic  ~ [ GstarCADS Professional - [Drawingl.dwg]

File Edit View Insert Format Tools Draw Dimension Modify Window Help Express

D HoEEbDRIT e » HOOOFRED DN Smm -
vﬁygrﬁimw v — Bylayer

Drawingl.dwg

[I!“'I‘Syf!,& HE AN MO+ EE RS G 15025 - 2
[ B oo o @l
| LEFEEY

D0TOEMNIOCL NN
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The Standard toolbar at the top of the drawing area contains commonly used commands such as Copy Pan and Zoom, as well
as Microsoft Office standard commands such as New, Open, and Save. GstarCADS8 classic workspace initially displays several
toolbars by default:

- Draw toolbar | FEEEEYEERI Y E SR e LY LYo
- Draw order toolbar [ sorcad T4 o B

- Change toolbar = 1o om0 -Bgapj

- Properties toolbar FLEET T b o g

- Layer toolbar lrr 208/ 00ro0d= - AHmAR

- Style toolbar feereme0lll OB +7 7 &f

- Standard toolbar

Displaying and Hiding Toolbars

GstarCADS8 provides many toolbars, which you can show or hide in both classic and ribbon interfaces. You can also move and
dock toolbars. To choose which toolbars to display:

1.- Execute TOOLBAR command or select the option TOOLBARS from the drop-down list under Appearance button (at top right
of the interface) to open the Toolbar dialog box.

2.- Choose the toolbars you want to hide or display by checking/unchecking the small boxes in the dialog box, then click OK.

colBar 3l e ; . A
o E20cE83hhdzs e -~ -4a00%2E 9 Of
?-Z:om it Ey Standard - £ 15025 -B
[insert
[ Layout 1 —
Borwon 3 fle 2% om0 -2 % e @Of
Lm;:mes A
V|
o [ meyiayer « —Bylayer « —Bylayer -
Closhap
Sl Il -ocErGorocdn - @auo Al
[~ Render
Modeline " " Er—
“aatans BeRA&B 40N~ C1f127 7 &
[ Standard Annotation
] Standard S
[ %= uf

To make floated a horizontal docked toolbar, just click and hold the 1 Drawing2.dwg %

left side of it and drag around the place you need. i/ /205 @0rcodam - @B Al
Hao  sendae - & 15025 -

To make floated a vertical docked toolbar, just click and hold the top k PR =T N X Y

"4 DrawingZdwg X

of it and drag around. To dock any toolbar, just double-click at the left 5

side of it. =

Starting Commands Using Toolbars

4 ingZdwg X

—1 Revision Cloud i

To start a command from a toolbar, click a command button and

/A 2087 QRlroode - @Al
»
respond to the prompts. L4
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8.- User Coordinate System (UCS): The icon indicates the orientation of the drawing in two dimensional space.

>POH

e

|

M 4 » » 4 Model / Layoutl / Layout2

9.- Model Space and Layout Space tabs: Click a tab to switch between the drawing of your model and a printed layout.

< AREASUM SAMPLE FOR DEMO.dwg 4 AREASUM SAMPLE FOR DEMO.dwg

Baseball Field
Area summatory

Baseball Field
Area summatory

4 4 b bl |,Model | Layoutl W 4 v ¥ " Model |,Layout1]

10.- Command Window: The command bar is a dockable window in which you can type commands and view prompts and
other program messages. You can move the command bar by dragging it.

When the command bar is floating, you can drag the top or bottom of the window to change the number of lines of text it
displays. You can dock the command bar at the top or bottom of the drawing.

. H 4 » ¥ % Model / Layoutl 4 Layout2

X |Specify first point:

1 |Specify next point or [Undo]:

\Specify nest point or [Undo]:"Cancel®
Command:

19166.6755, 1915.7656, 0 SNAP  GR ORTHO [xelEGEN OSHNAP EReI

Command Line X
Command: Specify opposite comer: ~
Command: Specify opposite comer:

Command: CUIUNLOAD

Command: CUIUNLOAD |
Command: CUSTACC A
Command:

A
Command: < [l »
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Enter Commands on the Command Line

Type the full command on the command line and press ENTER or
SPACEBAR, or right-click your pointing device to start the command.

Some commands also have abbreviated names (aliases).

Specify Command Options

Once you have entered a command on the command line,
it displays a set of options or a dialog box. To choose a
different option, enter one of the options in the brackets
(either uppercase or lowercase letter is OK), and then
press ENTER or SPACEBAR

Execute, Repeat and Cancel Commands

Command: circle 1
\Specify center point for circle or [3P /2P /Ttr/Arc/Multiple]:'osnap
=>Resuming CIRCLE command.

'Specify center point for circle or [3P/2P/Ttr/Arc/Multiple] Cancel* [ |
Command: Cancel” -
t:ommanq: SPLINE | < y

pecify center point for circle or [3P/2P/Tir/Arc/Multiple]-'osnap
=>Resuming CIRCLE command.
pecify center point for circle or [3P/2P/Tir/Arc/Multiple]: "Cancel™
mmand: “Cancel®
mmand: SPLINE

[Specify first point o [Object]: O |

To execute commands, press SPACEBAR or ENTER, or right-click your pointing device when the command names has been
entered or responsive to prompts. If you want to repeat a command that you have just used, press ENTER or SPACEBAR. To

cancel a command in progress, press ESC.

Nesting a Command

To use a command inside an active command, type an apostrophe before you type the command. For example, you turn on the
object snap while you are drawing a circle, thus you can setup Object snap mode before continuing drawing.

Command: circle > Specify center point for circle or [3P/2P/Tir (tan tan radius)]: 'osnap

(Setup object snap mode as Center in Draft Settings dialog, and then close the dialog to go on performing CIRCLE command)

Command Line

Command: Cancel™

Command: &

ERASE

Select object: Specify opposite comer: 1found

Select object:

Command: CIRCLE

Specify center point for circle or [3P/2P/Tir/Arc/Multiple] OSNAP
>

{F Drafting Settings ‘_XZ N
| Snap and GRid I Polar Tracking ‘ Object Snap | Dynamic Inputl
Object Snap On (F3) [ Object Snap Tracking On (F11)

Ohbiject Snap modes
O Endpoirt 0 [T ingertion Select All
A [T Midpoint b [] Pependicular
] Center el [ Tangent
& [] Node = [] Nearest
&[] Quadrant [ Apparent intersection
* Intersection P [] Paralel
- Exension

10
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Enter System Variables on the Command Line e x

Command: *Cancel* -
Command: “Cancel™
System variables are available for controlling how certain [ommene: Zoneer
. Command: “Cancel™
commands work. For example, GRIDMODE is used to control the  fcommand: <cancer* o
Command: GRIDMODE -

grid status ON or OFF. Enter new valus for GRIDMODE <0>: 1 AL

Using the Prompt History Window

{F gead Text Window =B R

Edit
The Prompt History window displays a history of the commands e e vabe for GHIDMODE <001
and prompts issued since you started the current session of S——

GRIDMODE
GstarCAD. Command: GRIDMODE

Enter new value for GRIDMODE <0 cirCancel™
To display or close the Prompt History window press F2. (Command: “Cancel”

Command: circle

Specify center poirt for circle or [3P/2P/Tir/ Arc/Multiple]: F
To view entries in the Prompt History window, just drag the scroll ot or cption keyword recured. U
bars or use the Up (1) and Down () arrows to display previously | Fesremrmrr e e,

used commands. Commard: =L

Switch Dialog Boxes and Command Line

If you enter LINETYPE on the command line, the Linetype Manager dialog box will pop up. Entering -LINETYPE on the
command line displays the equivalent command line options. The system variables below affect the display of dialog boxes as
well:

-ATTDIA controls whether INSERT uses a dialog box for attribute value entry.

-EXPERT controls whether certain warning dialog boxes are displayed.

-FILEDIA controls the display of dialog boxes used with commands that read and write files. For example, if FILEDIA is setto 1,
OPEN displays the Open Drawing As dialog box. If FILEDIA is set to 0, OPEN displays prompts on the command line. Even
when you set FILEDIA to 0, you can get a file dialog box displayed through entering a tilde (—~) at the first prompt.

Dynamic Input

"Dynamic input" box is a floating window which appears near the +
Cross cursor. It provides a convenient method for users to input L —
commands or system variables dynamically and display the index yégﬁgﬁﬁw [
information. When the DYN mode is turned on, a drop-down box [HGHTLETELOSE 7
will appear near the cross cursor. SNAP__GRID _ ORTHO OTRACK _ LWEIGHT

11



Chapter 2_Starting up GstarCAD8

11.- Status Bar: Display information such as the current cursor coordinates, Snap, Grid, Ortho, Polar, Osnap, Otrack and other
settings. In addition to displaying information, the status bar is a quick way to access many features. You can click status bar
items to make changes, and right click items to display short cut menus that allow you more choices. By default, the status bar
is shown as the picture below:

v COORDS{F6)
v SMAP(F3)
v | GRID(FT)
¥ | ORTHO(F8)
v v POLAR(F10)
v OSNAP(F3)
e v OTRACK(F11)
v LWEIGHT
1 4 » v Model A Layoutl 4 Layout2 v DYNFL2)
3 |[DynBlock] RegisterServer. Access is denied. v | Model/Paper
1 Command
Command: _TIPOFDAY Tray Settings..]

snap GRID  ortHo IEWYM IR OTRACK  LWEIGHT moDeL ||

, 504,206, 0

12.- Properties Palette: You can modify the value or properties of object(s) you wanted in each column. The Properties palette
shows all properties of the specified object. When selecting multiple objects, the Properties palette shows the command
properties of the selected objects. If none of the object is selected, the Properties palette displays the general properties of the
current layer, View properties as well as the UCS information. By default, double-click an object opens Properties palette if the
Properties palette is hidden. This operation is not available when the objects are block, hatch pattern, text, multiline, external
reference or gradient fill.

Properties & %4  BEARING DRAWING.dwg

lHalch V] |+|£MW‘

General o
Calor W Color 150
Layer 0
Linetype — Bylayer
Linetype scale |1
Plot Style BYCOLOR
Lineweight — Bylayer B 1 B 2 B 3

Hypedink:

o A e el
Type Predefined &L

Pattem name | ANSI31

Angle 0 -ttt -+t —_—t -ttt —fF——
Scale 25

Origin X 0 —S

Spacing 25 [ - T

I1SO pen width | 0.13mm

Double No

Associative No N

Island detectio .. | Normal
Annotative No
Geometry hd v
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Customize the Drawing Environment

In GstarCAD8 there are different elements of the working environment that can be customized to fit your needs.
Set Interface Options

In the Options dialog box, you can change many of the settings that affect the interface and drawing environment.

Cument profile: <<lnnamed Profile> ﬁ Current drawing: Drawing1.dwg

Display | Open and Save | User Preferences | Draw | Selection set [ Profiles |

Window Elements Display resolution

ropemnce  [Diiee 2007 Base & 1000 Aeend cicle smodthness

n 8 Segments in a pohline curve
Display gcroll bars in drawing window & os Rendered obiect smoothness
Show ToolTips a 4 Contour lines per suface
Display performance
[ Colors... ] [ Pan and zoom with raster & OLE

a Highlight raster image frame only
& [¥] Apply solid fil

[ Eoghee ] o) [7] Show text boundary frame only
7] Draw true sibhousttes for solids and surfaces
Layout clemert Crosshair size
ements
Display Layout and Mode! tabs 5
Display printable area Fade control
Display paper background Xoef display
Display paper shadow Ll : D
[ Show Page Setup Manager for new layouts Inplace edit and annotative representations
Create viewport in new layouts 50

Settings of Modifying Interface:

Automatic Save (Open and Save tab): Save your drawing at specified time intervals. To use this option, in the Options dialog
box, Open and Save tab, select Automatic Save and enter the interval in minutes.

Cument profile: <<Unnamed Profile>» a Cumrent drawing: Drawing1.dwg

| File | Display | Open and Save]!| User Preferences | Draw | Selection set | Profiles |

File Save File Open
Save as: 9 MNumber of recenthy-used files
AutoCAD 2010(LT2010) Drawing("dwg)  ~| [ Display fullpath in tle
Maintain visual fidelity for annotative obje: Application Menu
Maintain drawing size compatibili
@ - z ity 5 MNumber of recently-used files
[ Thumbnail Preview Settings... ]
50 Incremental save percentage Yrefs
Demand load Xrefs:
File Safety Precautions
[Enable -
Automatic save
10 e i) Retain changes to Xref layers
Create backup copy with each save a Allow other users to Refedit cument dawing
[ Full4ime CRC validation
GRX Applications
ac$ File extension for temporary files Proxy images for custom objects:

[Show prowy rapics .

Display digital signature information

[ ok ][ Ccancel Apply Help
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Color (Display tab): Specify the background colors used in Search Path (Files tab): Set the search path to find drawing
the layout and Model tabs and the color used for prompts support files such as text fonts, drawings, linetypes, and
and crosshair. hatch patterns.

Font (Display tab): Change the fonts used in the window

and in the text window. This setting does not affect the text (G omiors

m yOUF draWIﬂgS Current profile: <¢Unnamed Profile>> & Cument drawing:
File || Display I Open and Save I User Preferences I Draw I Selection set I F'roﬂlesl

= Search paths, file names, and file locations:
Options
— 22 THRRREREREREREREEHEHH—————w—" =5 @ Support File Search Path -

Currert profile: <<Unnamed Profile>> = Clsers\asus\AppData\ Roaming'G S TARSOFTVGSTARCADR13.0MEN
[Fie rmi Open and Save | User Preferences | D g FAGSTARCAD 8 BETA\GE\SUPPORT
~mp FAGSTARCAD 8 BETA\GB\FONTS
Window Blements | = FAGSTARCAD 8 BETA'GE\HELP
- wp CProgram Files (x86)\Gstarsoft\GstarCADB" \ExtendCmd
Appearance [Oﬁice 2007 Black v] % Woarking Support File Search Path 3

ﬁ Customization Files

ﬁ Help and Miscellansous File Names

ﬁ Text Editor, Dictionary. and Fort File Names

ﬁ Print File, Spoaler, and Prolog Section Names

ﬁ Printer Support File Path =

’ Colors... ] % Automatic Save File Location
% Color Book Locations

ﬁ Template Settings

[ Forts. .. ] [, Tool Palettes File Locations -
4 [ 3

Display scroll bars in drawing window

Show ToolTips

Save and Restore Profiles

Creating profiles for different users or projects and sharing profiles by importing and exporting profile files are enabled in
GstarCADS. By default, your current options are stored in a profile named Default. The current profile name, as well as the
current drawing name, is displayed in the Options dialog box.

Current profile: <cUnnamed Profiles> E) Curent drawing Drawing1.dwg

| Fie | Display | Open and Save | User Preferences | Draw | Selection set | Profiies
Avalable profikes Export Profile
<<Unnamed Profle>>
Dialogs = Savein: | Suppott - @F o
| [ Addtolim - - -
@ Add Profile = . authorpalette
Recent Places
New DWG PJ Workstation | J. Teons
Export L . MenuFiles
Descrption = Deskiop totalet
Classified Project Engineering| ! toolpalette
=
Libraries
o >
Computer
-
i | @ . ,
Network
File name: DWG PJ Classfied Enginesring - Save
‘ Save astype Corfiguration Fie{~ARG) <[ Cenesl |
oK | [ Cancel Apply Help

GstarCADS stores the profile information in the system registry and saves it as a text file (an ARG file) and also organizes
essential data and maintains changes in the registry as required.

If you make changes to your current profile during a session and you want to save those changes in the ARG file, you must
export the profile. When you export the profile with the current profile name, GstarCAD updates the ARG file with the new
settings. You can re-import the profile into GstarCAD8 to update your profile settings.

14
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Tool Palettes

Tool palettes are tabbed areas within the Tool Palettes window. The items you add to a tool palette are

called tools. You can create a tool by dragging an object onto the tool palette. In GstarCAD, blocks and ;ﬂmﬂ B
external references (xrefs) can be dragged onto the tool palette. The new tool inserted will has the same 2]
properties into your drawing. Also you can create, delete, rename and customize panels by doing right ﬁ &
click on it. To open the tool palettes just press CTRL+3 or Type TOOLPALETTES command. ;
i Hanjd(
I oo
View Options... = Refgerator(
e |
Rename Paete P~

Customize Commands...

Design Center
With Design Center, you can organize access to drawings, blocks, text styles and other drawing contents:

-Browse for drawing content on your computer or a networked drive.

-View definition tables for named objects and then insert, attach, copy and paste the definitions into the current drawing.
-Create shortcuts to drawings and folders that you access frequently.

-Add content such as xrefs, blocks to a drawing.

-Drag drawings, blocks to a tool palette for convenient access

Folders Tab: The following icons are displayed in this tab: networks and computers, computer drives, folders, drawings and

related support files, Xrefs, layouts and named objects, including blocks, layers, linetypes, text styles and dimension styles
within a drawing.

Open Drawings: A list of currently opened
drawings is displayed. If you click a drawing | pesees xSy i & =+ [T
. . Y { - Librarie: Dimension Layout Block Layer XREF
file and then click one of the definition tables, |3 Homegrous Sile
. a

you can load the content into the content area. | computer A e

. . . . . 1€ Network
History: A list of previously opened files is &5 Cortrol Panel Text Syfe  Linetype

. . . . Govemor of Poker
displayed. If you double-click a drawing file NetSethan

. . PHOTOSHOP CS5E
from the list, you can load the content into the | &] for help documentation dwg
- & sample.dwg

COﬂtem area. windows_7_basic_black_theme_by_:

Favorites: If you have contents need to access quickly on a regular basis, the Design Center provides a solution to finding those.
When you select any type of content, you can right-click and choose to add it to Favorites. In favorite folder you can save
shortcuts to content on local drives, a network drives. The original file or folder doesn't move; but all shortcuts you create are
stored in the Favorites folder.
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Create, Open, Save and Recover a Drawing

Create a Drawing
Create a New Drawing Using Default Settings
When the system variables FILEDIA and STARTUP are set to 1, typing NEW &0 4N | Default Settings
at the command bar, it opens Startup dialog box, from which you can use Defact Setings
Default Setting, Template or Wizard to create a new drawing. © ImperalFest and Inches)
@) Metric
You can select either imperial or metric units for the new drawing. mem =

Prompt Info
Uses the default metric settings.

Imperial measurement system: The drawing uses internal default values
with default boundary is 12 x 9 inches. =

Metric measurement system: The drawing uses internal default values with default boundary is 429 x 297 millimeters.

'd Startup @1
Create a New Drawing Using a Setup Wizard @ | O Use a Wizard
Select a Wizard:

From the Startup dialog box, you can select "Use a Wizard" tab to create a new Qs |
drawing by the wizard. There are two wizard options illuminated as follows: j

Wizard Description

Set the units, angle, angle measure. angle direction, and area for your new

drawing. Based on the template gcadiso dwt

Advanced Setup Wizard:

From this option, you can set units of measurement, precision of displayed units, and grid limits. Also specify angle settings
such as units of measurement style, precision, direction, and origntation based on template gcadiso.dwt.

wasw T
[ — o ]
Par— : A5 [
— '
fnghs Douition ﬁ! Arge Drection .
@ Advanced Setup =% —
Unts Seiect e ande of meas.nerment ard he precidon fr e st youwant o epsesert ik
m i " Ful scal unts, Eampe: 10 draw i an
et ® Decind Dagres | area 12x S metrs, ke 12 urer Vit o 9uncer
Length.
Ioge Meanre Deg/Mi/Sec .\ )
Angle Drection Grads. = ¥
oo Taton "IN = 297000
Suveyor 4
Precision
0
) [ ) [ b | [ ] [omet |

Quick Setup Wizard: From this option, you can specify units of measurement, precision of displayed units, and grid limits
based on template gcadiso.dwt.
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Create a New Drawing Using Template

@ sorn =
When you need to create several drawings with the default settings, you can gg@ e

save time by creating a template file designed to create the same drawing files

so that you does not need to specify default settings each time you start.

Conventions and settings commonly stored in template files include: unit type =

and precision, title blocks, borders, and logos, layer names, snap, grid, and e

ortho settings, grid limits, dimension styles, text styles and Linetypes.

Also when the system variables FILEDIA and STARTUP are set to 1 and 0 separately, typing NEW opens Select Template dialog
box, from which you can select the desired one or use the default template by clicking the arrowhead button next to the Open
button.

Select Template ]
(B —————————————————————————————————————— |
| Lookin: |, Template - @3 E i

- Name Date modf.. Type Size Ret=Ts
= ol geadiso 5/21/2013 ... _AutoCAD Template 81 KB

Recent Places i gcad 5/21/2013 ... AutoCAD Template 82 KB

Desktop

=
Libraries
Computer
=
A
Netwark
File pame: goadisa - Qpen |+
Files of type: Drawing Template{" cwi) - [ Canea |

Open a Drawing

Open a Drawmg Edit View Insert Format Tools Draw Dimension Modify Window Help Express
w Manage Export Help Express
You can open drawing (.dwg) files, Drawing Exchange e
. . . Import...
Format (.dxf) files and drawing template (.dwt) files. You can st
also open and check drawings that you suspect are EHE= CTRL+S
Save As... SHIFT+CTRL+S
damaged. @ Epor.
& cTansmit...
To open an existing drawing:  File > Open Command line> OPEN Using shortcut> CTRL+0
-In the dialog box, choose the type of file you want to open. q s ===
-Choose the folder containing the desired file. Do oo
. . ’;} & DCK1 10/9/2004 6:56 Piz.. DWG File 4148 KB
-Choose the drawing you want to open, and then click the Recntlces i pcxz i
. . B ST vmmmesn owere  aoee
Open button or Double click on the drawing you want to bee  @wotome:  vmmmears were oG
open = =
' e
LY
Remark: If the drawing requires a password, enter the @
. . . o Fie pame: DCKI - Qpen |+
password, click OK to verify the password, and then click . s =
Open again. T an
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Chapter 3 Create, Open, Save and Recover a Drawing

Multiple Open Drawings
You can open multiple drawings at one time. There are several methods for switching a drawing to another.

- Acting the drawing by clicking it or using shortcut keys of <Ctrl+Tab>.
-You can change the display styles to Cascade, Title Vertically or Title Horizontally from the Window menu. You can also use
Arrange Icons to align icons if there are several minimum drawings.

Remark: The document switch preview function is only available after you opened three or more drawings.

- NN =EE > - 2D Drafting M - GstarCADB Professional - [MECHANICAL DRAWING.dwg]
File Edit View Insert Format Tools Draw Dimension Modify O] Help Express

Home  Inset  Annotation 3D  layout  View  Manage]BENELES

4 ALIGN TOOL.dwg . AREASUM SAMPLE FOR DEMO.dwg . BEARING DRAWIN| B Close All g MECHANICAL DRAWING.dwg <
IR Cascade
= Tile Horizontally
[0 Tile vertically
og

4 3| gn Amangelcons 2 | 1
T O
Window... e e e
D D
2

e ‘

Save a Drawing

Save a Drawing

You save drawing files for later use. You can also set up automatic saving and backup files and save only selected objects. In
addition, you can also save a drawing in a Drawing Exchange Format (.dxf) file or a drawing template (.dwt) file. If you created
your drawing using a template, saving the drawing does not alter the original template.

To save a drawing:  File > Save Command line> SAVE Using shortcut> CTRL+S
[Ef) Edit View Inset Format Jools Draw Dimension Modify Window Help Express
W Manage Export Help Express
4 Dra 25 Open.. CTRL+O

FJ Close

Import...

Attach...
[E]  save CTRL+5]
Save As... SHIFT+CTRL+S
@ Export.
& eTransmit...
[@ send..
[E Page Setup Manager...
ity Plotter Manager...
i Plot Style Manager...
5 Plot Preview
£ Plot. CTRL+P

Remark: When you save a drawing the first time, the program displays the Save Drawing As dialog box so that you can choose a
directory and type a name for the drawing.
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Chapter 3 Create, Open, Save and Recover a Drawing

Save Your Drawing Automatically

You can specify to save drawing files automatically in order to minimize the lost data onc
problem occurs.

If you start the automatic save option, your drawing is saved at specified time intervals. By
default, system assigned the name filename.ac$ for temporarily saved files, filename here

refers to current drawing name.

@ Options

Current profile: Dialogs

€a

File Display | Open and Save || User Preferences

File Save
Saveas

[AutoCAD 20100LT2010) Drawing(“dwg)  ~|

Maintain visual fidelity for annotative obje:
Maintzin drawing size compatibility

[ Thumbnail Freview Seftings... |

50 Incremental save percentage

File Safety Precautions
Automatic save
10 Minutes between saves

Create backup copy with each save
[ Fulltime CRC validation

acs File extension for temporary files
. . 'a rite Bloch lﬁq
Save Part of a Drawing File SW =
Block:
Entirs dfawing
You can use BLOCK command or WBLOCK command to create a new drawing from | °2= o
part of an existing drawing. You can select entities or a block definition in your Gy [fes ot B st e B
x 0 g-ﬂaam
current drawing and save them in a new drawing file. The description also can be ¥ e
saved in the new drawing. 20 &) Nocopt sl
Destination
File name and path:
C\New Block - D
Inserturits: | Milmeter -
[ ok J[ cancel |[ hHep |

Save to a Different Type of Drawing File

| Savein Suppott - 0 mE-
Choose the format from Save as Type in the Save B Neme
L authorpalette
Drawing As dialog box, you can save a drawing to i il
. . , | MeniFies
an earlier version of the drawing format (DWG) or Do | roopalete
. . e &) Drawing3
drawing interchange format (DXF), or save a =
drawing as a template file. ¥
Computer
T different format; N@k - ‘ :
0 save a direrent rormat: e Flle ame: SAMPLE DRAWING FORMAT -
Save as type. AutoCAD 2010(LT2010) Drawing(".dwg) e Cancel
File > Save As  Command line> SAVE AS AasCih T30 brownat v

AutoCAD 2004(LT2004) Drawing(".
AutoCAD 2000(LT2000) Drawing(".

Using shortcut> SHIFT+CTRL+S AASEAD Dok S E oy )

AutoCAD Drawing Template{"dint)
AutoCAD 2013 DXF(" )
AutoCAD 2010 DXF(" )
AutoCAD 2007(L T2007) DXF("bd)

AutoCAD R12(LT2) DXF(" cbd)

dwg)
dwa)

Use Backup Files

GstarCADS creates a backup file with the current drawing name and a ".bak" extension to save the previous version of the

current drawing when launching "backup automatically" option.
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Chapter 3 Create, Open, Save and Recover a Drawing

Reduce the Time Required to Save a Drawing File

In order to reduce the time of saving a drawing file, you can specify the incremental save
percentage on the Open and Save tab of Options dialog box or from the ISAVEPERCENT system
variable.

The incremental save updates only the portions of the saved drawing file you changed. Drawing
files will contain a percentage of potentially wasted space when you use incremental saves.
This percentage increases after each incremental save until it reaches the specified maximum
value, and then a full save is perform.

Recover a Drawing

Recover a Damaged File

You can recover some or all of data by reverting to a backup file or using commands to find and
correct errors if a drawing file is damaged. A drawing file may be damaged by a hardware
failure, power outage and system crash. You had better create a backup file if the drawing is
important.

On the Open and Save tab of Options dialog box, you can specify the backup file are created
when you save drawings and set the proper interval time for saving. Then a backup copy file
with a ".bak" extension is created when you save the named drawing once again. After that, a
backup file is always updated while you executing the command SAVE or SAVEAS.

You can use RECOVER command to check and attempt to open a damage file.
Then uses AUDIT command to find and correct errors.

To open a damaged file:  File > Drawing Utilities> Recover

Edit View Insert Format Tools Draw Dimension Modify Window Help Express

7
{ Options

Cument profile:
File Display |- Open and Save § User Preferences

File Save
Saveas:
[AutoCAD 2010(LT2010) Drawing(“dwa) | ~|

Dialogs

Maintain visual fidelity for annotative obje:
Maintain drawing size compatibility

[ Thumbnail Preview Settings |

50 Incremental save percentage

File Safety Precautions
Automatic save
10 Minutes between saves

Create backup copy with each save
[] Fulltime CRC validation

ack File extension for temporary files

@ Options

Currert profile

Dialogs

[ File [ Display || Open and Save :user Preferences

File Save
Save as
[AutoCAD 2010(L.T2010) Drawing{"dwa) |

Maintain visual fidelty for annotative objer
Maintain drawing size compatibility

[ Thumbnail Preview Settings ]

50 Incremertal save percentage

File Safety Precavtions
[¥] Automatic save
10 Minues between saves

[¥] Create backup copy with sach save
[7] Fulltime CRC validation

Command line> RECOVER

acs File extension for temporary files

Drawing Utilities v | d Audit
[ Drawing Properties... E Recover...
Drawing History 4% Drawing Recovery Manager...
) Exit CTRL+Q Update Block Icons
| [E  Purge..
-In the dialog box at Files of Type, choose the type of s I

file you want to recover. &G
-Choose the directory containing the damaged file.

ReceslRiacey DWG FOR THE SALES STAFF AND CUSTOMERS

- OF e E

. Preview:

- DXF MAPS
LHAZ13
-Choose the damaged file you want to recover and R
Click the Open button or Double click on the drawing Li Egﬁ%&}”:fgg;;xgmoﬂggmo _T
. |&] BATPURGE SAMPLE

you want to open.

|&] BEARING DRAWING
|&] BEARING DRAWING 1 4317.5v§

8
‘.5 &l CHANGE TEXT
<[ m

Network

Computer

File pame: AREASUM SAMPLE FOR DEMO

Fies of type: [ Drawing" dwg)

[ cancel |
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Chapter 3 Create, Open, Save and Recover a Drawing

To check errors for a drawing file:  File > Drawing Utilities> Audit Command line> Audit

Edit View Insert Format Tools Draw Dimension Modify Window Help Express

B New. (G, Manage Export  Help Ex
% Open.. CTRL+0  [ARING DRAWING.dwg  LAYOUTBYPATH SAMPI
FJ Close

Import...

Attach...
[ save CTRL+S Model /T, A 5
Save As... SHIFT+ CTRL+S M 4« ¥ Model ; Layou ayou

s—

@ Eport. 3 Command: AUDIT
P e — p [Fix any emors detected? [Yes/No] <N=:Y
@ send 120165 objects audited
- Total emors found during audit 0, fixed 0
[F Page Setup Manager...
ity Plotter Manager... Command:
Dt oo0
L Plot Preview
Z  Plot.. CTRL+P
£ Publish...

Drawing Utilities v O Audit
Drawing Properties... JBl Recover...

Drawing History 4 Drawing Recovery Manager..
® Edit CTRL+Q Update Block Icons

B Purge..

1. To choose from the opened drawing, click on File > Drawing Utilities > Audit
2. InputY or N to determine whether to recover the errors that are automatically found by GstarCAD, and then press Enter.

Drawing Recovery Manager

Once terminated by hardware problems, power failure or software problems, the application is capable of backup the opened
drawing file. At the next startup, the program starts "Drawing Recovery Manager" in which all of the auto-backup drawing files
that have been closed accidentally will be displayed. You can open the file of your demand by double clicking at the Backup
File list on the "Drawing Recovery", if there is any damage to the file, system attempts to recover the drawing in process of
backup.

When program or system stopped by accident, the drawing files need to recover are sorted into the following types.

Drawing Recovery Manager x
Skip to automatic save file local

-Recovered drawing file saved when program fails (DWG)
-Auto saved file, so called "auto-save" file (ac$)

“Backup file (BAK) = B socs2s e
-Source drawing file (DWG) s

IFie Bama BLODKE 2
\Aushssie Flle BLOCKS 2_1_S538 315

|Last Save Tima: 2913 yaor § moni  day 195752
A L0 Zaws

[Last Sawve Timar 2013 year monm 28 sy 13117

Preview: ¥
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Chapter 4 Control the Drawing Views

Control the Drawing Views

Redraw and Regenerate a Drawing

As you work on a drawing, visual elements may remain after the completion of a command. You can remove these elements by
refreshing, or redrawing, the display.

To redraw (refresh) the current window display:  View > Redraw Command line> REDRAW

To regenerate the current window: View > Regen Command line> REGEN

File Edit BUTY Inset Format Tools Draw Dimension Modify Window Help Express

JOENS ~  Redraw i Manage Export Help
5N TOOL.db

Regen

B Regen Al
Zoom
Pan

Orbit

Viewports
B Named Views.

3D Views

% (7 Hide
% Visual Styles
\ Render

Display
= Toolbars.
o

~n ' Model /{Layoutl /Layout2

Information about drawing entities is stored in a database as floating point values, ensuring a high level of precision.
Sometimes a drawing must be recalculated, or regenerated, from the floating point database to convert those values to the
appropriate screen coordinates.

Magnify a View (Zoom)
ViR Insert Format Tools Draw Dimension Modify Window Help Express
«#  Redraw hut View Manage Export Help Express
. Regen Jdwg  BEARING DRAWING.dwg LAYOUTBYPATH SAMPLEdwg
You can use ZOOM command to zoom in or zoom out the e T R/ . T 2 F ] i_ '
drawing view to meet your need. You can change the e » @, Realtime s i | ¢ |
magnification of your drawing at any time. The cursor - : & prees e/
indow kA
changes to a magnifying glass when a zoom tool is active. Viewports » @ Dynamic f
- . [& Named Views... (@], Scale
Zoom out to reduce the magnification so you can see more — ' @ Ccenter /
of the drawing, or zoom in to increase the magnification so |7 wide @ |Otea g
i L . Visual Styles Y B, ¥
you can see a portion of the drawing in greater detail. Render v @ ou
Display v @ AN
. . . BT Toolbars... @ Extents b A 1
Remark: If you are working in a layout viewport and cannot | ©0

zoom, the layout viewport may be locked. The scale and view do not change in model space while panning or zooming in a
locked layout viewport.
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Chapter 4 Control the Drawing Views

Zooming Methods

To zoom, you can use any of the following methods:

-To define the portion of the drawing to zoom, create a window.

-To zoom in real time, use the Zoom Realtime tool on the Standard toolbar.

-If you have a mouse with a wheel, rotate the wheel to zoom in and out.

Zoom to Magnify a Specified Rectangular Area

You can specify a rectangular area defined by two corners to display the objects within that area as large as possibly.
The lower-left corner of the specified area becomes the lower-left corner of the new view.

To zoom in to an area using a window:  View > Zoom> Window Command line> Z0OOM

-Choose View > Zoom > Window
-Select one corner of the window around the area you want to magnify.

-Specify the opposite corner of the window around the area you want to magnify.

P Insert Format Tools Draw Dimension Modify Window Help Express

7 Redraw ut  View  Manage  Export  Help  Express
Regen DRAWING, dwg
T Regen Al

Zoom » Realtime
Pan »

Orbit »

Previous
Window
Dynamic

Scale

Viewports ,
& Named Views..

3D Views

(7 Hide

Visual Styles

Center
Object

Render

Display
G Toolbars.

2L LD PRPRPOE O

Zoom in Real Time

Realtime option zooms dynamically by moving your pointing device up or
down. By right-clicking, you can display a shortcut menu with additional
viewing options.

To zoom in real time:  View > Zoom>Realtime
Command line> RTZOOM

-Choose View > Zoom > Realtime from the main menu.
-Hold the left mouse button, then drag the cursor forward to zoom in and
move back to zoom out.

File Edit View Insert Fomat Jools Draw Dimension Modify Window Help Expres

Home  Inset  Annotation 3D Layout Manage Export  Help

LAYOUTBYPATH SAMPLEdwg > MECHANICAL DRAWING.dwg

G ———— — — ————
— o o o =

Insert Fomat Tools Draw n Modify Window Help Express
7 Redraw Manage  Export  Help  Express
Regen
5 Regen All
Zoom » | Realtime ,
3 !
Pan @ Previous
»
Orbit @, Window
Viewports »| @ Dynamic {
@ MNamed Views... @ Scale /e
3D Views b | @ Center
A Hide & Object
Visual Styles M@ I
Render v & out
a @ A
) Zoom

. o0 3D Orbit
= Zoom Window

Zoom Original

Zoom EBxtents

23



Chapter 4 Control the Drawing Views

Displaying the Previous View of a Drawing

After you zoom in or pan to view a portion of your drawing in greater detail, you may want to zoom back out to see the entire
drawing. On the View > Zoom menu, the Previous tool lets you restore the previous view. Selecting this tool repeatedly steps
back through up to 25 successive zoomed or panned views.

Zooming to a Specific Scale

You can increase or decrease the magnification of your view by a precise scale factor measured relative to the overall size of
the drawing or in relation to the current display. When you change the magnification factor, the portion of the drawing located at
the center of the current viewport remains centered on the screen.

To zoom to a specific scale relative to the current display:  View > Zoom>Scale Command line> Z0OM

-Choose View > Zoom > Scale from the main menu.

-0n the Zoom toolbar, click the Zoom Scale.

-Type ZOOM in the command line, choose the Scale option, and then press Enter.
-Type the scale factor, followed by an x (such as 2x).

-Press Enter.

Eile Edit View Insert Format Tools Draw Dimepsion Modiy Window Help Express

Tl Insert Format Draw Dimepsion Modify Window Help Express

& Redraw
Regen

T3 Regen Al

Zoom

Tools

Insert  Annotation 3D layout  View  Manage  Export  Help  Express

Lopens  BRen  FEE [EWeE 'OUTBYPATH SAMPLE.dwg MECHANICAL DRAWING. dwg

Realtime
Pan

Orbit

&
] Previous
@, Window
Viewports @ Dynamic
&  Named Views. (@), Scale
3D Views v @ Center
£ Hide @, Object
Visual Styles | @
Render i<y
a
&

In
Out

All
Extents

Display ,

= Toolbars.

14 4 » »l Model / Layoutl /| Layout2

=
firt point as displacement>
mmand: ZOOM

peciy comer of window, enter a scale factor (1X or nXP), or
[AllACerter/Dynamic/ Exterts/Previous/Scale Window/Object] <real time>: SCALE
Enter a scale facter X or nXP): 3

Displaying the Entire Drawing

Z00M Extents option, displays a view that includes all of the objects in the drawing as large as possible. The view can display
the objects on layers that are turned off but do not include objects on frozen layers.

Z00M All option, displays all of objects within either the user-defined limits or the drawing extents, whichever view is larger.

You can use the Zoom All tool on the zoom toolbar to display an entire drawing. The Zoom Extents tool on the zoom toolbar
displays the drawing to its extents, making the image fill the display to the greatest possible magnification.
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Chapter 4 Control the Drawing Views

Pan and View

You can move the drawing in any direction using the pan command. Panning shifts or slides the view of the drawing
horizontally, vertically, or diagonally. The magnification of the drawing remains the same, as does its orientation in space.
The only change is the portion of the drawing displayed. To pan, you can use any of the following methods:

-For precise panning, specify two points defining the magnitude and direction of the pan. The first point indicates the starting
point of the pan. The second point indicates the amount of pan displacement relative to the first point.

-To pan in real time, use the Pan Realtime tool on the Standard toolbar.

-If you have a mouse with a wheel, press and hold the wheel, and then move the mouse.

To panin real time:  View > Pan>Realtime

Command line> PAN

-Choose View > Zoom > Realtime from the main menu.

-Move the cursor in the direction you want to pan.
-To stop panning, press Enter, ESC or choose Exit from the shortcut menu.

To pan using a mouse with a wheel:

-Press and hold the wheel, and then move the mouse in the direction you
want to pan (The MBUTTONPAN system variable controls this feature.)

Display Multiple Views on Model Space

View BUHI ST
@ Redraw

Regen
IE% Regen All

Zoom
Pan

Orbit
Viewports

[& MNamed Views...

3D Views

1) Hide
Visual Styles
Render
Display

G Toolbars..

Tools

Draw Dimension Modify Window Help Expr

Manage

Export

Help

B4 Realtime

Point
Left

Right
Up

When you begin a new drawing, it is displayed in a single window. You can view the drawing in a second window, or you can
divide one window into multiple windows. You can also open and display multiple drawings.

Set Model Space Viewports

The viewports created on the Model tab completely fill the drawing area and do not overlap. As you make changes in one
viewport, the others are updated simultaneously. You can do the following operations at the model space viewport:

-Set Snap, Grid, and UCS icon modes; Pan;
Zoom; and restore named views.

-Save orientations of UCS with individual
viewports.

-When executing a command, you can draw
from one viewport to another.

-Name a viewport arrangement in order to you
can reuse it on the Model tab or insert it on a
layout tab.

-When you work on 3D models, is helpful

setting up different UCS in individual viewports.

P insert Format Tools Draw Dimensi

Regen
£ Regen Al

Zoom

Orbit

Viewports
[ Named Views..
3D Views

Visual Styles
Render

Display
[T Toolbars...

Manage  Export  Help

on Modify Window Help Express

O MNamed Viewports..

L& Mew Viewports...
1 Viewport

2 Viewports
3 Viewports

4 Viewports
4] Polygonal Viewport

£ Object

B lein




Chapter 4 Control the Drawing Views

Working with Multiple Views of a Single Drawing

You can open and work with several views of the same drawing simultaneously. After you divide a single window into multiple

windows, you can control each window separately. For example, you can zoom or pan in one window without affecting the

display in any of the other windows. As you draw, any changes you make in one window are immediately visible in the others.

And also you can switch from one window to another at any time.
To create multiple views:  View > Viewports Command line> VPORTS

-Choose View > Viewports
-In viewports menu, choose 1, 2, 3, or 4 viewports.
-Type h if you want the horizontal orientation, or type v if you want the vertical orientation.

To join two views:  View > Viewports> Join Command line> VPORTS

-Choose View > Viewports > Join
-Click anywhere inside the window you want to keep.
-Click anywhere inside the adjacent window you want to join to the first window.

To restore a named window configuration:

-Type -VPORTS system variable at the command line and press ENTER.
-Then type Restore.
-Then type the name of the window configuration you want to restore.

[P0 Insert Format Tools Draw Dimepsion Modify Window Help Express Viewports.
@ Redraw L Manage Export Help Express New Viewports
Regen } New iame:
T Regen Al —?— .
‘Standard viewports review
Zoom 3 4 El + “Petive Model Configuration™
Single
Pan » ‘ Two: Vertical *Current* *Current¥
Orbit > D e :;’g"};"”‘ﬂ' 20 Wrretrame 20 Wrretrame
Three: Left
- Three: Abe
Viewports » [0 Named Viewports... T o
0 N Three: Vertical
[&' Named Views.. L& NewViewports... | || Three: Horzortal
s L 1 Viewport e “Current* “Current*
- &= o 20 Wreframe 20 Wreframe
Hide 2 Viewports
Visual Styles ’ 3 Viewports
Render 3 4 Viewports = Appiyto Setup: Change viewta Visual Syle
— , | 2] Polygonal Viewport Display. -] [m ~] [Curent ] 2D Wieirame -
7 Object
= Toolbars.. i | e i
B Join ok J[ Concd J[ hep
T —

T2 ] owcz | IR = ] .
T ewer [ woewe [ e | e
e e T s | romea | o
PARTS LS
INIT| APPROVALS | DATE | spPROvALS |DATE GSTARCAD
MXX KOO
i
BMW CHASSIS CLAMP
il ASSEMBLY.
o B2 [P Bunce-10006304 | =
£ s .
L. :
PARTUST
i ] _mwon i ausINGS 3 [ e e B
i 10 BMW-C-10 SHAFT 1 Q3
1 5 | owos SEesraE |1 | s -
o E, § | swos | wunwoseserae | 1 | s [y
| 7 [ ewor THREADED ST | oo et 0
& [ owce BusGE ) i e
=) m 5 BMW-CS 'SUPFORT PLATE 1 STEEL
i 4| mwwos BUSHNG & 1| cema il
I = mom s carsor v 3 | swwos BMW-THREADEDFING | 1 | Qema s [
o 7 [ ower | ewormeoeens | v | com s
x x = T PuATE | e e i
W 4+ "\ Model {Tayoutl

26



Chapter 4 Control the Drawing Views

Working with Multiple Drawings

With the multiple document interface, you can open and work on several drawings at one time, you can copy, cut, or paste an
entity from one drawing to another. Each drawing appears in a drawing window, which has the following advantages: You can
see two or more drawings side by side, and you can easily copy entities from one drawing to another. Under the Window menu,
the following three methods that determine how drawings are arranged are provided for user's choice.

'Cascade y A0 £ ESbe w GstarC onal - ALIGN TOOL dwg
-Tile Horizontally e o e T
-Tile Vertica“y EMECHANICALDRAW{NG‘dwg
a OVERLAPPING SELECTION.dwg
‘1 &) BEARING DRAWING.dwg
B1 B2
s,
% % E‘AuGN'rL.d«g
[ansian Elevation Plan
Layout] "¢y, )i Model /4 Layoutl /] Layout2 | E
-
u‘ v 0 \Medel (a1 /
. & View Manager — — &
View Manager e
Views
, , gk Gt ﬁ m
With the view manager, you can create, set current, update = o Restore Orto UCS
) i ) 3 e e | et Relative to \WORLD
layers, edit boundaries, and deletes named views, and DT Upcate Layer
switch quickly between each views, it is helpful to reduce Ed"i“ .:
Frort Delete
many unnecessary view adjust operation. . fenlil
: SE Isometric
NE |sometric
NW Isometric
Cancel Aopl Help

Specify a 3D View

You can set a 3D view to facilitate verifying the 3D effects of the drawing, constructing and visualizing 3D models. You can
specify a new viewpoint to create new objects or modify the existing objects.

Set the Viewing Direction

You view three dimensional drawings by setting the viewing direction. The viewing direction establishes the viewing position,
When you view a drawing from the default viewpoint (0,0,1), you see a plan view of the drawing. You can change the viewing
direction to look at the drawing from a different vantage point or to work on a three dimensional model from a different
orientation.
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Chapter 4 Control the Drawing Views

To set a new viewing direction: g e =

Set Viewing Angles

View > 3D Views> Viewpoint Presets ~ Command line> DDVPOINT e e

-Choose View > 3D Views > Viewpoint Presets
-Set viewing angles at absolute to WCS and relative to UCS by moving the position of the

needle according to your preference. Then click OK button. e T
[ox | [ caneal | [ nHeb

To display a plan view of the current drawing: View > 3D Views> Plan View Command linge> PLAN

-Choose View > 3D Views > Plan View from the main menu.
-It concludes three plan views: Current UCS, World UCS and Named UCS. Choose one what you want.

=S N=ER RS 22D Drafting B - GstarCADS Professional - [sample.dwg]

FEite Edit WYJ0Y Insert Format Tools Draw Dimension Modify Window Help

Home j /  Redraw hut View Manage Export Help
4 ALGN TOOLd: Regen QUTBYPATH SAMPLE.dwg ~ MECHANICAL DRAWING.dwg  OVERLAPPING SELECTION.dwg  Drawing3.dwg  sampledwg X b
% Regen Al
Zoom »
Pan L3
Orbit 3
Viewparts > @ Viewpoint Presets &’
B Named Views.. T ——
3D Views 4 Viewpoint Presets... ©) Absolute to WCS () Relative to UCS
Plan View 3 Current UCS
(7 Hide
World UCS
Visual Styles 0 Top o
Named UCS
Render [ Bottom TS
ey 0 L 'Illll‘l“ A
[ Right ~
= Toolbars..
- yy B Front
[ Back
From: From:
& SWilsometric Xaxs: 3150 XY Plane: 383
5 SElsometric
@ Nelometic
Z
(] [Coc ) [cancel | [ he |
ky :

i 4 » » " Model {Layoutl /Layout

@ [N - > > Drafting - GstarCADS Professional - [sample.dwg]

Edit View Insert Format Tools Draw Dimension Modify Window Help

Home  Insert  Annotation 3D  layout  View  Manage  Export  Help Appearance

4 AUGHTOOL.dwg | BEARING DRAWING.dwg ' LAYOUTEVPATH SAMPLE.dwg = MECHANICAL DRAWING.dwg OVERLAPPING SELECTION.dwg  Drawing3.dwg sample.dwg 3

@ Viewpoint Presets ==

Set Viening Angles
© Absolute to WCS () Relative to UCS

From: From:

X fis: 5.0 XY Plane: 0.0
Set to Plan View
ok ) [ cancd | [ _Heb |

i« 4 » » " Model {Layoutl /Layout2
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Chapter 4 Control the Drawing Views

Isometric View

e [ G T B e O e B
You can define perspective views of a e

model to create realistic effects. Select = "

predefined standard orthographic and o .

isometric views by name or description. e

These views represent commonly used = EHD:E"“ = i

options: Top, Bottom, Front, Left, Right, fesuca g l

and Back. In addition, you can set views pinlr , g o -

from isometric options: SW (southwest) = g ot Ui
Isometric, SE (southeast) Isometric, NE g SHemec ) »“
(northeast) Isometric, and NW (northwest) o e w J

Isometric.

>
Draw 2D Isometric Views
With Isometric Snap, you can create 2D objects that appear to be 3D solids.

By setting Isometric Snap on the Draft Settings dialog box and turning on Snap and Grid, you can easily align objects along one
of three isometric planes. However, although the isometric drawing looks like 3D, it is actually a 2D representation.

File Edit View Insert Format Tools Draw Dimension Modify Window Help

Home Insert Annotation 3D Layout View Manage Export Help Appearance * =2 X
< ALGNTOOLdwg BEARING DRAWING.dwg  LAYOUTBYPATH SAMPLE.dwg MECHANICAL DRAWING.dwg OVERLAPPING SELECTION.dwg Drawing3.dwg x sample.dwg 3
e N
@ Drafting Settings [

Snap and GRid | Polar Tracking | Object Snap | Dynamic Input |

[]Snap On (F9) [Z]Grid On (F7)
Snap spacing Grid spacing
Snap X spacing: 17.3205080 Grd X spacing: 17.3205080
Snap Y spacing: iy Grid Y spacing: 0

Equal Xand Y spacing Major line every: 5
Snap type Grid behavior
@) Grid snap Adaptive grid Y

(© Rectangular snap [ Allaw subdivision below grid
@ Isometric snap spacing
>

Display grid beyond Limits
] Follow Dynamic UCS

[ok J[ Camcel |[ Heb

4 4 » b Model {Layoutl /Layout2

=t lsoplane: Top
ommand: Speciy opposte comer =
ommand <l G

TR ovvio RN cinve T creace ISR ow [ voce.
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Chapter 4 Control the Drawing Views

Set Isometric Grid and Snap

By aligning along three major axes, isometric drawing simulates a 3D drawing from specified viewpoint. When the snap angle
is set to 0, the axes of the isometric plane are 30 degrees, 90 degrees and 150 degrees. With Isometric Snap on, you can work
on any of three isometric planes, each with a pair of associated axes.

-Left. The left isometric plane defined by a pair of 90- and 150-degrees axes. The snap and grips align along the 90- and
150-degree axes.

-Top. The top isometric plane defined by a pair of 30- and 150-degrees axes. The snap and grips align along the 30- and
150-degrees axes.

-Right. The right isometric plane defined by a pair of 90- and 30-degrees axes. The snap and grips align along the 90- and

30-degrees axes.

{J Drafting Settings l&J
o]
Snap and GRid | Polar Tracking | Object Snap | Dynamic Inputl 9 0
[C1Snap On (F3) [ Grid On (F7)
Snap spacing Grid spacing To p
T 173205080 | Grid X spacing 17.32065080
Snap Y spacing: 10 Grid Y spacing 0
Equal X and Y spacing Major line every: 5
Snap type Grid behavior
@ Grid snap Adaptive gnd
() Rectangular snap [ Mliow subdivision below arid
(@ |sometric snap spacing
Display grid beyond Limits Left
[ Follow Dynamic UCS ng h t
300 150°
) Cow )

In addition to using ISOPLANE command to switch isometric planes, you can also use shortcut key F5 or CTRL+E. specifying
one of the three isometric planes results in Ortho and crosshairs to be aligned along the corresponding isometric axes.

For example, when Ortho is on, the points you specified align along the simulated plane you are working on. Therefore, you can
draw the top plane first, and switch to the left plane to draw another side, and then switch to the right plane to complete the
drawing.

GRID LA osnee [ omack ow [ mooe. ||

Left plane Right plane

Top plane
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Chapter 4 Control the Drawing Views

Change a 3D View Dynamically

You can view objects from any viewing direction by holding down mouse or other pointing devices and moving dynamically.
With dynamic viewing, you can display the effects of changing viewpoint while you change the view. You can execute move or
zoom operations as the 3D Orbit is active. When the 3D Orbit is active, you are not allowed to modify objects. To close 3D Orbit,
press Enter, ESC or choose Exit from the shortcut menu.

% insert Format Tools Draw Dimension Modify Window Help
7 Redraw
Regen OUTBYPATH SAMPLE.dwg ~ MECHANICAL DRAWING.dwg  OVERLAPPING SELECTION.dwg  sample.dwa  x
IS, Regen Al 1
Zoom »
Pan 13
Qrbit »[cf,. Constrained Orbit
Viewports b
MNamed Views... 3D orbit
3D Views 3 K
(71 Hide
Visual Styles 3
Render »
Display 3
= Toolbars.

el {Layoutl / LayoutZ

E)
C:\Users\asus'App Data' Local\Temp \sample_1_5432.5V% ...

ORTHO osnap | otrack NGEOE o | MopeL

Hide Lines or Shade 3D Objects

Hides or shapes for 3D objects in the current drawing, suppresses the display of the objects (partly or entirely) that are located
behind other objects, or generates a simply shaded image displayed in the current view. You can use HIDE command to
remove the hidden lines to verify the current placement of these surfaces. Hiding background lines makes the display much
clearer, but you cannot modify hidden-line or render views.

v | B &2

Solid  Solid  Solid

SNE S

D 3D 3D 3D
Solid  Face Surfaces Mesh

£)

Section
Plane

Render Create Materials Render Advanced
Light~ Environment Render setings

fl@  gdSeparate -

@ 3D Wireframe

3D Hidden

@ 3D Hidden Visual Style
ii Flat Shaded -

D
@ | A

M““U

9 Flat Shaded, Edges on
N

q Gourand Shaded, Edges on |
i

et L

.\.;ij‘:.\t < %% ﬁ/ ~
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Chapter 4 Control the Drawing Views

Add Simple Shading to 3D Objects

Although hiding lines can enhance the drawing and clarifies the design, shading produces a more realistic image of your model.
You can modify shaded objects as you normally would. When a shaded object is selected, the wireframe and grips appear on
top of the shading.

Wt

Box Extrude

[« T
&%
Solid  Solid  Solid
Profile  View Drawing

SRS

2D 3D 3D 3D
Solid Face Surfaces Mesh

&)

Section
Plane

B ) Render Creste Materiols  Render  Advanced
@ [ Separate Light~ Environment Render settings

CELE
|20 || 3 33 31 3B
Wireframe ~ ||| Rotate Align Mirror Array
- I@ 20
@EDereﬁamE
@EDHMMEH
‘iﬂatihaded
Q Gourand Shaded
9 Flat Shaded, Edges on Q Gourand Shaded Visual Styles

Q Gourand Shaded, Edges on

= H
ﬁgﬁ‘;:i:::z::f Qe o

Render

Rendering creates a 2D image based on a 3D scene. It
shades the scene's geometry using the lighting you've set
up, the materials you've applied, and environmental
settings such as background and fog. At a basic level,
you can use the render command to render your model
without applying any materials, adding any lights, or
setting up a scene. You cannot move or adjust this light.

Render Environment Render Enviromment - =
Fog / Depth Cue

\ . ErablzFog [On -]
You can use environmental features to set up atmospheric effects or background o
i : . \ Fog Background [On -
images. You can enhance a rendered image by means of atmospheric effects like fog I
and depth cueing or by adding a bitmap image as a background. Fog and depth e
cueing are actually two extremes of the same effect: a white color is fog, and a black FrFogParcetage. 100

Speciy the norvtiansparency of the distant atamzaton

color is traditional depth cueing. You can use any color in between.
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Chapter 4 Control the Drawing Views

Light

Lighting adds the finishing touch to the scene. You can add point lights, spotlights, and distant lights and set the location and

photometric properties of each.
Point Light: A point light radiates light in all directions from
its location and does not target an object.

Spotlights: A spotlight can be directed towards an object.

Distant Lights: Simulates the effect of sunlight and can be
used to show how the shadows cast by a structure affect the
surrounding area.

Light List: Displays a list of type and light name used in
model. Distant lights and the sun do not appear as interface
objects in the model.

Materials

You can add materials to objects in your drawings to provide a realistic effect. In
the context of rendering, materials describe how an object reflects or transmits
light. Within a material, maps can simulate textures, bump effects, reflections,
or refractions.

Water r

Diffuse:

Refraction index T M
Translucency: | [
SeHllumination: | [}

Diffuse map

100

Precision Tools and the Properties of Drawings

Specify Units, Angles and Scale

Specify the units of measurement you want to use, their format, and other conventions.

Set the Units Format

You can set the display format of the unit that includes: scientific, decimal,
engineering, architectural and fractional notation. To enter architectural feet and
inches format, you can indicate feet using the prime symbol ('), for example, 72'3.
You do not need to specify inches by entering quotation marks (). You can set the
unit type and precision in the Quick Setup wizard, the Advanced Setup wizard, or the
Units Control dialog box. These settings control how your coordinate, offset, and
distance entries are interpreted, and how coordinates and distances are displayed.

{J Drawing Units

Length
Type

| Decimal

Frecision

Insertion scale

Units to scale inserted co
Sample Output
1.5,2.0039, 0

3<45.0

Lighting

rtert:

Milimeters -

To open drawing units dialog: ~ Format > Units Command line> UNITS

Units for specifying the intensity of lighting

Intemational -

[ok ][ caneel | [

Direction.

J [ Heo ]
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Chapter 5 Precision Tools and the properties of Drawing

Set Angle Conventions

You can specify the location for angle 0 and the positive direction for the angle measurement: clockwise or counterclockwise.

You can also specify the format and the number of decimal fraction.

-Specify the measurement unit and precision: The units include

. . . @ Drawing Units ==
grad, radian, surveyor's unit and degree, minute and second. ot e
I;::mal - T[::mall]egrea -
. Preciion H;SLE-;; @ Direction Contral ==
-Specify where the angle measurement starts from: east, west, = —
. Surveyor's Units (@ East 0
south, north or others. For example, to enter a coordinate isaton scde e ©
Units to scale inserted content ©) West 180
relative to the current coordinate for a property line that is 54 . -
. . . Sample Qutput (©) Other Pick / Type
feet, 7 inches long with a bearing of 60 degrees north, 12 o ? il
minutes, 6 seconds east, enter @54'7"'<n60d12'6"e. e —————
. . . . . . [ ok [ Concel | [ Diection.. | [ Hel
-Specify the positive direction: counterclockwise or clockwise.

The angle 0 can be set to any location.

Setting Scale Factors

Instead of drawing to a particular scale, you draw everything full size in the

Standard scale ratios and equivalent text heights

Scale
program. When you print your drawing, you can assign the scale at which
the drawing is to print. Scale, however, does affect the way a few elements 116" =1-0"
such as text, arrows, or linetypes print in your drawing. For example, when 1/8" = 1-0"
you draw text, you need to determine the text size so that when you print it 316" = 10"
|ater at a particular scale, the text height is correct.

1/4u — 1|_0u
After you determine the eventual scale of your finished drawing, you can 3/8" =1-0"
calculate the scale factor for the drawing as a ratio of one drawing unit to 172" = 10"
the actual scale unit represented by each drawing unit.

3/4” = 1I_OII
The following table shows some standard architectural and engineering 1" =1-0"
scale ratios and equivalent text heights required to create text that measures | 4 4 /"= 4
1/8 inch high when you print the drawing at the specified scale. 31
You can use these scale factors to predetermine the size of your drawingto | 1" = 10'
make sure that it fits on a specific size paper when you print it. You control | 4u — 9
the size of your drawing by the drawing limits. To calculate the drawing -
limits to match the size of your paper, multiply the dimensions of your .
paper size by your scale factor. 1" =40

1" = 50

1" = 60

1" =100'

Scale factor
192
96
64
48
32
24

120
240
360
480
600
720
1200

Text height
24”
12"
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Chapter 5 Precision Tools and the properties of Drawing

Drawing Limits

You can specify the drawing limits that form an invisible boundary around your drawing. You can use the drawing limits to make
sure that you do not create a drawing larger than can fit on a specific sheet of paper when printed at a specific scale.

For example, if you plan to print your drawing at 1/8" = 1'-0" (in other words, using a scale factor of 96) on a sheet of paper
measuring 36 inches x 24 inches, you can set drawing limits to 3,264 units wide (that is, 34 x 96) and 2,112 units high (22 x
96), which allows a 1-inch margin around the edges of the printed image.

To set the drawing limits:

Command line> LIMITS

-Choose Format > Drawing Limits

-Specify the x-coordinate and y-coordinate of the upper right
drawing limit and the lower left drawing limit. You can also click

Format > Drawing limits

Format |11
L=
L=

Draw

Layer...

Layer States Manager...
Layer tools
@ Color.
Linetype...
Lineweight...
A5 Scale List..

W TedStyle..
&, Dimension Style...
Plot Style...

Dimension Modify Window Help

“

X

%7 Point Style...
Select to specify the drawing limits by selecting points in the e
drawing. i
Grid and Grid Snap

The grid in GstarCADS8, is a rectangular pattern
comprised of minor and major lines extended over the
drawing area. Displaying grids and using grids snap
improve the performance of regenerating. When you
turn Snap mode on, the cursor adheres or snaps to
the invisible grids. Grid and snap settings are effective
tools to use in your drawing to ensure accuracy. In
addition, the cursor can be restricted to move :
orthogonally only or guides can display on the screen ) on
automatically at specified polar angle increments.

Change Grid and Snap Spacing

You can turn Grid and Snap on and off and specify their spacing on the Snap
and Grid tab at the Drafting Settings dialog box. Grid spacing does not have to
match snap spacing. A wide grid spacing can be used as a reference while a
closer grid spacing helps you specify points accurately.

19447541, 1 , 0

< v » ", Model /Layoutl / LayoutZ

mmand: _LIMIT
[Reset Model space limits:
pecify lower left comer or [DN/OFF]<0.0000,0.0000=: 34}
pecify upper right comer «420.0000,297.0000>: x
invalid Point.

|Specify upper ight comer <420.0000,257.0000>: 96

SNAP  GRID [gelvia0y

4 4 b ¥ Model

5% [Automaic save to
 [Command: L
LINE

Specify first poirt

‘Speciy next point or [Undo]

Loyoutl  Layout2

ksers'asus AppDatan Local . emp Drawingd_1_t

On
Off

‘Specy et pairk or [Undo]

snap | ¢

osnap | oTrack o | mopeL |

@ Drafting Settings

[

Snzp and GRid | Polar Tracking | Object Snap | Dynamic Input |

Snap On (FS)

Snap spacing
Snap X spacing 0

Snap Y spacing 0
Equal Xand Y spacing

Snap type
@ Giid snap
@ Rectangular snap

) Isometric snap

Grid On (F7)

Grid spacing
Giid X spacing
Giid Y spacing

Major line every: 5

Grid behavior
[¥] Adaptive grid
[] Allow subdivision below grid
spacing
Display ard beyond Limits
[ Follow Dynamic UCS

oK ][ Cancel || Hep |
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Chapter 5 Precision Tools and the properties of Drawing

Use Object Snaps

Object snaps enable you to quickly select exact geometric points on existing
entities without having to know the exact coordinates of those points. With
object snaps, you can select the endpoint of a line or arc, the center point of a
circle, the intersection of any two entities, or any other geometrically significant

position. You can also use object snaps to draw entities that are tangent or
perpendicular to an existing entity.

ayoutl / Layout2

snap GRID  ortHO  PolAR (SR NS vwecht [T

Setting Object Snaps

{ Drafting Settings ==
You can set object snaps using any of the following methods: Soopand R | BT Ot Sy i eget].
-Choose Tools > Drafting Settings > Object Snap, and then click one of the e I .
object snap tools. s R E
-On the Object Snap toolbar, click one of the object snap tools. e -
-On the status bar, right-click on the Object Snap button to choose Settings. i g
-Press and hold down the Shift key while right clicking anywhere within the e
drawing window to display the object snap shortcut menu, and then choose
the object snap you want to set. —
AutoSnap Tools

The automatic snap tool is a visual aid tool for snapping that help you see and use object snaps more efficiently. When any
object snap is on, the system displays a marker and a tooltip when you move your cursor on over a snap point. AutoSnap turns
on automatically when an object snap is on. By default, AutoSnap marker, tooltip and magnet are on. You can change the
settings of AutoSnap on the Options dialog box. AutoSnap consists of the following snap tools:

-Marker. The object snap location is displayed when the (Goror . ==

Current profie <cUnnamed Profile>> B Curent drawing: Drawing4 dwg

cursor moves over or near an object. Marker shape is e T e
determined by the snap it is marking. S e —
Magnet Display full-screen tracking vector
Display AutoSnap toolip Display Auto Track tooltip
-Tooltip. Indicates which part of the object you are snapping ey At apeers box e For fonten
Colors -
to in a flag at the cursor location. st e
AutoSnap Marker Size Aperture Size
m}
-Magnet. Attracts and locks the cursor onto the nearest g L
detected snap points. Provides a visual that is similar to Db Snap Ot
. . lanore hatch objects
snapping to a grid. I Flace Z ek wih curert dlovation

-Aperture box. Surrounds the crosshairs and defines an area within which, when you move the cursor, system evaluates objects
for object snaps. You can determine the aperture box is displayed or not, and the aperture box size can be changed too.
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Chapter 5 Precision Tools and the properties of Drawing

Use Polar Tracking and Object Snap Tracking

Auto tracking includes polar tracking and object snap tracking. You can turn them on and off by repressing POLAR and OTRACK
buttons on the Status Bar. When the polar tracking mode is on, the cursor moves along the specified angle. When the object
snap tracking is on, the cursor moves along an alignment path based on the snap point.

Polar Tracking
When polar tracking is turned on, guides display on the screen automatically at the polar angle increment that you specify. For

example, if you draw a line with polar tracking turned on with angle increment set as 65 degrees, the rubber-banding line
displays at 65 degree increments.

To enable polar tracking and specify the polar angle increment: Z A bobating ___) -

Fglmat Draw Dimepsion Modify Window Help

Our WebSite

1.Do one of the following: = z::;d s cmg>
-Choose Tools > Drafting Settings from the main menu. & gk;;d X
-On the Object Snap toolbar, click the Object Snap Settings button. b ’

& Update Fields

-Type DSETTINGS in the command line and then press Enter.

= Block Editor
Xref and Block In-place Editing 3
5 Data Extraction...

TCanest” g:f (B Load Application...
Macro 3
w Zaige VN ] MODEL AutolISP »
Mew UCS 3
12 Named UCS...
. . _Draftm Settings...
2.Switch to the Polar Tracking tab. i Gpg—
3.Select the Polar Tracking On checkbox. o '
ptions...
4.Do one of the following to specify the polar angle increments:
-Select an angle from the Increment Angle drop-down list.
-Mark the Additional Angles check box and click New to define a custom angle increment.
5.Click OK.
[ Sniap and GRid | Polar Tracking | Object Snap | Dynamic input | | Snap and GRid | Polar Tracking | Object Snap | Dynamic input |
Polar Tracking On (F10) Palar Tracking On (F10)
Polar Angle Settings Object Snap Tracking Settings Polar Angle Settings Object Snap Tracking Settings
@) Track orthogonally only Increment angle: © Track orthogonally only
) Track using al polar angle setiings 0 M ) Track using all polar angle setiings
Addtional angles
[ New
B — i e S
©) Absolute 150 ©) Absolute
() Relative to last segment 7 () Relative to last segment
[ok J[ cama |[ b ok ][ Caned ][ hed

Remark: To toggle polar tracking on and off at any time, click the Polar Tracking button on the status bar or press F10.
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Chapter 5 Precision Tools and the properties of Drawing

To draw objects using polar tracking:

-Turn on polar tracking and start a drawing command, such as ARC, CIRCLE, or
LINE. You can also use polar tracking with editing commands, such as COPY and /
MOVE.

-As you move your cursor to specify points, notice the dotted polar tracking line
that appears at the tracking angles you specified. Points you specify while the

out2 |
line is displayed conform to the polar tracking angle. 5

12
SNAP  GRI

Object Snap Tracking

Object snap tracking can track along alignment paths that are based on object snap points and display tooltips at the acquired
points. After you acquire a point, horizontal, vertical and polar alignment paths relative to the point are displayed when the
cursor moves over their drawing path. For example, you can specify a point along a path that is based on an object endpoint or
midpoint or an intersection between objects.

You can also use system variable TRACKPATH to control the display of polar and object snap tracking alignment paths.

pain
Endpoint: 46,3636 < 0°

v Object

i drawn
x

4 Model | Layoutl |  Layout2

swe o omro eou VOGS v OO 0|

start point

Use Orthogonal (Ortho Mode)

You can restrict cursor movement to the current horizontal and vertical axes so that you can draw at right angles, or
orthogonally. For example, when the Draw Orthogonal option is enabled, lines are restricted to 0 degrees, 90 degrees, 180
degrees, or 270 degrees. As you draw lines, the rubber banding line follows either the horizontal or vertical axis, depending on
which axis is farthest from the cursor. When you enable the isometric snap and grid, cursor movement is restricted to
orthogonal equivalents within the current isometric plane. Ortho mode and polar tracking cannot be on at the same time.
Turning on Ortho turns off polar tracking.

To fast enable orthogonal drawing:
[Specify nedt point: @'\ | EE

-Press F8 or press the ORTO button at the status bar

you
EVCINE Sl ORTHO OSNAP | OTRACK o | mooe. [
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Chapter 5 Precision Tools and the properties of Drawing

Working with Linetypes

A'linetype is a repeating pattern of dashes, dots, and blank spaces displayed in a line or a curve. You can assign linetypes to
objects by layer, or by specifying the linetype explicitly. And also, you can specify its scale, load more linetypes into the
program from a linetype library file, and create your own custom linetypes.

By default, every drawing has at least three linetypes: CONTINUOUS, BYLAYER, and
BYBLOCK. You cannot rename or delete these linetypes.

Remark: You should not confuse these linetypes with the hardware linetypes provided
by some plotters. Both linetypes of dashes produce the similar effects. However, if you
use both linetypes at the same time, the results can be unpredictable.

Load Linetypes

I
(o Ml red =

5
et o ByLayer
nse % -

CENTER2  |=

Eylayer

ByBlock

Continuous
CENTER2
— - —  — DASHDOT2

—p——o—— FENCELINE1

Mare..,

GstarCAD includes the linetype definition files gcad.lin and geadiso.lin. If you select gcadiso.lin, you can use ISO pen-width
option when you plot. If you want to know what linetypes are already available, you can display a list of linetypes that are loaded
in the drawing or stored in an LIN (linetype definition) file. Both linetype definition files contain several complex linetypes.

(@ Linetype Manager =
@ Load or Reload Linetypes ===
Linetype fiters Load Deielo
Clmeste — A
T T Avalable Linetypes
Linetype Appearance Description Linetype o
BORDER L
BVB' - BORDERZ '|
Byt BORDERX2 o
Contiruous Soid e CENTER
CENTER2
CENTERX2
DASHDOT
DASHDOTZ
= DASHDOTX2
Global scale factor: 1.000000 DASHED
DASHED2
Current bject scale 000800 DASHEDX2 Dashed (20 =
Use paper space units for scaling 1.00 Milime
0K | [ Cancel | [ Heo
oK | [ Concel | [ Hep

Change the Linetype of an Object

You can change the linetype of an object by changing the linetype of the layer the object is on, reassigning the object to
another layer, or by specifying a linetype for the object directly.

age Export

fim 2
illet ~ 3%,
rray  d

e RgFgEEe BB
L 4ppEARABE

Help

A [

Bylayer

il 1 ©

=
Insert \% .

——

CENTERZ |+

Bylayer
ByBlock
Continuous
CENTER2
DASHDOT2
FEMCELIMEL

More...
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Chapter 5 Precision Tools and the properties of Drawing

Set the Current Linetype

By default, all objects are created using the current linetype, which is displayed in the Linetype Control on the Properties
toolbar. To modify this current linetype, you can select a linetype and make it current in the Linetype Manager dialog box. If the
current linetype is BYLAYER, objects are created using the linetype assigned to the current layer.

If the current linetype is BYBLOCK, objects are created
using CONTINOUS linetype until they are grouped into a
block. When you insert the block, it acquires the current
linetype setting.

To make the linetype current;

Select a linetype from the Linetype Control pull-down list
on the Properties toolbar, which is set to the current
linetype.

Control Linetype Scale

PR BEHE

ByLayer
ByBlock

You can set global or individual scales for objects to control the display of linetypes. The Global Scale Factor and Current

Object Scale are displayed in the Linetype Manager. The Global Scale Factor value is stored in the system variable LTSCALE,

which changes the linetype scale globally for new and existing objects.

The Current Object Scale is stored in the system variable CELTSCALE, which specifies the linetype scale for new objects. In a
layout, you can use system variable PSLTSCALE to adjust the linetype scale in different viewports.

Remark: Setting the linetype scale too large or too small may result in a line pattern looking like a solid line, depending on what

the scale view is or at what scale the drawing is printed.

To set the current individual linetype scale:

-Choose Format > Linetype

-Click the Show Details button.

-In the Current Object Scale field, type the linetype scale
that you want to make current.

-Click OK.

To change the global linetype scale:

-Choose Format > Linetype

-Click the Show Details button.

-In the Global Scale Factor field, type the global linetype
scale that you want to change. Then click OK button.

Format > Linetype

Command line> LINETYPE

Linetype fiters
Show all linetypes. =| [ nvert fiter
[ ' ) (A
Furrenl linstype:  ByLayer
Linetype Appearance Description
Bylayer
ByBlock
Continuous Solid line
Details
Mame: Global scale factor: 25
Descriptian: Currert object scale 2

Use paper space units for scalin

50 pen widh

1.00 Millime

[

] [ Cancel | [ Hep |
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Chapter 5 Precision Tools and the properties of Drawing

Working with Layers

Layers are like the transparent overlays you use in manual drafting. You use layers to organize different types of drawing
information. Each object in a drawing exists on a layer. When you draw an object, it is created on the current layer.

Create and Name Layers

You can create an unlimited number of layers in every drawing and use those layers for organizing information. When you
create a new layer, it is initially assigned the color white (or black, depending on your system settings) and the linetype
CONTINUOUS. By default, a new layer is also visible. After you create and name a layer, you can change its color, linetype,
visibility, and other properties.

To create a new layer:  Format > Layer Command line> LAYER

-Choose Format > Layer

-Click the New Layer button. (@ Loyer Properties Manoger
H Current layer: 0
Type a name for the new layer and then click P e TR
OK button. [ ][ states MName &  On  Fe. lock Color  Linetype Lineweight Plot Style Pt Ne.. De.
s 0 G o of EWhite Continuous Defaut  Color 7 2 B
NEW 1 {1 o' B White Continuous Defaut  Color 7 g B
) . * . o Whe Continuous i = I
To change a layer name in the current drawing: e U d Wi ot elesk b = "
-Choose Format > Layer
-In the Layer Properties Manager dialog box,
click the name of layer you want to change. N
-Type a new name and click OK button. e A Shows 4 ayer. el 4 e o |l s

Setting the Current Layer

When you start a drawing, objects are created in the current layer. By default, the layer 0 is set to the current layer, but you can
also create a new one and make it current. Any subsequent objects you create are associated with the current layer and use its
color and linetype.

{F Layer Properties Manager
To make a layer current: i e
&8 @ =% X[ i
[ [ stae Name & i:tsct:reriz\te\::!;gyerastha(urrantlayar Objects that you ot Style Plot Ne.. De
= o create are drawn on the current layer. (CLAYER system variable) lor 7 g =8
-Choose Format > I_ayer . NEW 1 9% of M Whie Continuous Defauk  Color_7 2 5
- i _ (=3
-In the Layer Properties Manager dialog box, news ¥ % o WWue Gommom  ——Ddak  Cior e &
select a layer and then click the Set Current
button to make the layer current.
-Click OK.
1
Removing LayerS @~ Al Shows 4 layers, total 4 layers 0K Cancel

You can remove unused layers from your drawing with PURGE or by deleting the layer from the Layer Properties Manager.

41



Chapter 5 Precision Tools and the properties of Drawing

Controlling Layer Visibility

A'layer can be visible or invisible. Objects on invisible layers are not displayed and do not print. By controlling layer visibility,
you can turn off unnecessary information.

To turn layers on or off: ~ Format > Layer (I erv—
Command line> LAYER Curert layer. NEW 2
%@ = n K
2 || Status Name |Dn - |Fre Lock  Color Linetype Lineweight Plot Style F
g On: ——— Defaul olor_7
-ChOOSG Format > Layel' ‘PJJEWT g \Tu:n layer on or offforent\redrawmg] g:au: Eu:nr:TZ
~Click the icon under "On" tab in the layer list. < L IS S - = . Dot __Co

-Click OK button.

Locking and Unlocking Layers
Locking a layer prevents you from accidentally modifying its objects. When a layer is locked (but visible and thawed), you
cannot edit them. If you lock the current layer, you can still add new objects to it. You can also change the linetype and color

associated with a locked layer. Unlocking a layer restores full editing capabilities.

To lock or unlock layers:  Format > Layer Command line> LAYER

-Choose Format > Layer from the main menu. Qv Properies Mansger
Curert layer: NEW 2
-Click the icon under "Lock" tab in the layer list. GRS &% X
-C“Ck OK buﬂon » iatus DName On Fr;l Lock L;kl: Color Linetype Lineweight CPUI“:S?Ae
NEW 1 ; Lacks or unlocks layer globally for entire drawing | ¢ "5

" NEW 2

Defaut  Color_40

%
9
9
*

O ot 40  Continuous
;

= 10 Continuous

Controlling Layer Printing
Controlling layer printing is another way you can specify which objects print in your drawing. By controlling layer printing, you
can turn off unnecessary information during printing. When you turn off printing for a layer, objects drawn on that layer are still

visible, but they do not print.

To turn layer printing on or off: ~ Format > Layer Command line> LAYER

~Choose Format > Layer [ Layer Properties Manager |

Cument layer: NEW 2 Q
FERE v X

|| Status Name On

-Click the icon under "Plot" tab = 0

Color  Linetype: Lineweight Plot Style Plot_[Ne.. De |

a
g
&

a
9 % o' B Whie Continuous Defaut  Color 7 ot:
NEW 1 9 & &  E7Z Cotos st Coor 72 Determines i layer is plottable or not for entire drawing
in the laver list : * o H40  Confnuous
y . NEW/ 3 IR & H10  Contruous Defash  Color 10 2 B

-Click OK button.

»

o [ ok | cancel [ 2opy |[ Hep L
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Chapter 5 Precision Tools and the properties of Drawing

Setting a Layer's Print Style

If your drawing uses named print style tables, you can specify a print style for each layer. Named print style tables contain print
styles that you set up to control what objects look like when they print, without actually changing the objects in the drawing. If
your drawing uses color-dependent print style tables, you cannot specify a print style for a layer. These types of print style
tables automatically determine printing requirements by the color assigned to a layer or an object.

To change the print style assigned to one or more layers (only in a drawing that uses named print style tables):

Format > Layer Command line> LAYER

qQ
-Choose Format > Layer
-Click the name of Plot Style in the layer list to open Select Plot Cobr  Lnepe  Lnewsgnt | PoiSive al Mot Newviewporfr. Descipton
) . ) ] M Wit Continuous Defaut G 7 ?;atnsgt):::p\utstyIEFurEntirEdrawing
Style dialog box, from which, you can specify the desired plot style. = %
W10 Continuous Default  Color_10 =] =)

-Click OK button.

Freeze or Thaw Layers

You can also freeze layers to improve the performance of operations such as zooming and panning or producing hidden lines or
shaded images. When a layer is frozen, objects drawn on that layer are no longer visible.

To freeze or thaw layers:  Format > Layer Command line> LAYER

-Choose Format > Layer @ Layes roperties Manager
. . . . Curent layer: NEW 2
-Click the icon under "Freeze" tab in the layer list. ARG %R

Freezes or Thaws layer globally for entire drawing

-Click OK button. Iz = =, e —ma

Setting the Layer Color

Each layer in a drawing is assigned a color. GstarCAD uses the BYLAYER color as the default color setting for object creation so
that new objects are drawn in the color of the layer on which they are inserted.

To change the layer color: @ LajerProperies Manager @ seectcor =)
Format > Layer ~ Command line> LAYER | e ot & o« o it | T | o |
; Status Name On Freeze Lock Color [l
= 0 @ gt o W White

-Choose Format > Layer v ews § % e

. . , I
-Click the icon under "Color" tab in the layer
list to open Select Color dialog box, from

. . . . . ..-. Bylayer ByBlock
which, you can specify the desired color — '
through index, true and color books tabs Cooe: 10

. » <

—Then C||Ck OK bUHOﬂ (@< Al Shows 4 layers, total 4layers i [ ok J[ Concel [ b ]




Chapter 5 Precision Tools and the properties of Drawing

Setting a Layer's Linetype

Each layer uses a default linetype. Linetype determines the appearance of objects both on the screen and when printed. It's
recommendable to assign the BYLAYER linetype to any objects that you draw on that layer.

To change the linetype assigned to one or more layers: Format > Layer Command line> LAYER

-Choose Format > Layer =)
~Click the Linetype name in the layer list to open Select Linetype a:;:fjp . ]
dialog box, from which, you can specify the desired linetype.

-Click OK button.

mio Continuous

Setting a Layer's Lineweight

Each layer uses a default lineweight. Lineweights determine the thickness of objects both on the screen and when printed. All
new layers are assigned the DEFAULT lineweight, which is .25 millimeters or .01 inches. If you want a different lineweight
assigned to a layer, you can easily change it using Layer Properties Manager.

To change the lineweight assigned to one or more layers: E yr— =)

Format > Layer Command line> LAYER b
PP rr—

0.00 mm

M White Continuous Default
BORDER —Defaut__|{|
-Choose Format > Layer D& Cortmams  — O

| Continuous — Default
-Click the Lineweight name in the layer list to open Lineweight
dialog box, from which, you can specify the desired lineweight.
~Click OK button. =

[ ok ][ canedl | [ reb

0.05mm
0.08 mm
0.13mm
0.15mm
0.18mm
0.20mm
0.25mm
0.30mm
0.35mm o

Filter List of Layers

You can use a layer filter to limit the display of layer names in the Layer Properties Manager. The following properties can be
included in the filter definition: Layer names, colors, linetypes, lineweights, and plot styles. Whether layers are locked or
unlocked, turned on or off, frozen or thawed in the current viewport or all viewports. When setting filter conditions, you can also
use wild-card characters to filter names by name. For example, typing D* displays layer name preceded with D, just click Add
button if the filter name has been

L { Layer Properties Manager O Layer Filter Properties ==
Specmed =l HEWES | Fiter rame:
& HBa & H X Propertes Fiter 1 Show example
— Filter definition:
>||s Name: On Fresze Lok
i . B 0 o & Status ;’ Freeze Lok Color Linetype Lineweight Pl.. Plot N.
To filter list of layers: wemeic ) £ o :
BIPOLAR CON 9 &8 o
DUMPER 1 Q9 & o
DUMPER 2 Q & o
L___JOUMPER3 & % o ||
NEW 1 Q Eed of
-Choose Format > Layer A S S § [E=re
ROTATORHEX  § & & Status N.. On Freeze lok  Cok Linetype Lineneight Pl Plot N..
H H H ROTATORNUT % of DuMP. Q) &5 o Ho Continuous —Defat C 2 m
-Click the New Property Filter Icon, SEPARATORT (4B & e § % of Ew Continuos — belt . @ &
SOLID MATE g @ g o, Q&3 o Ew Continuous —Defalt . =S
. SOLID WALL &
located at top left of the window. ][
@ v Al Shows 14 layers, total 14 layers

—In the Layer Filter Properties dialog
box, under filter definition, click the tabs properties you want to filter. Then click OK button.
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Chapter 5 Precision Tools and the properties of Drawing

Displaying Lineweights
Lineweights are displayed differently in paper space layout than model space. Lineweights are useful for graphical
representations of different objects and information.

Display Lineweights in Model Space

In model space, a 0-value lineweight is displayed as a pixel, and other lineweights are display with a pixel width proportional to
their real-unit value. In model space, lineweight display does not change with the zoom factor. A lineweight value that is
represented by a width of several pixels is always displayed using the same number of pixels. In model space, press LWT
button on the status toolbar to turn lineweight display on and off.

2 % |4 Drawingl.dwg | sample.dwg

Fropertes
[#]% ]
General -

Color M ByLayer

W < » » " Model {Layoutl /LayoutZ

w oo onvo EEIETOETANCTACIOT 0 |

Display Lineweights in Layouts

In paper space (layout tab), lineweights are displayed in exact plotting width. In plot preview and paper space, lineweights are
displayed in real-world units, and lineweight changes with the scale factor. From the Plotting Scale tab of Plot dialog box, you
can control the lineweight plotting and scaling in a drawing. In paper space, press LWT button on the status toolbar to turn
lineweight display on and off. This change does not affect the lineweight plotting.

Properties 2 X |4 Drawingl.dwg = sample.dwg x
[ o
General - r o
Color My Layer ‘ |
Layer Lines
Linetype — Bylayer | |
Linetype scale |7
Flot Style BYCOLOR ‘ ‘
| ‘
-
Thickness | Default | |
s — 0.00mm
Wisslizion] 05 rm | |
Materizls —009mm
—013mm
ET —0.15mm | |
Stant X —0.18mm
Statt Y — | |
Stat Z _‘;35 ‘ ‘
—035mm
et —040mm
Center Y = 0%m | ‘
— 53 mm
o=z o 060 mm
End X - (70 mm | |
— (80
Ediy =050mm | ‘
End Z -1 00mm
s
i .20 | |
Statange  EE140mm
S | |
Totadlangle 211 mm
Aclengh | 1446314 L - - _
2226 5768
W 4 » » " Model » Layoutl {Layout2

I el Posr | osnap | omack [ wwecHT [ o | mopel
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Chapter 6 Create Objects

Create Objects

Drawings are made up of objects. In general, you draw objects by specifying points with the pointing device or by entering
coordinate values at the command prompt.

Draw Linear Objects

Lines: A line consists of two points: a start point and an endpoint. You can connect a series of lings, but each line segment is
considered a separate line object. To draw a line:  Draw > Line Command line> LINE

1.Choose Draw > Line from the main menu. Point
2.Specify the start point. T
3.Complete the first line segment by specifying the endpoint. .
4 Press Enter to complete the command. A
X

<+ w “Model {Layoutl /LayoutZ

To start a new line at the endpoint of the last line drawn, start the Line ==

(Select object: Specfy opposite comer: 1 found
X X X . . ISelect object
command again and press Enter directly at the "Specify first point:" Eormend LNE
Specfy next point or [Undo]
prOmpt B LGEN FoLar | oshiap | oTRack o | mc

Multilines: Multilines consist of several parallel lines, called elements.

You can determine the position of elements by specifying offset from the origin of each element. By default, multiline objects
contain two elements. You can create and save new multiline styles by yourself or modify existing mline styles.

To draw a multi-line: Draw > Multiline Command line> MLINE

1.Choose Draw > Multiling from the main menu.
2.5pecify the start point.

3.Specify the endpoint. I« < » i \Model {Layoutl {Layout2 /
4 Press Enter to complete the command. °§§3:§323?31"'“”s’"m’"/s°a'e/me':

Specify next point or [Undo]:
I} gSpecify next point or [Close/Undo]:
-528.9422, -129.3366, 0 sNaP GRID  OrRTHO PolAR [EEIR

8]

@ Muliiline Style

@ New Multiline StylesM =
Cument Mutiine  STANDARD
Sles Descrption NEW MSTYLE FOR CONSTRUCTION LINES
STANDARD St Cyrent
Desciiption Bements
e = O o Lo
) - o B B
Mo
Outerare B o B K
Bename et
Deite nge 000 0.0 - Delete
Do |
Ot 0000
Fill coler: W
Proview: STANDARD Color:
r .
( Dplayiart: B inetypes Linetyp
[ oK ] [ —_ ] l Help I
I oK ] [ Cancel ] I Help
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Chapter 6 Create Objects

Rays: Aray is a line in three dimensional space that starts at a point and extends to infinity. Because rays extend to infinity, they
are not calculated as part of the drawing extents. The default method for drawing a ray is to select the start point of the ray and

then specify its direction. To draw a ray:
Draw > Ray Command line> RAY

1.Choose Draw > Ray from the main menu.
2.Specify the start point and the direction.
3.Press Enter to complete the command.

Construction Lines: A construction line is a line through a given point, .
oriented at a specified angle in three dimensional space and extending to AJ
infinity in both directions. You can also draw a construction line at a specific

angle or at an angle relative to an existing object.

To draw a construction line:

Draw > Construction Line Command line> XLINE

1.Choose Draw > Construction Line from the main menu.

2.5pecify a point along the line.
3.Specify the direction.
4 Press Enter to complete the command.

mﬁ“\te
\in€

¥ Point
LA

el

4 4 r » "\ Model {Layoutl /Layout2

5 [Select object
ly {Specily base point or [Displacement] <Displacement>: Speciy secand point or <us
firs point as displacement>:
mmand: RAY
pecify start point:

Ispecify through point

11494.5506, 1330.2165, 0 VLI EVIO roLar | osnap | otrack JNRVGETM Dy | MoDEL -

g o
—

F— X

4 » b Model £ Layoutl / Layout?

x

Command: “Cancel*

Command: “Cancel™

Command: “Cancel®

{Command: "Cancel™

{Command: “Cancel*

Command: XLINE

\Specify a poirt or [Hor/Ver/Ang/Bisect /Offset]: H
{Specify through poirtt:

Specify through point

Specify through poirt:

=

> GRID [geltiglely POLAR [elRIS I OTRA

Polylines: A polyline is a single object with connected sequence of line segments

or/and arc segments. When you draw a polyline, you can switch to different options.
After you draw more than one segment, you can close the polyline, undo or finish. T

To draw a polyline with straight segments:
Draw > Polyline Command line> PLINE

1.Choose Draw > Polyline from the main menu.
2.Specify the start point.
3.Specify the endpoint of each segment.

4 Press Enter to end, or enter ¢ (close) to close the polyline.

TL

.
i— o [eedfyneepointor [T ]-58356 |

4 4 b ¥ Model {Layoutl - Layout2

Specify start point

Cumrent line-width is 0.0000

Specify next point or [Anc/Halfwidth/Length/Undo /Width].
(Specify next point or [Arc/Close/Halfwidth/Length/Undo./Width]:
(Specify next point or [Arc/Close/Halfwidth/Length/Undo,/ Width]:
[Specify next point or [Anc/Close/Halfwidth/Length/Undo./Width]:
(Specify next point or [Anc/Close/Halfwidth/Length/Undo./Width]:

=R

11497.986, 1329.4548, 0 SNAP  GRID [gelap(ely POLA
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To draw a line and arc combination polyline:
Draw > Polyline Command line> PLINE

1.Choose Draw > Polyline from the main menu.
2.Specify the start point.

3.Specify the endpoint.

4 At the command prompt, choose Arc.
5.Specify the endpoint of the arc segment.

6.To complete the command, Press ENTER.

To create closed polylines: Draw > Polyline Command line> PLINE

L
L+—-

x

M 4 b Model /Layoutl » Layout?

[& Speciy nt point or [Are/Close, Hafwidth, Length UndovWidt:

5 |specify next poirt or [Arc/CloseHalfwidth /Length,/Lindo, Width]:

{Specify next paint or [Arc/Close/Halfwidth/Length,/Undo/ Widih: A

{Speciy endpoint of arc or
[Angle/CErter/CLase/Direction/Halfwidth,/Line/ Radius/Second pt/Undo/Width:
ISpeciy endpoint of arc or

[Angle/CErts =/ Direction, Haffwidth/Line/Radius/Second pt/Undo /Width]:

GRID [gelilely POLAR [eRy]

114639104,

When creating polylines with PLINE command, the Close option is only available if no less than two line or arc segments are
drawn. A closed polyline object is drawn if you connect the start point of the polyline to endpoint of the last line or arc segment

with a line or arc.

LWPalyline
Color Bylayer
Layer O

Linetype Bylayer

4 4 » W 4 Model 4 Layoutl A Layout2

¥ [Specify endpoint of arc or

0 [Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius./Second pt/Undo./Width]:

Specify endpoint of arc or

[Specify next point or [Arc./Close/Halfwidth/Length/Undo/Width]:
Specify next point or [Arc./Close/Halfwidth/Length/Undo/Width]: CLOSE

[Angle/CEnter/CLose/Direction/Halfwidth/Line/Radius./Second pt/Undo/Width]: LINE

Command

1359.6969, 0 SNAP

To create wide polylines: Draw > Polyline Command line> PLINE

[ ORTHO [QEeIELEN OSHAP

You can draw polylines of various widths by using the Width and Halfwidth options of PLINE command. The Width and
Halfwidth options set the width of the next polyline segments you draw. You can set the width of individual segments and make

them taper gradually from one width to another.

Epeehmeeponar | o]

14 4 » o 4 Model /£ Layoutl ¢ Layout?

—
¥ [Specify ending width <0.3000>:

n Specify next poirt or [Arc/Close/Halfwidth./Length/Unda/Width]:

|Specify next poirt or [Arc/Close/Halfwidth/Length/Undo/Width]:

|Specify next point or [Arc/Close/Halfwidth/Length/Undo/Width]:

Specify next poirt or [Arc/Close/Halfwidth./Length./Unda/Width]:
Specify next poirt or [Arc/Close/Halfwidth./Length/Unda/Width]:

GRID  ORTHO

|Specify next point or [Arc/Close./Halfwidth/Length./Undo/Width]:
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Chapter 6 Create Objects

To draw a boundary polyline: Draw > Boundary Command line> BOUNDARY

1.Choose Draw > Boundary from the main menu. (@ Eoundary Creation [=5=)
2.Specify the objects by doing one of the following:

P#{  Pick Points

Island detection

-Current viewport Define a boundary set with all entities in the e
current viewport. if this option is selected, any boundary set ————
currently used will be canceled. S

e
-Existing set Click New button to switch to the drawing area, and [ ok ) [ Comcal | [ ]

prompt users to select objects for defining boundary sets. Press
Enter to return to the dialog box after selection. This option is only available after selecting objects by using the New button.

3.Select the Island Detection option.

4.Click Pick Points.

5.In the drawing, click inside the area whose closed perimeter forms the boundary, not on the polyline itself. If desired,
continue clicking inside additional closed perimeters.

6.To complete the selection, press Enter.

7.In the Boundary Creation dialog box, click OK.

N e v : : LWPolyline
— I---!— Color Bylayer
(| Layer 0
Linetype Bylayer
Pal X
M 4 » H “Model £ Layoutl / Layout2 4 4 ¢ b ' Model / Layoutl » Layout2
% |Pick intemal poirt: Selecting all objects... * |Analyzing the selected data...Emor analyzing intemal islands
@ |Selecting evenything visible ... 1 |Pick intemal paint:
[Analyzing the selected data BOUNDARY created 1 polylines.
|Analyzing the selected data.. Emor analyzing intemal islands Command:
Pick intemal poirt: Command:

11559.7166, 1350.4103, 0 SNAP  GRID ORTHO

11561.1469, 1351.7565, 0 SNAP GRID ORTHO  PC

Polygons: Creating polygons is a simple way to draw squares, equilateral triangles, octagons, and so on. Polygons are closed
polylings with between 3 and 1,024 equal-length sides.

To draw a polygon by vertex:
Draw > Polygon Command line>POLYGON

1.Choose Draw > Polygon from the main menu.
2.Type 6 to specify six sides for the polygon.

SSpeley the Ceﬂter 0]( the p0|yg0ﬂ 4 4 » » Model / Layoutl / Layout2 /
i FEnt umber of sides <4>: 6
4.Specify the vertex of the polygon. i}ve;f: AN
|Enter an option [Inscribed in circle/Circumscribed about circle] <I>:1
[ gSpecifyradiusofcircle:

423,689, -223.8862, 0 SNAP GRID ORTHO POLA
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Rectangles: Rectangles are closed polylines with four sides. You draw a rectangle by specifying its opposite corners. The
rectangle is normally aligned parallel to the current snap and grid alignment, but you can use the Rotated option to align the
rectangle to any angle.

To draw a rectangle:
Draw > Rectangle  Command line>RECTANG

1.Do one of the following:
-Select Draw > Rectangle on the main menu. D
-Click the Rectangle tool or type RECTANG command and press

Eﬂtel' 4 4 » » “Model /Layoutl {Layout? /

" ify first comer point or [Chamfer/Elevation/Fillet/ Thickness/Width]: F
o ify fillet radius for rectangles <0.0000>: 10
. |Specify first comer point or [Chamfer/Elevation/Fillet/ Thickness/Width]:

2.Identify one corner of the rectangle or enter an option. Specify Specfy other comer port or [vea/ Dimensions/Rotation]
first corner point or [Chamfer/Elevation/Fillet/Thickness/Width]:

-272.9449, -287.2165, 0 snap GRID  ORTHO POLAR (BB OTRACK  Lwi

3.Identify the opposite corner of the rectangle or enter an option. Specify other comner point or [Area/Dimensions/Rotation]:

Points: You can draw a point object formatted as either a single dot or as one of 19 other possible display styles.

To draw a point: Draw > Point Command line>POINT

+ o+
RS
1.Choose Draw > Point > Single Point from the main menu. S
. . . ﬁg [
2.Specify the location of the point. e e | ]
x
To draw several points; —

1 Command
Command: _POINT

PDMODE=2 PDSIZE=-3.0000

sNAP  GRID ORTHO POLAR (RN

1.Choose Draw > Point > Multiple Point from the main menu.
2.Specify the location of each point.

To change the size and appearance of point objects:
Format > Point Style Command line>DDPTYPE

1.Choose Format > Point Style from the main menu.

2.Under Point Style, select the style you want. + 4
3.Under Point Size, specify the point size, or choose one of the options. + [ -
4.Click OK button. SR | et

[ ok J[ cancel |[ Hep

¢
) ) ) ) &

When you regenerate the drawing, all point objects change to reflect the new size and v *®
appearance settings. #* &
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Freehand Sketches: A freehand sketch consists of many straight line segments, created either as individual line objects or as a
polyline. Before you begin creating a freehand sketch, you must set the length, or increment, of each segment. The smaller the
segments, the more accurate your sketch, but segments that are too small can greatly increase the file size.

To create a freehand sketch:

1.0n the command line, enter SKETCH and press Enter.

2.At the "Record increment" prompt, enter the minimum line segment length.
3.Move the cursor to the drawing area, then click or enter p (pen)

to begin sketching.

4.Click or enter p (pen) again to lift the pen up and stop drawing,

M « » b “Model £ Layoutl / Layout?

so that you can move the cursor around the drawing area without drawing. fomand SETCH
¥ |Record increment < >
5.Enter R (Record) at any time to write into the drawing the line you're drawing o g oo Emse Comect 2
399 i rded. <Pen down
and those already drawn. 334,512, 13479513, 0 AP GRID ORTHO O

6.Press Enter to complete the sketch and write all lines into the drawing.

To erase freehand sketch lines:
1.While running the SKETCH command, enter E. If the pen was down, it moves up.
2.Move the cursor to the end of the line you drew last and then move it back as far

along the line as you want to erase. oo Mol (Tayout  [ayouz

¥ [Specify origin of UCS or [ZAds/3 points/OBject/Face/Mew/X/Y/Z] <0,0.0>

3.To end the erasure and return to the sketch Command prompt, enter E. If you want B Formand: SETCH

Record increment <3.0000:
to change the current viewport while sketching, make sure the pen is up and all lines e e e Come £
were written into the drawing.

Erase: Select end of delete

-7000. 4671, 0 SNAP  GRID ORTHO POLAR

Draw Curved Objects

Home Insert Annotation 3D Layout

Arcs: An arc is a portion of a circle. There are numerous ways to define an arc, the default
) ) ) ) ) ) ) u—r:) @ f"“ 1~ || $Move T
method uses three pick points, a start point, a second point and an end point. Using this & | B 4

Line Polyline Circe | Arc | .
B - || [\ extrude B

method, the arc will start at the first pick point, pass through the second point and end at the o=+ [,
third point. Once you have mastered the default method try some others: et 2 ~
Start, Center, End
-3 points -Start, Center, End -Start, Center, Angle (B, s ot g
-Start, Center, Length -Start, End, Angle -Start, End, Direction /7 EREIE T
-Start, End, Radius -Center, Start, End -Center, Start, Angle /7\‘: Start, End, Angle
-Center, Start, Length -Continue [/ sta,ena, pirection
) 2nd {I Start, End, Radius
To draw an arc by 3 points as sample: point .
D A int 1st 3rd :
raW ~ rc>3 pOI S pzlmt f\: Center, Start, Angle
1.Choose Draw > Arc > 3 Points from the main menu. L T . w5t s
2.Specify the start and second points. R — 1w
3.Specify the endpoint. B e

swap  oRID  oRTHO  pouar [EENGE IEIETNER
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Chapter 6 Create Objects

Circles: The default method for drawing a circle is to specify a center point and radius. W
R () S
Line Polyllne|[\r‘:re\ A-r: -t

You can draw circles using any of following methods:

e Center, Radius
4 Drawingl.dw

-Center, Radius ~ -Center, Diameter

Cen,Dia

-2 points -3 points 2point

3 Point

Tan, Tan, Radius

-Tangent, Tangent, Radius

CoOO000

Tan, Tan, Tan

-Tangent, Tangent, Tangent

Center MR
To draw a circle by specifying its center and radius: )|
Draw > Circle>Center, Radius ~ Command line>CIRCLE
1.Choose Draw > Circle > Center, Radius from the main menu. N R (Y (YT
2.Specify the center point. Bl o S or 23t 0Bt Focoows 7721 <00
ICommand: C
SSpemfy the radiUS Of the CirCle. CIRCLE Specify center point for circle or [3P/2P/Ttr/Arc/Mutiple]:

[Specty the radius o circle or [Diameter]:
5,0 SNAP GRID ORTHO POLAR [eiiEN]

To draw a circle tangent to existing objects:
Draw > Circle>Tan, Tan, Radius ~ Command line>CIRCLE

1.Choose Draw > Circle > Tan, Tan, Radius from the main menu.

2.Select the first tangent point on the object to be tangent with the circle. ety partcn abject for frt tangert f ccle:
pecify point on object for second tangent of circle:
3.Select the second tangent point on the object to be tangent with the circle. pecly radus of cicle: Specy second por

4-SpeCify the radius Of the CirCIB- -3.2505, 10.2104, 0 SNAP GRID ORTHO  P(

Ellipses: The default method for drawing an ellipse is to specify the endpoints of one axis of the ellipse, and then specify a
distance representing half the length of the second axis. The endpoints of the first axis determine the orientation of the ellipse.
You can draw ellipses using any of the following methods:  -Center ~ -Axis, End  -Ellipse, Arc

To draw an ellipse by specifying the axis and endpoints: i:gpoint
Draw > Ellipse>Axis  Command line>ELLIPSE .

endpoint
1.Choose Draw > Ellipse > Axis, End from the main menu.

1 4 » v Model /Layoutl /Layout?
2.Specify the first endpoint and second endpoint. -
. . . R "pa'jy;;s:spn‘lsr::;g:'\[a:emm] <Displacement>: Specty second point or <us

3.Specify a distance for half the length of the second axis. oyt

pecty axs endpoirt of elipse or [Ars/Carter]:

pecily other endpoint of ads
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To draw an elliptical arc by specifying the axis endpoints:

Draw > Ellipse>Arc

1.Choose Draw > Ellipse > Arc from the main menu.

2.Specify the first endpoint.
3.Specify the second endpoint.

4.Specify the half length of the other axis.

5.Specify the start angle of the arc.
6.Specify the end angle.

Splines: Spline is a smooth curve that passes through a series of control points. Multiple points are required for drawing
irregular splines than can be closed as well, so the start and endpoints are coincident and tangent. The tolerance in a spline,

Command line>ELLIPSE

2nd
endpoint

1st
endpoint

1 4 » » Model /Layoutl / Layout2

x
R

ISpecify axis endpoint of elipse or [Arc/Center:ARC
ISpecify axis endpoint of eliptical arc or [Center]
{Specify other endpoirt of ads:

(Specify distance to other axis or [Rotation]

ISpsciy start angle or [Parameter]: 15
ISpeciy end angle or [Parameter/Included angle]:

describes how precisely fits between multiple points (lower tolerance, more closely the spline fits the points). Usually there are

two ways to create splines:

-Create a spline converted from a polyline using Spline option of PEDIT command.

-Create a spline using SPLINE command.

To draw a spline:  Draw > Spline

1.Choose Draw > Spline from the main menu.

2.Specify the first point of the spline.

3.Specify the second point of the spline.
4 Specify as many more points as you want.

5.When you have finished, press Enter.

To draw a closed spline: Draw > Spline

1.Choose Draw > Spline from the main menu.

2.Specify the first point of the spline.

3.Specify the second point of the spline.
4 Specify as many more points as you want.

Command line>SPLINE

Command line > SPLINE

5.When you have finished, on the command line, type C and press Enter.

6.To complete the command, specify the tangent point.

M 4 » » 4 Model / Layoutl / Layout2

Command: spine

A {Unknown command "spine”. Press F1 for help.
Command: SPLINE

(Specify first point or [Object]):

(Specify next point:

ISpecify next paint or [Close/Fit tolerance] <start tangent>:
ISpecify next paint or [Close/Fit tolerance] <start tangent>:

-08.96 28,0 SNAP  GRID ORTHO

POLAI

4 b M Model £ Layoutl / Layout2

# ISpeciy next point or [Close/Fit tolerance] <start tangent>
& [specify next poirt or [Close/Fit tolerance] <start tangent >
Specify next point or [Close/Fit tolerance] <start tangent >
‘Specify next point or [Close/Fit tolerance] <start tangent>
'Speciy next point or [Closs/Fit tolerance] <start tangent:>
Specify next point or [Close/Fit tolerance] <start tangent>
iSpecfy next point or [Close./Fit tolerance] <start tangent>

-110.1425, 5.591, 0

i« 4 » » " Model {Layoutl /Layout2

X
n

pecity tangent

pecity next point or [Close/Fit tolerance] cstart tangert>
pecify next point or [Close./Fit tolerance] <start tangent>
pecy next point or [Close/Fit tolerance] <start tangent>
peciy neat point or [Close./Fit tolerance] <start tangert:
peciy neat point or [Close./Fit tolerance] <start tangert>: C

mand

SNAP GRID ORTHO

53



Chapter 6 Create Objects

Helix: Creates a 2D spiral or 3D spring. Initially, the default base radius is set to 1.

During a drawing session, the default value for the base radius is always the previously .
]

entered base radius value for any solid primitive or helix. The base radius and top

<=
radius cannot both be set to 0. @ -?‘
2,3

To draw a helix: Draw > Helix ~ Command line>HELIX
The following prompts are displayed: Number of turns = 3 (default) Twist = CCW (default)
1.Specify center point of base: Specify a point

2.Specify base radius or [Diameter] <1.0000>: Specify a base radius, enter d to specify the diameter, or press ENTER to
specify the default base radius value

3.Specify top radius or [Diameter] <1.0000>: Specify a top radius, enter d to specify the diameter, or press ENTER to
specify the default top radius value

4.Specify helix height or [Axis endpoint/Turns/turn Height/tWist] <1.0000>: Specify a helix height, or enter an option

Y
L *
4 4 » k' Model £ Layoutl ¢ Layout2 M 4 » M Model {Layoutl /Layout?
¥ Command: HELIX * Command:
& [Tums = 3.0000 Twist =CCW &~ STRETCH™
(Specify center poirt of base: Specify stretch point or [Base point/Copy//Undo/eXit]
Specify base radius or [Diameter] <12.6743>: Command: Specify opposite comer:
(Specify top radius or [Diameter] <5.5348> Command: “Cancel”
(Specify helix height or [Axds endpaint/ Tums/Aum Height/A\Wist] <30.0000::50 Command
Command: Command:

585.1905, -21.8049, 0 SMAP GRID ORTHO POLAR

636.1002, 238.1603, 0

Donut: Donuts are solid, filled circles or rings created as closed, wide polyline. The system variable FILLMODE controls
whether to fill the donut or not. FILLMODE is set to 1, creates filled donuts; if FILLMODE is set to 0, creates without filled.

To create a donut, you specify its inside and outside diameters and its center. You can continue creating multiple copies with
the same diameter by specifying different center points. To create solid-filled circles, just assign the same value for the inside
radius and outside radius.

To draw a donut: Draw > Donut ~ Command line>DONUT

1.Choose Draw > Donut from the main menu. ' Frzmi |
2.Specify the inside diameter of the donut. v
3.Specify the outside diameter of the donut.

M 4 » » < Model  Layoutl A Layout2

4.Specify the center of the donut. .
X . B 1Specify origin of UCS or [ZAds/3 points/OBject/Face/View/ X}/ Y/Z] <0,0,0>
5.Specify the center point to draw another donut, or press Enter to complete e erf conut <2000 10

Specify outside diameter of donut <2.0000>: 7
the command. Specky contr o drukor <o

Specify center of donut or <exit>

SMAP GRID ORTHO  POLAR
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Chapter 6 Create Objects

Create 3D Objects

With 3D models, you can: View entities in three dimensions, create three-dimensional entities, edit entities in
three-dimensional space, edit three-dimensional solids, display hidden-line and shaded views of three-dimensional entities.

3D Thickness and Elevation: By default, the program creates new two dimensional objects with a zero elevation and thickness.
The easiest way to create a three dimensional object is to change the elevation or thickness property of an existing two

dimensional object. You can extrude any two dimensional object into a three dimensional object by changing the thickness of
the object to a nonzero value. For example, a circle becomes a cylinder, a
line becomes a three dimensional plane, and a rectangle becomes a box.

To set the current elevation: Command line>CHANGE

1.Type CHANGE on the command line, and then press Enter after selecting
the two dimensional object(s).
2.Enter P (Properties) and press Enter.

3.Enter E (EleV) and press Enter. 2 g«??ri‘::f«E::ri‘:nogre[gfyég;Uqa/LTwemSca\e/LWaghtrrmdmess/Mater
jal/Annotative]: E
4.Specify a new elevation, and then press Enter. e ooy o shoree Kot/ v T e iSea oG ks e e

SNAP GRID ORTHO

To set the current thickness:
Command line>CHANGE

Command Line x
. Command: CHANGE o
1.Type CHANGE on the command line, and then press ] e et spocty comste comer.vuns
object:
Enter after selecting the two dimensional object(s). e ey o Liyer/LTypo N Scsl/LWeight Trckness Mot
. al/Annotative]: T
2.Enter P (Properties) and press Enter. Speciy new tHickness <0.0000>: 40
) || Enter property to change [Color/Blev/LAyer/| Type/t Scale/L Weight/Thickness/Mater
3.Enter T (Thickness) and press Enter. o Aenctsive) -
4.Specify a new Thickness, and then press Enter. || Ly Fomment _____
3D Faces: You can create a three dimensional T %
Command: 3DFACE -
face, which consists of a section of a plane in rechrictportor b,
ecify thi irt or [I le] <endt>:
three dimensional space. After you specify the o] oo s>
ible] <create three-sided face>: E
fourth point, the program continues to prompt rect ot port o e o oo idd o>

z pecify third point or [Invisibl 2
] <t < L

you for additional faces by alternating prompts v
for the third point and fourth point to allow you l<>< [Specly thid pomtor[[7701 | |
to build a complex three dimensional object.

To create a three dimensional face: Draw > Modeling>Meshes>3D Face ~ Command line>3DFACE

1.Type 3Dface on the command line.

2.Specify the first point of the three-dimensional face.

3.Specify the second, third, and fourth points.

4.Specify the third and fourth points for additional faces. =
5.To complete the command, press Enter. L<Y

x

-
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Ruled Surfaces: You can create a ruled surface, which is a three-dimensional body that approximates the surface between two
existing entities. You select the two entities that define the ruled surface. These entities can be arcs, circles, lines, points, or
polylines.

To create a ruled surface:

Draw > Modeling>Meshes>Ruled Mesh ~ Command line>RULESURF

1.Type RULESURF on the command line.

Command: RULESURF b
2.5elect the first defining object. et vfame derly: SURFTAGN-6 H
|Select second defining curve: -

3.Select the second defining object. Commard TR

Tabulated Surface: Tabulated surface meshes are used as a serial of paralleled polygon on specified path, you should draw
direction vector and original object before creating a tabulated surface. The objects like a line, arc, circle, ellipse, or 2D or 3D
polyline can be used as outline curves for defining polygons.

To create an extruded surface mesh:
Draw > Modeling>Meshes>Tabulated Mesh Command line>TABSURF

. Command Line
1.Type TABSURF on the command line. o TABSURE
. Cumrert wireframe density: SURFTAB1=6
2.Select the object to extrude. Scioct cbiect for peth curve:
Select object for direction vector:
3.Select the extrusion path. Fommand:

Revolved Surface: Use REVSURF command to create a surface of revolution by rotating a profile of the object about an axis. The
object to be revolved can be a line, arc, circle, ellipse, elliptical arc, closed polyline, polygon, closed spline or torus. REVSURF
is useful for surfaces with rotational symmetry.

To create a revolved surface mesh: Draw > Modeling>Meshes > Revolved Mesh Command line>REVSURF

1.Type REVSURF on the command line.

2.Select the object to revolve.

3.Select the object to be used as the axis of revolution.
4.Specify the starting angle.

5.Specify the number of degrees to revolve the object.

Command Line x
Command: REVSURF

Cument frame densities: SURFTAB1=6 SURFTAB2=6

ISelect objects to rotate:

[Select object that defines the ds of revolution:

[Specify start angle <0 360 |

ISpsciy included andle (+=cow, —cw) <3605 =
Command: <0 v
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Solid Box: A solid box consists of six rectangular surface planes. The base of the box is always parallel with the xy plane of the
current UCS. The length of the box is mapping to X axis of current UCS, and its width maps to Y axis, and height maps to Z axis.
RECTANG or PLINE command creates a rectangle or closed polyline from which you can create a box using EXTRUDE.

To create a box:

Draw > Modeling>Box Command line>BOX R

Command: BOX
Specify first comer or [Center]:
Specify other comer or [Cube/Length]:

1.Choose Draw > Modeling > Box from the main menu. Speciy height o [2Poin]
2.5pecify the first corner of the base. R
3.Specify the opposite corner of the base.

4.Specify the height.

Solid Cone: By default, the cone's bottom lies on the XY plane of the current UCS. The cone height is parallel to the Z axis. The
apex determines the height and orientation of the cone. You can draw a 2D circle and then use EXTRUDE to taper the circle at
an angle along the Z axis to create a solid cone. To complete the truncation, you can subtract a box from the tip of the cone with
the SUBTRACT command.

To create a cone:
Draw > Modeling>Cone  Command line>CONE eSS |

Command Line
[Specify center paint of base or [3P/2P/Ttr/Blliptical]. “Cancel®

{Command: “Cancel”
{Command: CONE
(Specify center paint of base or [3P /2P, Tir/Hliptical]

1.Choose Draw > Modeling > Cone from the main menu.
2.Specify the center of the base of the cone.

3.Specify the radius or diameter.

4.Specify the height.

peciy height or [2P/fxis endpoin
/Top radius) <66.4522>.

Solid Cylinder: You can create cylinders defined by a circular base. The base of a cylinder is always parallel with the xy plane of
the current UCS; the height of a cylinder is always parallel with the z axis. You can draw a circle and then use EXTRUDE to
create a solid cylinder.

To create a cylinder:
Draw > Modeling>Cylinder ~ Command line>CYLINDER

‘Command Line
[2dwireframe /3dwireframe./Hidden/Realistic/Conceptual /Other] <Conceptual>: _2
Regenerating model.

1.Choose Draw > Modeling > Cylinder from the main menu. Command: CYLINGER
pecify height or [2P/Axis endpoin
2.Specify the center of the base of the cylinder. 16112 2062>: <ORTHO On><GRTHO of }—

3.Specify the radius or diameter. '

4.Specify the height.
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Sphere; The latitude lines of a sphere are always parallel with the xy plane of the current UCS; the central axis is always parallel
with the z axis. You determine the size of a sphere by specifying either its radius or its diameter.

To create a sphere: Draw > Modeling>Sphere  Command line>SPHERE

LT

AL it
’ |Select object: Specify oppostte comer: 2found
/ [Select object:
Command: SPHERE
|Specify center paint or [3P/2P/Ttr]
[Specify radius or[Diameter]:

1.Choose Draw > Modeling > Sphere from the main menu.
2.Specify the center of the sphere.

Command:

3.Specify the radius or diameter.

Torus: A torus is constructed by revolving a circle about a line drawn in the plane of the circle and parallel with the z axis of the
current UCS. You determine the size of a torus by specifying its overall diameter or radius and the diameter or radius of the tube
(the circle being revolved).

To create a torus: Draw > Modeling>Torus Command line>TORUS

Command Line

Select object:

Command: TORUS

Specify center point or [3P/2P/Tir]:
(Specify raidus or[Diameter]:

[Specify tube radius or [2Point/Diameter]:

1.Choose Draw > Modeling > Torus from the main menu.
2.5pecify the center of the whole torus.

3.Specify the radius or diameter of the whole torus.

Command:

4.Specify the radius or diameter of the body of the torus.

Pyramid: You can create a tetrahedron (three-sided pyramid) or a four-sided pyramid. The base of the pyramid is always
parallel to the xy plane of the current UCS. You determine the size of the pyramid by specifying the base points and either the
apex, the corners of the top surface, or the endpoints of the ridge.

To create a pyramid: Draw > Modeling>Pyramid  Command line >PYRAMID

1. Choose Draw > Modeling > Pyramid from the main menu.
2. Specify the first point for the base of the pyramid.

Command Line

ICommand: PYRAMID

4 sides Inscribed Circumscribed

Specify center point of base or [Edge/Sides]:

[Specify base radius or [Inscribed] <32 .9466>:

ISpecify height or [2P/Auis endpoint/Top radius] <141 61943

3. Specify the second and third points.

4. In the prompt box, choose Tetrahedron.

ICommand:

5. Specify the apex of the tetrahedron.

Wedge: You can create three dimensional wedges consisting of five surface planes. You determine the size of the wedge by
gither specifying a second corner and the height; defining the wedge based on a cube having a given length; or specifying the
length, width, and height.

To create a wedge: Draw > Modeling>Wedge Command line>WEDGE

‘Command Line

[Speciy height or [2Point] <55.1953>: “Cancel®
Command: WEDGE

[Specify first comer or [Center]

ISpecify other comer or [Cube/Length]

1.Choose Draw > Modeling > Wedge from the main menu.
2.5pecify the first corner of the base.

|Specify height or [2Point] <55.1953>:

Command

3.Specify the opposite corner of the base.
4.Specify the height.
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Solids Extrude: EXTRUDE command, extrudes the profiles of the selected object along the chosen path to create solids. The
entities you can extrude are planar 3D faces, closed polylings, polygons, circles, ellipses, closed splines, donuts, and regions.
You cannot extrude objects contained within a block or polylines that have crossing or self-intersecting segments.

To create an extruded solid:
Draw > Modeling>Extrude ~ Command line>EXTRUDE

1.Choose Draw >Modeling >Extrude from the main menu.
2.Select the object to extrude.

3.Select the extrusion path, or specify the height.

Command Line
ICommand: EXTRUDE
ument wireframe density: ISOLINES=4
(Select objects to extrude: 1found
(Select objects to extrude
{Specify height of extrusion or [Direction/Path/Taper angle]
Command!

Solids Revolve: REVOLVE command revolves a 2D object to the specified certain angle to form solids. The revolving axis can
be X, Y axis of current UCS as well as lines, polylines. Objects can be revolved are closed polylines, polygons, rectangles,
circles, ellipses, regions and so on.

To create a revolved solid: Draw > Modeling>Revolve ~ Command line>REVOLVE

1.Choose Draw > Modeling > Revolve from the main menu.
2.Select the object to revolve.

3.Do one of the following to define the axis of revolution:
-Specify a start point and an end point.

-Type 0 and press Enter to select an object.

-Type x and press Enter to select the x axis.

-Type y and press Enter to select the y axis.

4 Specify the angle of revolution.

Command Bar x

[Command: REVOLVE -~
Select objects:Find out 1, total 1

Select objects:

Specify start point for axis of revelution o

r define axis by Object/Xaxis/Yaxis/Zaxis:
Specify endpoint of axis: ]
Specify angle of revolution <36@>:

Command: < [l G

Creating Composite Solids: You can create composite three-dimensional solids by combining, subtracting, and finding the
intersection of two or more solids. With UNION command, you can combine the total volume of two or more solids or two or
more regions into a composite object.

To combine solids: T

Modify> Solid Editing>Union  Command line>UNION \ fornd NN
1.Choose Modify> Solid Editing> Union from the main menu. '
2.Select the objects to combine.

To subtract solids:
Modify > Solid Editing>Subtract ~ Command line>SUBTRACT

Command Line

ommand: “Cancel®

[Command: SUBTRACT

ISelect solids, surfaces, and regigns e suptract from
ISelect object: 1 found ?ger&cf’
lSelect object

[Command

1.Choose Modify> Solid Editing>Subtract from the main menu.
the objects to subtract from one another.
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To intersect solids: Modify> Solid Editing>Intersect ~ Command line>INTERSECT

1.Choose Modify > Solids Editing >Intersect from the main menu.
2.Select the objects to intersect.

Command Line
mmand: “Cancel”
mmand: “Cancel™
mmand: INTERSECT
elect object: Speciy opposite comer: 2found
elect object
mmand.

Create Regions: You can convert a closed object into a two dimensional region. After you create a region, you can modify it
using the various three dimensional tools. You can create regions from closed objects, such as polylines, polygons, circles,
ellipses, closed splines, and donuts.

Command Line
- Command: REGION
o . A o Select object: Specify opposite comer: 6 found
To create a region: Draw> Region  Command line>REGION ~ =8 5 == =@ i

S H 1 loop extracted
] o o :
'._ _______ P i '.__ _____ H Created 1 region.
iand
Region

Layer O

1.Choose Draw > Region from the main menu.
2.Select the objects to create the region and press Enter.

Linetype Bylayer

Create Revision Cloud: REVCLOUD command, creates a polyline of sequential arcs to form a cloud-shaped object. You can
convert objects, such as a circle, ellipse, polyline, or spline, to a revision cloud. You can set the minimum and maximum
default values for the arc lengths of a revision cloud.

To create a revision cloud: Command line>REVCLOUD -
mmand: REVCLOUD
Minimum arc length: Masimum arc length: Style: Normal
pectfy start point or [Arc length/Chiect/Style] <Object>
wide crosshairs along doud path
Revision cloud firished

LWPolyline
Color Bylayer

mmand;

1.After type REVCLOUD command, specify the first point. {
2.Guide crosshairs along cloud path. e e [
3.Revision cloud finished (the device point is near to first point).

Create Break Line: Creates a polyline and inserts the breakline symbol. To use your own block for the breakline symbol, make
sure that the block contains two point objects on the Defpoints layer.

To create a revision cloud: Command line>BREAKLINE

Command Line
. [sXeNw) [eRoRe] lock = ize = ension =
1 Type BREAKLINE on the command line. [exeRe) [sXvLs] g‘[:e:ﬂyhﬁmﬂ:;:fo?::eiﬁne or ;B:}a‘lk?;ue/aqenzsg:/ﬁecwhr\eIerblea
line]
2.Specify first and second point for breakline. oo 008 [protemeribeie
{Command

3.Specify location for break symbol.

Create Wipeout: Wipeouts are created using existing polygons, closed zero-width polylines made up of only line segments, or
new polylines that you draw while using the WIPEQUT command.

=
Wipeout

To draw a wipeout: Draw>Wipeout Command line>WIPEQUT

Color Byl
olor Bylayer 1 Li

Layer 0
mmand; WIPEOUT
cify first poirt or [Frames/Polyine] <Palyiine>
Specify next paint:
Specify next paint or [Undo]
Specify next point or [Close/Undo]
Specify next point or [Close/Undol
mmand

Linetype Bylayer

1.Choose Draw > Wipeout from the main menu.
2.Specify the start point and endpoint of each segment. D D

[]

3.After specifying the last endpoint, press Enter.
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Modify Objects

You can easily modify the size, shape, and location of objects. You can either, enter a command first and then select the
objects to modify, or you can select the objects first and then enter a command to modify them.

Remove Objects: You can use ERASE command to delete objects, whatever the methods you use to select objects. To restore
the deleted objects, use UNDO command. You can remove objects using one of the following methods: Delete objects with
ERASE command, cut the selected objects to the clipboard, or press DELETE to remove the selected objects.

Copy Objects:  You can duplicate objects within the current drawing. The default method is to create a selection set and then
specify a base point, and a displacement point, for the copy. To copy objects at the specified distance, you can specify the
distance directly when the Ortho Mode or Polar Tracking is on.

Create only one copy of object one time:

1.Choose Modify > Copy from the main menu. e :""":"c::

2.Select the objects, and then press Enter. ettt Spckycpost come i

3.0n the command line, type O (mOde). ot bovopoet o Koo ] Dm0

4.0n the command line, type S (Single). — e ek e e Scoerts, ORTHOOms
5.Specify the base and displacement point. ecand oo st point s dsplcementl 1201 O8]

Create multiple copies for selected object one time:

1.Choose Modify > Copy from the main menu.

2.Select the objects, and then press Enter.

3.0n the command line, type O (mOde).

4.0n the command line, type M (Multiple).

5.Specify the base and displacement point of the first copy.
6.Specify the displacement point of the next copy.

7.To complete the command, press Enter.

Command Line

OPTOI DOeG O o |
Enter a copy mode opi
Specify base point or |
rst point as displacem:
'Specify second point ¢
'Specify second point ¢

Mirror Objects: You can specify a baseline to create a mirror image using MIRROR command. The mirror image is symmetrical
with the original one. So if you want to create a symmetrical objects, you only need to draw a half one, then create a full one
using MIRROR command.

' [ eeondpo ot mimerine ][ o]

To mirror objects: O O O T

mmand: “Cancel*

mmand: MIRROR
elect object: Specify opposite comer: 7 found

1.Choose Modify > Mirror from the main menu.

2.Select the object, and then press Enter. % SR Sty scotpare ot e
3.Specify the first and second point of the mirror line. ) ) )

4.0n the command line, if you want to retain the original objects, type N; if you want to delete the original objects, type Y.
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Offset an Object: You can use the offset to copy selected objects and align them offset to the original objects at a specified
distance. You can make offset objects using arcs, circles, ellipses, elliptical arcs, lines, two dimensional polylines, rays, and

infinite lines.

To make an offset copy by specifying the distance:

1.Choose Modify > Offset from the main menu.

2.Specify the distance (select two points or enter a distance).
3.Select the object to offset.

4.Specify on which side of the object to place the parallel copy.
5.Press Enter to complete the command.

To make an offset copy passing through a point:

m

1.Choose Modify > Offset from the main menu. )
2.0n the command line, type T (Through). . o .
3.Select the object to offset.
| ]

4 Specify the point for the object to pass through.
5.Press Enter to complete the command.

Command Bar

Command: OFFSET
Parallel:
Select objects:
[Both sides]<Side for parallel copy>:
Select objects:

[Through point]<Distance> <5::3

Command :

Command Bar

Command: OFFSET

Select objects:
Select objects:
Through point[More(M)]:M

Specify offset distance or [Through point]/<Distances:T

Command :

Create an Array of Objects: You can create copies of objects that array in rectangular or polar pattern. For rectangular arrays, you
can specify the number of rows and columns as well as the interval; for polar arrays, you can specify the number of copies of

the objects and determine whether the copies are
rotated.

To create a rectangular array:

1.Choose Modify > Array from the main menu.

2.In the Array dialog box, click Rectangular Array.
3.Click the Select Objects button, and then select
objects to array in your drawing.

4.In the Array dialog box, specify the row and column
offset distance and angle of offset.

5.Click OK.

OBIECT

To create a polar array:

OBJECT

1.Choose Modify > Array from the main menu.
2.In the Array tab, click Polar Array.

3.Click the Select Objects button, and then select
objects to array in your drawing.

@ Array |28
© Rectangular Arra ©) Polar Auray
o merenatu iy B 0, Select Dbiects
B rowe 3 M coumns: 3 1 objects selected
Dffset distance and direction
= oo
Row offset 20 5 =29
‘Column offset: 20
Angle of anay: 0
A% Bydefaul if the row offset is negative,
@ 1ows are added downward. | the column
offset is negative. columns are added to .
T ekt
@ Amay =5
(©) Bectangular Aray © Polar Aay EDE& Select Ohincts
Center point X 1128080 . 1331655 0 objects selected
Methods and Values
Method
Total number of fems & Angle to il -
Tota) number of items 8
Angle to fil 30
Angle betwesn items: 45
e Forangle taffil.a posiive valuz speciies
@ counterclockwise rotation. A negalive value
specifies clockuise rotaion
Tip
Rolate items a5 capied ¢
Object Base Poirt
et to object's default
Base point: ¥ 0 Y0 Preview <
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4.In the Array dialog box, choose Method and values you desired and click OK.

Move Objects: You can move objects to a new place without changing the objects. You can perform MOVE command and then
select object (1) to move; specify a base point (2) and Displacement point (3). The object is moved from point 2 to the point 3.

To move entities:

Command Bar
OBJECT Comnand: FOVE
1.Choose Modify > Move from the main menu. O oppocite. soner:Find out 1, total 1
o 1 geletlzz olbjects:‘ ) . .
2.Select the objects, and then press Enter. = ‘ Specify econd point of <uss First point ¢

[Specify second point or < use first point as displacement>: || ||<0°

3.Specify the base and displacement point.

To move an object using grips:

OBJECT -
1.Select the object. O P [Fpechy sueich pointor B[ IE <oz |
2.Click a grip to select it.

3.Drag the object to where you want to relocate it and press Click to release.

Rotate Objects: You can rotate the selected objects around a specified point. You can specify the rotated angle by specifying a
point on the drawing or entering the angle value directly. The direction that objects rotate depends on the value you enter is
positive or negative.

To rotate objects:

[Specify rotation angle o S| HEE [[<69° |

Command: ROTATE

. . OBJECT Select objects to rotate:
1.Choose Modify > Rotate from the main menu. @ Opposite corner:tind out 2, total 2

2.Select the objects, and then press Enter. Specify rotation ang
3.Specify the base point and rotation angle.

[ A Specify rotation angle or [Copy/Reference ] <B>:<Ortho off_
>

To rotate a selection set in reference to an Absolute Angle:

1.Choose Modify > Rotate from the main menu.

|
|Newangle<0>: ‘M ”490' | B =

2.Select the objects, and then press Enter. Select objacts to rotate:
) ) Opposite corner:Find Uut.2, total 2
3.Specify the base point. ; ; e e s
. e | Specify the Reference angle <6@>:
4.0n the command line, type R (Reference). New angle @>:

5.Specify the reference and new angle.

Align Objects: You can align objects with another through move or rotation with ALIGN command.

To align and object to other as reference:

. . , OBJECT
1.Choose Modify > Align from the main menu. @ / i

. Command: ALIGN
2.Select the object, and then press Enter. T [etet objectsctind out 2, total 3

i ; : [ o Specify first source point:
3.Specify the first source point. S opecify firet destination point:
‘Command :
4 Specify the destination point. DESTINATIO
OBJECT

5.Press Enter to finish the command.
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Scale Objects: You can use SCALE command to scale the proportionality of the selected objects. You can type a scale factor or
specify a base point and distance to zoom objects. A scale factor that is greater than 1 enlarges the object; and a scale factor
that is smaller than 1 shrinks the object.

To scale a selection set by a scale factor:

1.Choose Modify > Scale from the main menu. OBIECT Select abjects:Find aut 1, totol 1
2.Select he objects, and then press Ente. O] o e
3.Specify the base point. J{»

[specity scale factoror E|[ZEEE |[<270° |

4.Specify the scale factor.

Lengthen Objects: You can change the length of entities or the included angle of arcs. The results are similar to extending and
trimming. This command does not affect the closed entities.

To change the length of an object by dragging: OBJECT

1.0n the command line type LENGTHEN.

20n the Command Ilne’ type DY (DYnamm) Eﬁ:ﬁ?do]delact objects to changer: B

. cin e : namic a/Percent/Total]<Select objects to list length»: 1
3.Select the object you want to change. St e o g o poele F
4Specn(y the new endpoint or included angle. New start point for line: <[ v

Stretch Objects: When stretching objects, you have to specify a base point and displacement point. You should use crossing
selection to select the desired objects. With using grip edition, you can also stretch objects.

To stretch an object:

OBJECT
1.Choose Modify > Stretch from the main menu. @ ‘Oi——
2.Select the objects using either a crossing window ~ —— - e
ora Crossing p0|ygon’ and then press Enter. Z:i:: gg%:;::to stretch by crossing-window or crossing-polygon. .. &
Opposite corner:Find out 3, total 3

SspeCIfy the base pOint. ;:1::;:2:?;1“ or [Displacement] <Displacement>: I?
4 Specify the second point of displacement. :

|Specify second point or <use first point as displacements>: <&

To stretch an object using grips:

OBJECT 5 .
1.Select the object. -

2.Click a grip to activate it. Q
3.Drag the grip.
4.Click to release.

[pecity stretch point or |G |[<51° |
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Trim Objects: You can clip, or trim, objects so they end at one or more implied cutting edges defined by other objects. You

can trim arcs, circles, lines, unclosed polylines, and rays.
To trim an object;

1.Choose Modify > Trim from the main menu.

2.Select one or more cutting edges, and then press Enter.
3.Select the object to trim.

4.Press Enter to complete the command.

To trim several objects using the fence selection method.

1.Choose Modify > Trim from the main menu.

2.Select one or more cutting edges, and then press Enter.
3.0n the command line, type F (Fence).

4 Specify the first point of the fence.

5.Specify the second point of the fence.

6.Press Enter to complete the command.

-

[Fence/Crossing/Project/Edge/eRase/Undol
[Select object to trim or shift-select to extend or
[Fence/Crossing/Project /Edge/eRase/Undo]:

[Fence/Crossing/Project/Edge/e

o

Rase/Undo]

e e e e ol Sl

NN

----------

elect objects or <select all>:
elect object to tim or shift-select to extend or
[Fence/Crossing/Project/Edge/eRase/Unda]: FENCE

R

pecify next fence point or
Undo]:

1

< [ 3

Extend Objects: You can extend objects so that they end at a boundary defined by other objects. You can extend arcs, lines,
two-dimensional polylines, and rays. Arcs, circles, ellipses, lines, splines, polylines, rays, infinite lines, and viewports on a

Layout tab can act as boundary edges.
To extend an object:

1.Choose Modify > Extend from the main menu.

2.Select one or more objects as boundary edges, and then press Enter.
3.Select the object to extend, and press Enter to finish the command.

To extend an object to an implied boundary:

1.Choose Modify > Extend from the main menu.

2.Select one or more boundary edges, and then press Enter.

3.0n the command line, type E (Edge).
4.0n the command line, type E (Extend).
5.Select the object to extend, and press Enter to finish.

To extend several objects using the fence selection method:

1.Choose Modify > Extend from the main menu.

2.Select one or more boundary edges, and then press Enter.

3.0n the command line, type F (Fence).
4.Specify the first and second point of the fence.
5.Press Enter to complete the command.

[Fence/Crossing/Project/Edge/Undo]:

\Select object to extend or shift-select to trim or
[Fence/Crossing/Project/Edge/Undo]:

Undo]:

[Fence/Crossing/Project/Edge

N

[Fence/Crossing/Project/Edge/Undal:
elect object to extend or shift-select to tim or
[Fence/Crossing/Project/Edge/Undo]:

[

[Fence/Crossing/Project /Ed
e/Undo]: 4 /:l 1)

1

\

+ \

elect objects or <select all>;
elect object to extend or shift-select to tim or
[Fence/Crossing/Project/Edge/Unda]: FENCE

pecify nex fence point o
Undo]: g
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Create Breaks: You can break arcs, circles, ellipses, lines, polylines, rays, and infinite lines. When breaking entities, you must

specify two points for the break. By default, the point you use to select the entity becomes the first break point; however, you

can use the first break point option to select a break point different from the one that selects the entity.

To break an object:;

1.Choose Modify > Break from the main menu.
2.Select the object.
3.Specify the second break point.

To select an object and then specify the two break points:

1.Choose Modify > Break from the main menu.
2.Select the object.

3.0n the command line, type F (First point).

4 Specify the first and second break point.

50
[
i

€0
"
B

Command Line

[Select object

‘Specify first break point
'Specify second break poirt
Command.

‘Specty secand break poirt or [Frst paint]; FIRST

Command:

60

Create Chamfers: You can connect two nonparallel objects by extending or trimming them and then joining them with a line to
create a beveled edge. You can chamfer lines, polylines, rays, and infinite lines. When creating a chamfer, you can specify how
far to trim the objects back from their intersection (distance distance method), or you can specify the length of the chamfer and

the angle it forms along the first object (distance angle method).

When chamfering a polyline, you can chamfer multiple segments between two selected polyline segments, or you can chamfer

the entire polyline.

To chamfer two objects using the distance-distance method:

1.Choose Modify > Chamfer from the main menu.
2.0n the command line, type D (Distance).
3.Specify the first chamfer distance.

4.Specify the second chamfer distance.

5.Select the first object to chamfer.

6.Select the second object to chamfer.

To chamfer two objects using the distance-angle method:

1.Choose Modify > Chamfer from the main menu.
2.0n the command line, type A (Angle).

3.Specify chamfer length on the first line.

4 Specify chamfer angle from the first line.
5.Select the first object to chamfer.

6.Select the second object to chamfer.

Command Line
MMana; Lancel
ICommand: CHAMFER
["Trim" mode) Cument charmfer Dist1 = 20.0000, Dist2 = 20.0000
Select first line or [Undo/Polyine/Distance/Angle,/Trim/mEthod/Multiple]: D
[Specify first chamfer distance <20.0000>: 15
[Specify second chamfer distance <15.0000>:
ISelect first line or [Undo./Polyline/Distance./Angle. Trim/mEthod Multiple]
Select second line or shift-select to apply comer: “Cancel™
mmand:
ICommand:

Command Line

elect first line or [Undo/Polyline Distance,/Angle/ Trim/mEthod/Muliple]: ANGLE
pecify chamfer length on the first line: <0.0000>: 15
peciy chamfer angle from the fist ne <0>: 20
elect firstline or [Undo/Polyine Distance//Angle  Trim/mEthod Mutiple]:
elect second line or shiftsslect to apply comer:
mmand
HAMFER
"Trim" mode) Curent chaner Length = 15.0000, Angle = 20

mmand
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To chamfer selected vertices in a polyline:

1.Choose Modify > Chamfer from the main menu.
2.Select one polyline segment where you want to

begin the chamer. [ e
3.Select the other polyline segment where you want e I
to end the chamfer.

mmand: “Cancel*
mmand: CHAMFER
"Trim" mode) Cument chamfer Dist1 = 50 0000, Dist2 = 50.0000

elect first line o [U i gle/Tr iple]: D
pectyfirst chamfer distance <50.00005: 70
pecfy second chamfer distance <70.0000> 70

LwPolyline

To chamfer all vertices in a polyline: J— e

d Command: CHAMFER
------ S "Tiim" mode) Cument chamfer Dist1 = 5.0000, Dist2 = 5.0000
i ‘Select first line or [Uindo/Polyline/Distance/Angle./Trim/mEthod/Mutipie]: D
'Specify first chamfer distance <5.00005: 5
'Specify second chamfer distance <5.00005:
‘Select first line or [Lindo/Polyline/Distance/Angle./Trim/mEthod/Mutiple]: P

;

1.Choose Modify > Chamfer from the main menu.

LWPalyline

2.0n the command line, type P (Polyline). L coor coriso [ Fret i pante
Layer 0 Command:

Linetype ByLayer

3.Select the polyline.

Create Fillets: You can create a fillet using FILLET command. This command can apply to the objects such as arcs, circles,
ellipses, lines, polylines, rays, splines or construction lines. A fillet is an arc that connects two objects smoothly and has a
specified radius. An inside comer is called a fillet; an outside corner is called a round. Before creating fillets, you should
ensure the distance between each vertex is long enough to accommodate the fillet radius in order to insert a fillet arc. When the
fillet radius is set to 0, no fillet arcs are inserted. If two polyline segments are separated by one arc segments, system deletes
this arc segment and extends the lines to intersect with each other.

To fillet two objects:

mmand: “Cancel”
mmand: FILLET
ment settings: Mode = Trim, Radius = 0.0000
elect first object or [Undo/Polyline/Radius/ Trim/Muttiple]: RADIUS
pecify filet radius <0.0000>: 30
elect first object or [Undo/Polyline/Radius/Trim.Multiple]:
elect second object or shiftselect to apply comer

1.Choose Modify > Fillet from the main menu.
2.0n the command line, type R (Radius).
3.Specify the fillet radius.

4 Select the first and second object.

To fillet an entire polyline:
.

[Command: FILLET
KCurrent settings: Mode = Trim, Radius = 30.0000

elect first object or [Undo/Poline /Radius. Tim/Muliple]: R
Specty filet radius <30.0000>: 9

electfirst obiect or [Undo/Polyine /Radius. Trm/Muttple]: 9
Finvaiid selection”
Expects a point or Window/ Last/Crossing/BOX/Fenca/WPalygon/CPolygon/Alto/Undo/Pc
lyline./Racius/ Trim/Mutiple:

electfirst obiect or [Undo/Polyine /Radius. Tom/Muttple]: P
: elect 2D polyine:
B [7lines were fileted
Command

1.Choose Modify > Fillet from the main menu. B
2.0n the command line, type P (Polyling). ..
3.Select the polyline. :

To fillet selected vertices in a polyline:

1.Choose Modify > Fillet from the main menu.
2.Select one polyline segment where you want to
begin the fillet.

3.Select the other polyline segment where you want
to end the fillet.

Command: FILLET
Curent settings: Made = Trim, Radius = 30.0000

ISelect first object ar [Lndo/Polyiine/Radius/Trm/Mutiple]; RADIUS
ISpeciy fllt radius <30.00005 15

ISslect first abiect or [Undo/Polyiine/Radius.Trim/Mutiple]

|Select secand abject or shift select to apply comer.

(et second ot or et gy comer | 752 |
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Trim and Extend Filleted Objects: While performing fillet, you can select Trim
option to decide whether the selected edges are extended to the endpoints of
fillet arcs. By default, all objects except of circles, ellipses, closed polylines
and splines are trimmed or extended when performing filleting. FILLET>TRIM>TRIM FILLET>TRIM>NO TRIM

Fillet Line and Polyline Combinations: If the objects to fillet are a line and a
polyling, the line or its extension must be intersecting with one of the polyline ST
segments. With Trim option on, the filleted objects join with the filleted arc to .

Color Magenta

Linetype ByLayer PLINE & LINE
form a new polyline. PLINE & LINE ” FILLETED
Fillet Parallel Lines: You can fillet parallel lines, rays, and infinite lines. The first E—
entity must be a line or ray, the second entity can be a line, ray, or infinite line.
The diameter of the fillet arc is always equal to the distance between the parallel

. . o PARALLEL PARALLEL

entities. The current fillet radius is ignored. LINES LINES FILLETED

Disassociate Compound Objects: You can convert a complex entity, such as a block or polyline, from a single entity into its
component parts. Exploding a polyline, rectangle, donut, polygon, dimension, or leader reduces it to a collection of individual
line and arc entities that you can then modify individually. Blocks are converted to the individual entities, possibly including
other, nested blocks that composed the original entity.

4 Drawingldwg ’

EXPLODE EXPLODE EXPLODE EXPLODE
PLINES DIMENSIONS HATCHES BLOCK & ATTRIBUTES

N Ll ) FIR

4 Drawingldwg X 3

%/\/\/Lﬂq///%@ﬂﬂ

EXPLODE EXPLODE EXPLODE EXPLODE
PLINES DIMENSIONS HATCHES BLOCK & ATTRIBUTES

With the following exceptions, exploding an entity usually has no visible effect on a drawing:

-If the original polyline had a width, the width information is lost when you explode it.

-If you explode a block containing attributes, the attributes are lost, but the original attribute definitions are retained.

-Colors, linetypes, lineweights, and print styles assigned BYBLOCK may be different after exploding an entity, because they will
adopt the default color, linetype, lineweight, and print style until inserted into another block.
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Modify Polylines: Objects such as rectangles, polygons, and donuts, as well as three dimensional objects such as pyramids,
cylinders, and spheres, are all editable polylines. To modify a polyline, perform PEDIT command. The available options vary
depending on whether the selected polyline is a two dimensional or three dimensional object. If the selected object is not a
polyline, the Edit Polyline tool provides the option of turning it into one. You can convert only arcs and lines into polylines. If
several arcs or lings are joined endpoint to endpoint, they can all be selected and turned into one polyline.

Properties & =14  Drawingldwg x

No selection hd

General o
Color M ByLayer
Layer ]
Linetype — ByLayer
Linetype scale | 1
Lineweight — BylLayer
Thickness o

ek zation) = CLOSED PLINE OPEN PLINE WIDTH PLINE

Materials ByLayer
Shadow displa. | Shadow and receiy

View o

CerterX | 3670.1919

Center Y 352.2038

Center Z 0

Height 69.6622 ) |

ity TR - ’ | LWPalyline
Mi -

— PLINE TO SPLINE PLINE VERTEX coter Btayer
UCSicon On | Yes Layer 0
UCSiconato... Yes Linetype Bylayer
UCS per view...| Yes x
UCS Name M 4 b » - Model £ Layoutl 4 Layout?

Modify Multilines: You can use the methods such as common editing commands, a multiline editing command and multiline
styles to edit multilines or their elements. You can use MLEDIT command to add or delete vertices for a multiline, to control the
way two multilines intersected (cross and T shape that can be closed, open or merged), to add multiline style or set multilines
from the existing multiline style, such as the number of elements, color, linetype, lineweight and the offset of each element.

Drawingldwg x
@ Multiline Edit Tools ) S
Press ICON to use the tool Tooks must be selected before selecting targels.
Ml Edit Taols
Y A
NP, T i i i i
: H I |
. Closed Cross Closed Tee Comer Jaint Cut Single
= J= [ + Il G=]
i i == 1)
Ll Open Cross OpenTes Add Node Cut Al |
(_\J l, v T I J
I =F =IE -—-_ |.|
i i
Merged Cioss Marged Tee Delete Norde Weld 1
Y
®
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Notes and Labels

Create Text
Create text, multiline text (mtext) and text that includes one or more leader lines.

Single-Line Text: You can use TEXT command to create a single or multiline text. Each line text is an independent object which
can be modified. Before typing text, you can specify the text style and the way to align at the prompt of creating text.

Press ENTER if you have typed some characters, and then the command line prompts to input characters for the next row of text.
While creating single line text, you are also enabled to extend or compress certain single line text object in specified space to
meet with your need by means of selecting Align or Fit option from the TEXT command line prompt.

To create text:
1.Choose Draw > Text > Single Line Text from the main menu.

2.5pecify the start point for the text.
3.Specify the height of the text.

Command Line

Command: TEXT
Cumrent text style: "Standard” Test height: 8.3532 Annctative: Mo

4 Specify the text rotation angle. Specty stat point of text or Lusify./Siylel:
. ISpecify height <8.3532=: &
5.Type the text, and then press Enter at the end of each new line. Spety rotation angle of text <0>

6.To complete the command, press Enter again.

To specify the line text alignment:

1.Choose Draw > Text > Single Line Text from the main menu.

2.0n the command line, type J (Justify) and press ENTER. T g

‘Command Line
3.Type an alignment option BR to align text at its bottom-right comner. Specty s patof o r sty Seie] JUSTIFY
Enter an option [Align/Fit/Certer/Middle/Right/TL/TC/TR/ML/MC/MR/BL/BC/BR]: BR
. {Specfy bottom-ight point of text
4.Type the text, and then press Enter at the end of each new line. ooty gt
{Specify rotation angle of text <0
5.To complete the command, press Enter again. S

Multiline Text: Multiline text consists of one or more lines of text or paragraphs that fit within a boundary width that you specify.
When you create multiline text, you first determine the paragraph's boundary width by specifying the opposite corners of a
rectangle. The multiline text automatically wraps so that it fits within this rectangle. After defining the text frame, the system
opens the In-Place Text Editor, which is comprised of a text frame and the Text Formatting toolbar. You can type text in the text
frame and change the style from the Text Formatting toolbar.

To create multiline text: ) T ——— s
ultiline

1.Choose Draw > Text > Multiline Text from the main menu. Text sam ple

2.Select the first and second corner of the text area. EC —

3.In the Multiline Text window, type the text you want. mm%ﬂf’”sm Tethegt 5 Amoe: o

4.To create paragraphs, press Enter and continue typing. g et negacna R e
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On the toolbar, make format changes as follows:

1.To change the font of the selected text, select a font = Fp———

from the list. - HIEX A E Y :
2.To change the height of the selected text, enter a new ‘ﬁj“

value in the Height box. s

3.To apply color to the selected text, choose a color Multis :

from the Color list. Text sample

4 Click OK on the toolbar or Press <Ctrl + Enter>

Justify Multiline Text: You can specify the attachment point at the top left, top l;ﬁ; — ”ﬂﬁ Lﬂ: — ]"‘ =
center, top right, middle left, middle center, middle right, bottom left, bottom D e =
center, or bottom right. The multiline text can flow left to right, right to left, top MULTILINE

to bottom, or bottom to top. g

Format Characters within Multiline Text: During creating multiline text, you can
assign a new value to the selected objects to overlap the default setting. You can

specify underlines, bold, color and fonts for a single or multiple characters, or ) R
different text height. MULTILINE
=K

Indent Multiline Text and Use Tabs: You can control the appearance of text objects [+ — — +— —+ — A

and create a list by specifying the tap stops and indenting text. The arrowheads MUL TILINE

on the ruler are used to define the indent of text (first line and paragraph). L

Specify the Line Spacing: The line spacing of multiline texts is the distance T[j::ﬂ — Z30m er Jis B

between the baseline of one ling of text and the baseling of the next line of text. — Lkl LRt

You can right-click in the textbox and choose Paragraph to specify the desired MULTILINE ..

line space when the cursor stays on the text frame. o
ﬁPAﬂ!ME Gt s

Create Stacked Characters: Stacked text is text or fraction applied to mark tolerance or measure units. Before creating stacked
text, you have to use special characters to indicate the stacked place for the selected text. The following contents present the
special characters and illustrate how to create stacked text:

-Slash (/): Stacks text vertically and separates them with a horizontal line. slekls o "B /Ugaot iy
-Pound sign (#): Stacks text diagonally and separates them with a diagonal line.

-Carat (~): Creates a tolerance stack, which is stacked vertically as well as not S;[alcl‘(eld‘ 1‘ /4 ‘
separated by a line. You can also use Stack button on the toolbar to create 1
stacked text. Stacked 4
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Work with Text Styles: The text style is applied to the text objects. You can use text style to control the text font, size, angle,
direction and other features. By default, the current text style is STANDARD, and you have to make other text styles current when

you want to apply them. The STANDARD text style has the following default properties:

To create a text style:

1.Choose Format > Text Style from the main menu.
2.Click New, type a new text style name, and then click OK.
3.Under Text Measurements, specify the Text Height, Width
Factor, and Oblique Angle.

4. Under Text Font, select the name, style, you want to use.
5. Click Apply, and then click OK.

Create Leader

ra Text Style
Curent text style: Standard
Stes: Fort
— e —
o ol 5
e
Size
[7] Annotative: Height
[] Match text 00000
orientation to layout
lies, T)  Curent Style Name
- Width Factor
1.0000
ANaBbLc Obligue Angle
[C] Vetical [
[reey | [t | [CHen ]
'g Text Style X
Curent text style: NEW STYLE SAMPLE
L= Fort
e ] e
[@Aral Unicode MS v]  [Bold taiic -
[T Use Big Fort Delete
Sie
[] Match text 5.0000
orientation to layout
Bstyios, 7 [ curent Styie Name
. Widkh Factor:
1.0000
AaBbCec | = Qo e
[] Vertical 10l
(2o ] (oo | [ |

Leaders: A leader is a line or spline with arrowhead at one end, and annotations (Mtext, blocks as well as tolerance) at the other
end. Generally, you place an arrowhead at the first point. An annotation, created as dimension text, is placed immediately

adjacent to the last point.

To create a leader and an annotation:

1.Choose Dimension > Leader from the main menu.
2.Specify the starting point of the leader.

3.Specify the endpoint of the leader line segment.

4.Specify additional leader line segment endpoints.

5.After you specify the last endpoint, press Enter.

6.Type the annotation, and press Enter to enter the next line of
annotation text.

7.Press ENTER to complete the command.

next point or [Annotation/Format/Unda] <Annatation::
ify nexd point or [Annotation/Format./Undo] <Annotation:
ify next point or [Annotation/Format/Undo] <Annctation>: <ORTHO On>
ify nesd point or [Annotation/Format/Unde] <Annotation=:
next point or [Annotation/Format/Unda] <Annctation:
next point or [Annotation,/Format/Unde] <Annotation::
Erter first line of annotation text or <options>: LEADER
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Modify Text

Change Text: All of text objects can be moved, rotated, deleted and copied, just as like other objects. You can change the
properties at the Properties panel. You have two methods to modify single-line text:

-To modify only the content of text, use DDEDIT command.
-To change text style, location, size and content, use PROPERTIES command to open Properties palette, from which, you can
make the relevant settings.

To edit single or multiline text:

1.Type DDEDIT and then press Enter.

2.Select the single line or multiline text.

3.If select the single line text, the Edit Text box will pop up, edit the text and then press Enter.

4. 1f select the multiline text, the In-Place Text Editor will pop, edit the text according as you need.

Text Formatting
[ Stendard = | @Arial Unicode MS S *B [ Ugwv v & HR - | (=) ox | ®|
MIEIR zliEr aliE| @ | o 3w} of |
L 1=
Viodi
[Select an annotation object or [Undol.
f;?iﬁail Egréoéalnl‘?rn object or [Undo]: "Cancel®
Select an annotation object or [Undal]:
To change single or multiline text properties: Medifl "
= Repeat U
Recent Input ]
. . spe . & Mtext Edit...
1.Select a single line or multiline text object.
Clipboard »
2 Right-click the selected object and then click Properties on the shortcut menu. =
. . & Move
3.In the Properties palette, enter any new text in the Text Contents, and then change B Copy Seection
. . b Scale
formatting and other properties as needed. ) Rotate
Draw Order »
4.You can also do double-click on the multiline text to open the In-Place Text Editor, from B Growp
Deselect All
which, you can modify the contents and formats of text. o [mmere
@ QuickCalc
@ Find...
—_—
[Tee | =] [ ]
” bl ) m
NEW STYLE SAMPLE \L‘—I
e - = =
i ; o
OOl 0 Sty Standard
MODIFY == = - E
" T by ze
Annotative No -.
Line space factor 1
Line space distance 83333
Line space style At least
= Background mask No
Upside down No Defined with 224358
| Backward o Annotativ No
Defined height 11379

73
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Dimensions and Tolerances

Dimensions indicate the measurement values of objects (e.g. length or width), 3 1
distance or angles among objects, or the distance between feature point and the \ /
specified origin. You can create five basic types of dimensions: linear, angular, radial, 28

diametral and ordinate. Dimensions have several distinct elements: dimension text,
dimension lines, arrowheads, and extension lines.

1.Dimension text: A character string that usually indicates the measurement value, 4

includes prefixes, suffixes, tolerances, etc.

2.Dimension line: Indicates the direction and extent of a dimension. For linear dimensions, it displays as a line, for angular
dimensions, it displays as an arc segment.

3.Arrowhead: Usually displayed at both end of the dimension line. You can specify various sizes and shapes for arrowheads or
tick marks.

4 Extension lines: Extend from the object to the dimension line, in order to define dimension ranges.

Create Dimensions

You can create dimensions by selecting the entity to dimension and specifying the dimension line location, or by specifying the
extension line origins and the dimension line location.

Horizontal and Vertical Dimensions: As you create linear dimensions, the system automatically applies a horizontal or vertical
dimension depending on the specified extension line origins or the location where you select an object. However, you can
create a dimension by specifying it be horizontal or vertical.

To create a horizontal or vertical dimension: T —
=1
‘ |
1.Choose Dimension > Linear from the main menu. ﬂ I/ B
+
2.Press Enter, and then select the object to dimension. Or, you can specify  the 60 2
first and second extension line origins. Horizontal "
3.Specify the dimension line location. 0 . “

Create Aligned Dimensions: In the aligned dimensions, the dimension line is parallel to the line passing through the extension
line origins. The aligned dimension is also parallel to the objects you specify. The system creates the extension lines
automatically.

To create an aligned dimension:;

1.Choose Dimension > Aligned from the main menu.

2.Press Enter, and then select the object to dimension. Or, you can specify
the first and second extension line origins.

3.Specify the dimension line location.
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Create Baseline and Continued Dimensions: Both baseline and continued dimensions are multiple linear dimensions. Baseline
dimensions are measured from the dame baseline and continued dimensions are placed end to end. Before creating either
baseline or continued dimension, you have to create a linear, aligned, or angular dimension.

To create a linear baseline dimension:

- 60 -
1.Choose Dimension > Baseline from the main menu. » 40 o C
2.Specify a second extension line origin 20 B
3.Select the next extension line origin. e A -
4.Continue selecting extension line origins as required.
5.To end the command, press Enter twice.
To create a linear continued dimension:
1.Choose Dimension > Continue from the main menu. 20 _ 17 18
2.To select a starting dimension, press Enter. A B C

3.Select the next extension line origin, and then press Enter. Or press Enter, and
then select an existing dimension to continue.

5.To add continued dimensions, continue selecting extension ling origins.

6.To end the command, press Enter twice.

2

Create Rotated Dimensions: You can create rotated dimensions at a rotated angle you
specify using DIMLINEAR Rotated option. An example of a rotated dimension is shown
in the following illustration. In this illustration, the specified angle of the rotated
dimension is equal to the angle of the slot.

Create Angular Dimensions: Angular dimensions are used to measure the angle between lines or three points. You can
dimension objects including circles, arcs, and lines. When you create the angular dimension, you can modify the text contend
and alignment before placing the dimension line.

97°
To dimension an angle between two lines:
1.Choose Dimension > Angular from the main menu.
2.Select one line.
3.Select the other line.
4 Specify the dimension line location.
161°

To dimension an angle encompassed by an arc:

1.Choose Dimension > Angular from the main menu.
2.5elect the arc.
3.Specify the dimension arc location.
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Create Radial Dimensions: You can create radial dimensions for circles or arcs to measure ,{"1,
their radial. The radial dimension is a line with an arrowhead that points to a circle or arc. <

To create a radial dimension:

1.Choose Dimension > Radius from the main menu.
2.Select the arc or circle.
3.Specify the dimension line location.

Jogged Dimension: Jogged dimension is namely jogged radius dimension, which is also called "scaled radius dimension".
User can specify center position to place the origin of dimension for replacing center point of circle or arc within radius
dimension. DIMJOGGED command is useful for creating dimensions in case that the center of circle or arc to be dimensioned
is located outside the layout and can't be displayed in its actual position either.

To create a jogged radius dimension;

1.Choose Dimension > Jogged from the main menu. ,1/0
2.Select a circle or an arc. &
3.Select center position as the dimension origin.

4.Specify a point to position the jog symbol.

Create Diameter Dimensions: You can create diameter dimensions for circles or arcs to measure their diameters. Creating
diameter dimensions resembles creating radial dimensions. You can create various diameter dimensions based on the location
and size of circles or arc, and the settings of the dimension style.

To create a diameter dimension:
@as
1.Choose Dimension > Diameter from the main menu.
2.Select the arc or circle.
3.Specify the dimension line location.

Create Ordinate Dimensions: Ordinate dimensions are used to measure the perpendicular distance from an origin point called
the datum to a feature, such as a hole in a part. Ordinate dimensions are comprised of a leader line with an X or Y value, and
leaders are drawn along the orthographic direction at the current UCS.

3 ¥ § 7
AN g q = 5
To create an ordinate dimension: o " M
/ \\\
1.Choose Dimension > Ordinate from the main menu. 173384 . i
1726,27 4 3\ \ /
. . . . 17e6e7 | [ 1 ) -
2.Select the point for an ordinate dimension. — & al
3.Specify the ordinate leader endpoint| — __/ £
‘\ /
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Create Quick Dimension: Creates or edits a series of dimensions quickly by typing QDIM command.

To create a quick dimension:

1.Choose Dimension > Quick Dimension from the main menu.

2.Select the geometry to dimension, and then press Enter.

3.0n the command line, it will display "Specify dimension line position,
or[Continuous/Staggered/Baseline/Ordinate/Radius/Diameter/datumPoint
/Edit/seTtings] <Continuous>:". You can perform the operation as
desired. The default is Continuous.

20

17 |

18

A
J
!

1°

Create Arc Length Dimension: Arc length dimension is available for measuring the arc length of arc or polyline arc segment.
GstarCAD creates arc length dimension by specifying extension ling position directly after selecting arc by default. And use an
arc symbol as arc length dimension, which is differing from linear dimension and angular dimension.

To create an arc length dimension:

1.Choose Dimension > Arc Length from the main menu.
2.Select an arc or polyline arc segment.
3.Specify a point to position the arc length dimension.

Use Dimension Styles

Pt

40

You can control the appearance of dimensions by changing settings to help maintain dimensioning standards, you can store

these settings in dimension styles.

Dimension Styles: You can create, save, restore, and delete named dimension styles. Dimension styles provide a way for you to
change various settings that control the appearance of dimensions. You can change the following settings:
-Extension lines, dimension lines, arrowheads, center marks or lines, and the offsets between them.

-The positioning of the parts of the dimension in relation to one another and the orientation of the dimension text.
-The content and appearance of the dimension text and units of the dimension value.

To create a dimension style:

1.Choose Dimension > Style from the main menu.

2.In the Dimension Style Manager dialog box, click New.

3.Type the name of the new dimension style, and choose which style
started with and what kind of dimension used for. Then click Continue.
5.In the New Dimension Style dialog box, change the dimension
settings as necessary. Repeat this step for each tab, as needed.

6.To end the command, click OK.

@ Dimension Style Manager

Cumrent Dim Style: 150-25
Styles:

Preview of: 150-25

A Annotative
150-25
Standard

List

Dent it styles in Xrefs

14,11

e

16,6

Compare

~
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F New Dimension Style: NEW ST e T =)
Symbols and Arows | Text | Adiust | Primary Units | Atemate Units | Tolerance
Arows
First 14,14
= Closed filed hd
Secend: m\E }
= Closed filed hd o ?0)
- BEN
Azrr;wslze QS),"(\
Center maks Arc Symbol
© Nore 0 Freced\r!g dimension text
n Mk 25 :l;::e dimension text
i Radius jog dimension
Dimension Break Jog angle: 45
L Linear jog dimension
75 Jog height factor:
15 * Text height
[ok | [ Cencel | [ Hep
To rename a dimension style: Em e —
Curent Dim Style: NEW ST ENG
Styles: Preview of: NEW ST ENG
. . . & ggg;we Set Curent
1.Choose Dimension > Style from the mainmenu. | EEE ao. P
2.In the Styles list do one of the following: 3%
-Double click the required style. S
-Right click on the required style name, and then choose Rename. - —
3.Type the new name. —
4.Click Close to exit. =
{F Dimension Style Manager &1
To delete a named dimension style: T s
A Annotative Set Curent
1.Choose Dimension > Style from the main menu. -
2.In the Styles list, right click on the required style name, and then
choose Delete. = =
3.Click Close to close. LR
-Uose Help
To display information about the current style:
1.Choose Dimension > Style from the main menu. PP ow-. . ==
2.In the Dimension Style Manager dialog box, click Compare. o
. . . . . :
3.In the Compare Dimension Style dialog box, choose the same dimension style Bl— -
. . . . . . gead found 2 differences: ]
from the Compare and With pulldown list. All properties for specified dimension F— TR y—
. . Color of dimension line DIMCLRD ByBlock Green
Sty|e will be d|sp|ayed. Text colar DIMCLRT ByBlock Blue
4.1f you want to know the different information between two styles, choose one
style in the Compare box, choose the other in the With box, and then you will see =

difference in the following tab.
5.Click Close to close.
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Modify Dimension Lines: On the Line tab of the Modify Dimension
Style dialog box, you can set the color of dimension lines,
lineweight, ticks beyond extend line, baseline spacing, and visibility.

Modify Extension Lines: Extension lines have the following properties:
color, lineweight, distance beyond extension lines, offset from start
of extension lines, and visibility. You can set these properties on the
Line tab of the Modify Dimension Style box:

-The distance beyond extension lines means that how far the
extension lines extend beyond the dimension line.

-Start offset is the distance between the extension line origin and the
start of the extension line, also called extension origin offset.

@ Modify Dimension Style: NEW ST ENG

Lines | Symbols and Arows | Text | Adjust | Primary Units | Altemate Units | Tolerance |
Dimension Lines
Color. MGreen - 14,11
A — ByBlock -
Lineweight: — ByBlock -
Extend beyond ticks:
Baseline spacing: 375
Suppress: [] Dim line 1 [ Dimline 2
Edension lnes
Color By Biock ¥ Bitendbeyond dmlincs 125
Linetype ext line 1:  — ByBlock -

P Offet from orgin 0625
Linetype est line 2= — ByBlock -

[] Fixed length extension nes
Linewsight — ByBlock -
Length 1

Suppress [etine1  [JEtine2

ok | [ Cacel | |

Help

Choose Dimension Arrowheads: You can control the appearance and size of arrowheads or hook marks placed at the ends of

dimension lines. You can specify different arrowheads for both ends
of a dimension or leader lines. The First arrow is toward the first
extension line; The Second arrow is toward the second extension line.

To choose an arrowhead:

1.Choose Dimension > Style from the main menu.

2.In the Dimension Style Manager dialog box, select the style you
want to change and click Modify button.

3.In the Modify Dimension Style dialog box, click the Symbols and
Arrows tab.

4 Make your selections under the Arrowheads.

5.Click OK and then choose CLOSE to exit.

¥ Modify Dimension Style: NEW ST ENG

=

Lines | Symbols and Arows | Text | Adust | Primary Units | Atemate Units | Tolerance |

Amows

First:

= Closed filed -
Second:

BB Closed filed -
Leader:

BB Closed filed -

Arow size
25

Arc Symbol
@ Preceding dimension text

Center marks
(©) Nene

© Mark

O Line

25 Above dimension text

() None

Radius jog dimension
Dimension Break Jog angle: 45
Break size:

37

Linear jog dimension
Jog height factor

15

* Text height

ok | [ Camedd | |

Help

Fit Dimension Text within Extension Lines: When there is no enough space between extension lines to accept both of dimension
text and arrowheads, you have to adjust one or both of their placement. By default, the system fits them best depending on the

available space. You can specify other methods to place them on the
Adjust tab of the Modify Dimension Style dialog box.

To format dimensions:

1.Choose Dimension > Style.

2.In the Dimension Style Manager dialog box, select the style you wish
to change and choose Modify.

3.In the Modify Dimension Style dialog box, click the Adjust tab.
4.Under Fit Options and Text Placement, select an option.

5.Click OK and choose Close to exit.

@ Modify Dimension Style: NEW ST ENG

=)

Lines | Symbols and Amows | Text | Adust | Primary Units | Atemate Units | Tolerancs |

Fthere isnt enough room to piace both text and
amows inside extension lines. the first thing to
move outside the extension lines is

14,11
() Etthertext or amows (best fit)
© Amows
© Text

Fit options
ﬂ:
9
k1

Scale for dimension features

() Both text and amows

(©) Mways keep text between ext ines

] Suppress arows f they dont ft inside

[C] Annotative
Text postion (©) Scale dimensions to layout
]

When text is not in the defautt postion, place t ©) Use overal scale of:

®) Beside the dimension ine Fine Tuning
[7] Place text manualy

Draw dim line between ext lines

(©) Over dimension line. with leader

(©) Over dimension line. without leader

e

i

[ ok ] [ camee | |

Heo |
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Fit Diameter Dimension Text: You can create various diameter dimensions based on text placement, fit options and the selection
of "Always keep text between ext lines" option on the Adjust tab.

@37

Default horizontal
placement text outside

User defined horizontal
placement dimension line

Text and arrows inside
with inside horizontal

@ Modify Dimension Style: NEW DS FEG

circle, center mark,

no forced interior line forced interior line

and arrows, no center mark,

option selected

Symbols and Amows Adust | Pr

Fit options

If there isn't enough room to place both text and
amows inside extension lines, the first thing to
move outside the extension lines is:

() Etthertext or amows (best fit)

() Amows

© Text

(7 Both text and amows

| (@ Always keep text between ext lines

[ Suppress amows if they dont fit inside

Align Dimension Text: Whether the text is inside or outside the extension line, it has no effect on the justification of dimension

text. You can choose whether the text is align with the
dimension lines or remains horizontal.

To align dimension text with the dimension line:

1.Choose Dimension > Style.

2.In the Dimension Style Manager dialog box, select
the style you wish to change and choose Modify.
3.In the Modify Dimension Style dialog box, click the
Text tab.

4 Make your selections.

5.Click OK and choose Close to exit.

Position Dimension Text Vertically:

& Modity Dimension Style: NEW DS FEG

=20

The vertical text placement is the position of the

text relative to the dimension. You can place text
above, below, or centered within the dimension
line, or use the JIS dimensions.

Position Dimension Text Horizontally:
The position of text along the horizon is relation
to the extension lines. The settings include

Fraction height scale 1

Text alignment

Draw frame around text

Text position

Vertical Up e
Offset from dim line: -0.625 =

© Horizontal

() Migned with dimension line

() 180 standard

Centered, At Ext Line 1, At Ext Line 2, Over Ext
Line1, and Over Ext Line2.

[ ines | symbois and Amows | Text | Adjust | Prmary Units | Atemate Units | Tolerance |
Text appearance
Tt style: [stonderd ][]
Text color: HRed ~] L
Fil color MGreen E
Text height 25 =
Fraction height scale 1 o 37|
Draw frame around text Text alignment
T pe T ) Horizortal
Vettical [center |
®) Aligned with dmension line
View Direction: () 150 standard
Offset from dimline: 0625
ok ] [ cocet | [ hep =
@ Modity Dimension Style: NEW DS FEG =
| Lines | Symbols and Amows | Text | Agjust | Primary Units | Atemate Units | Tolerance |
Text appearance
S e
Text color: ERed -
Fill color DGreen -
Techag = - -

[ cancel |

[ Help b
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Dimension Units: You can determine the appearance and format of the primary and alternate dimension units. You can set the
primary units for linear and angular dimensions, including unit format, numeric precision and so on. These settings control the

display of dimension values.

To round off dimensions:

1.Choose Dimension > Style from the main menu.
2.In the Dimension Style Manager dialog box, select
the style you wish to change and choose Modify.
3.In the Modify Dimension Style dialog box, click the

Primary Units tab.

4 In the Linear Dimensions and Angular Dimensions
fields, type or select the nearest value to which you

want to round off dimensions.
5.Click OK and choose Close to exit.

& Modify Dimension Style: NEW DS FEG

Lnes | Symbols and Amows | Text [ Adust | Primary Units | Atemate Units | Toierance |

=

.

Suffe: Angular dimensions

Measurement scale Units format
Scalefactar: 1

7] Apply to layout dimensions oty

Precision. 0.00

Decimal Degress -

Zero suppression
[] Leading
Sub-unts factor
100 S

Zero suppression
[ Leading
[ Trailing

Traiing
0 Fest

Sub-uni suffc Uinches

[ ok | [ Cancsl | [ Heo |[F

Alternate Units: You can create a dimension in two systems of measurement simultaneously in a drawing. This feature is helpful
when you want to add feet and inches dimensions in a drawing created using metric units. The alternative units appear in a
square brackets ([]) in the dimension text. Alternative units can be applied to linear dimensions only. The precision for alternate

units determines the number of decimal places.

To create an alternate dimension:

1.Choose Dimension > Style.

2.In the Dimension Style Manager dialog
box, select the style you wish to change and
choose Modify.

3.In the Modify Dimension Style dialog box,
click the Alternate Units tab.

4.Click the Display Alternate Units check
box.

5.Make your selections.

6.Click OK and choose Close to exit.

@ Medify Dimension Style: NEW DS FEG

Lines | Symbols and Arows | Text | Adust | Pimary Units | Attemate Units | Tolerance |

Display altemate urits
Altemiate: Units

]

/’

Placement

Decimal -

Precision 00 -

Urit format
Muttiplierfor ah units: 0039370078 =
Round distances to 0

Prefic:

Suffic:

@
Zero suppression @ After primary value

[l Leading
Sub-units factor:
100

*) Below primary value

Tralling

0 Feet

0Inches

Sub-unit suffic

[ Cancel | [ Heb

Display Lateral Tolerances: Lateral tolerance represents a value that the amount a measured distance can vary. You can control
the degree of accuracy needed for a future by specifying tolerances in manufacturing. These dimension tolerances indicate the
largest and smallest permissible size. You can also apply geometric tolerances to indicate deviations of form, profile, location,

orientation, and runout.
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Deviation tolerances represent with the plus and minus values that are appended to the dimension values. If the deviation

tolerances are equal, the + signs precede them and they are known as symmetrical. Otherwise, the plus value locates above
the minus value.

The vertical placement of tolerance values that is relative to the main dimension text can be specified. For example, you can
align the tolerances with the top, middle, or bottom of the dimension text.

Limts
Upper value Basic

 Modify Dimension Style: NEW DS FEG - = ]
[ Lines | Symbols and Arows | Text | Adjust | Primary Units | Akemate Unis | Tolerance |
Tolerance fomat
Mabo = 14,120
lethox Symmetrical -
None SYMMETRICAL
Precision ‘ =
Deviation o]
D

HEPYAYS B —
e ’ 24 DEVIATION
7
Lower value: 0 = +0,5
i @\?' 24 - 0,6 24+0,5
Scaling for height: 1 =

Altemate unit tolerance

35+0,5 +0,5
Precision: -0,6 35 o

Align decimal

+
pLe

35-

) Align operational symbols Zero suppression

Zero suppression Leading Dfeet
[ Leading 0 Fest

Trailing Uinches TOP MIDDLE DOWN
[¥] Traiing 0 Inches

oKk | [ cencel | [ ke - | ‘ | ‘ | ‘

Set the Scale for Dimensions: Setting dimension scale depends on the method you use to lay out and plot drawings. Dimension
scale has effects on the size of dimension geometry relative to the objects in the drawing. In addition to text height and
arrowhead size, dimension scale affects offsets in dimension as well, such as the extension line origin offset. When you create
dimensions, it's recommended to set the size and offset to values that represent their actual plotted size. However, the

tolerances, measured lengths, coordinates, and angles cannot be applied to the overall scale factor. The method of creating
dimensions in a drawing layout is shown as follows:

-Dimension in model space for plotting in model space. If you want to create dimensions that are scaled correctly for plotting,

you have to set the system variable DIMSCALE to the inverse of the desired plot scale. For example, if the plot scale is 1/4, you
have to set DIMSCALE to 4.

-Dimension in model space for plotting in paper space. If you want to create dimensions that are scaled automatically for
display in a paper space layout, you have to set the DIMSCALE to 0. This method is useful when you encounter the following
situations: the dimensions in a drawing need to be referenced by other drawings (xrefs); when you create isometric dimensions
in 3D isometric views. To prevent the dimensions in one layout viewport from being displayed in other layout viewports, it's
recommended to create a dimensioning layer for each layout viewport that is frozen in all other layout viewports.

-Dimension in layouts. You can create dimensions in paper space by selecting model space objects or by specifying object

snap locations on model space objects. The dimensions created in a paper space layout do not need additional scaling: there is
no need to change the default value of DIMLFAC and DIMSCALE.
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Modify Existing Dimensions

You can modify all components of the existing dimension objects in a drawing either individually or by using dimension styles.

Modify Dimension Style:

You can modify all of properties of
the existing dimension objects in a
drawing using dimension styles.
You can also create a dimension
style override to temporarily
change a dimensioning system
variable without changing the
current dimension style. If a
dimension style is changed, the
dimension associated with that
dimension style updates
automatically.

Make Dimensions Obligue: Extension lines are normally created at a perpendicular
angle to the dimension line. You can change the angle of the extension lines,
however, so that they tilt relative to the dimension line.

To make oblique extension lines:

1.Choose Dimension > Oblique from the main menu.

@ Modity Dimension Styles NEW DS FEG

Lines | Symbols and Arows | Text | Adjust | Pamary Units | Atemate Units | Tolerance

@ Dimension Style Manager

52 Toleranes fomat
14,140

Wt [
Curent Dim Siyle: NEW DS FEG E
Sjes: Preview of: NEW DS FEG Precision i -
& Annotative Set Carert _ e
15025 14 140 Upper value [}
Standard Freniie o
g 5
4 ® oF
< i
E i Sealing for height 1
Compare — =
N
& Atemate unt tolerar
List: Description Precisi
Dont fst shfes in Yeefa N Leading fest
Trailing 0 Inches
—X

, ok ]

¥\ Meodel { Layoutl {Layout2

[ canesl | [ Hep

2.Select the linear dimension, and then press Enter.
3.Type the obliquing angle, and then press Enter.

Remark: To align the oblique angle if you don't know the exact measurement, use

snaps to pick two points on the entity.

Dimension Jogged Linear: The DIMJOGLINE command is available for
adding or removing jog symbol for linear dimensions. The jog symbol is
default to be placed at the center point between first extension line and
text. To relocate jog symbol, you can adjust the position of dimension
text or specify new position to locate jog after reselecting dimension.

To add a jog to linear dimension;

1.Choose Dimension > Jogged Linear from the main menu.

2.Select a linear dimension.

3.Specify a point on the dimension line to determine the jog symbol, or
press ENTER directly to position the jog symbol in default place.

I Modify Window Help  Express
[%#  Quick Dimension

[ Linear
%y, Aligned
&% ArcLength
'} Ordinate

= Radius 1
#) Jogged
(% Diameter
£ Angular

{57 Baseline
[ Continue

Help  Express

', Dimension Space
' Dimension Break

AL Leader
Tolerance... A
(#) Center Mark
Il Inspection

¥ Jogged Linear

[~ Oblique

Align Text »

£, Dimension Style.

ICAEEL] Modify Window  Help  Express
[ Quick Dimension

[ Linear
%, Aligned

& Arclength

52

‘}L Ordinate

(®) Radius
#) Jogged
(%) Diameter

A Angular
{5 Baseline

M1 Continue

|, Dimension Space
1 Dimension Break

52

A Leader

Hi Tolerance...
(¥) Center Mark
I7  Inspection

- Jn;;EdLmEar
/- Oblique

Align Text »

&, Dimension Style...

A Override

¥  Update
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Dimension Inspection: Dimension inspection is created to transmit the frequency of inspecting the part being dimensioned, the
dimension value and parts tolerance are ensured to be within specified range. Dimension inspection is composed by a frame
and internal text and contains utmost three kinds of information field: inspection tag, dimension value and inspection rate.

Inspection tag, used for mark the text of dimension inspection is located at the left side within the inspection frame.
Dimension value is the value before adding dimension inspection, which is located at the central part of the inspection
dimension including tolerance, text and measurement value.

Inspection rate is expressed by percentage, which is located at the right side within the inspection frame, indicates required
frequency of the part being created.

P r— ==

To create an inspection dimension: %:mml | BW,L

© Round [¥]Label
1.Choose Dimension > Inspect from the main menu. o ::mm
2.In the Inspection Dimension dialog box, click Select Dimensions button. - = 2
3.Select dimensions to add dimension inspection, and then press ENTER to finish _ =
selection and return to the dialog box. EX1]77,94]55%)
4.Select a shape for frame from the Shape option.
5.Click Label option to input label in the text box.
6.Click Inspection Rate option to input a value in the text box.
7.Click OK.
To remove an inspection dimension;

77,94

1.Choose Dimension > Inspect from the main menu.

2.In the Inspection Dimension dialog box, click Select Dimensions button.
3.Select dimensions to remove dimension inspection, and then press ENTER to
finish selection and return to the dialog box. 4.Click Remave Inspection button.
5.Click OK. - *

Adjust Dimension Space: Once you have created multiple paralleled linear dimensions or angular dimensions, you can adjust
the space among these paralleled lines with an equal value either default or specified. DIMSPACE command adjust the space
among paralleled linear or

. . 77,94
angular dimensions or
77,94 46,08
overlapped dimensions 48,08 1069
\ \ 40,65 . -
automatically in case that the e - -
o . 36,77 7 36,77 7
original space is not equal
values. If you set the space 7 7
value to 0 when adjusting space Z é
among dimensions, you can B N N

align selected dimensions at the
dimension line as well.
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Chapter 9 Dimensions and Tolerances

Add Geometric Tolerances

Geometric tolerances show acceptable deviations of form, profile, orientation, location, and runout of a feature. You add
geometric tolerances in feature control frames. These frames contain all the tolerance information for a single dimension.
Geometric tolerances can be created with or without leader lines, you can create them with TOLERANCE or LEADER
command.

®.505-.525

| & @.005@|A|D@|B|

\— Tertiary Datum
Datum Material

Conditien Modifier

A feature control frame consists of two or more components. The
first feature control frame contains a symbol that represents the
geometric characteristic to which a tolerance is being applied, for
example, location, profile, form, orientation, or runout. Form
tolerances control straightness, flatness, circularity and
cylindricity; profiles control line and surface. In the illustration,
the characteristic is position.

Secondary Datum

Primary Datum

Material Condition
Modifier

Tolerance

Diameter Symbol Indicating a
Cylindrical Tolerance Zone

Geometric Characteristic

Symbal

Geometric Tolerance Dialog Box: Specifies the symbols and values for a feature control frame.

Geometric Characteristics symbol (menu
Tol Zone form (t Iy) | | 123 4 .
olerance Zone form (toggle -
Tolerance zone value ~ ﬁ%"#"% ¢ ¢ ¢

Sym Tolerance 1 Tolerance 2 Datum 1 Datum 2 Datum 3
Material condition symbol (menu) 8 B ol | H:E:E =
Datum reference 1 of 3 g mm L = B ®E =

Projected Tolerance Zone: [ |

Height: 1.00

Datum reference 2 of 3 9 —JE
Projected tolerance zone symbol (toogle) ==
Projected tolerance zone value _
Datum identifier

© N o g W

Geometric Tolerance Symbols: The geometric tolerance symbols and their characteristics are shown in the following.

12. Profile of a line (Profile)
13. Circular runout (Runout)
14. Total runout (Runout)

Position (Location)

Concentricity or Coaxiality (Location)
Symmetry (Location)

Parallelism (Orientation)
Perpendicularity (Orientation)

./7

Angularity (Origntation)

Cylindricity (Orientation)
Flatness (Orientation)
Circularity or roundness (Form)

o =2 © 0o N o ok -

0. Straightness (Form)
1. Profile of a surface (Profile)

NN NN

11 12 13 14
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Chapter 9 Dimensions and Tolerances

Material Conditions: Depending on control type, you can add a diameter symbol prior to the tolerance value, and specify a
material condition symbol behind this value. You can apply material conditions to features that can vary in size.

Datum Reference Frames: A datum reference consists of values and modifying symbols. A datum is a theoretically exact
geometric reference that measures and verifies a theoretically exact point, axis, or plane. The system provides up to three datum
reference letters and relative symbols followed by the tolerance value.

Projected Tolerance Zones: Projected tolerance zones control the height of the fixed perpendicular part of the extension area,
and control tolerance accuracy by positional tolerances. Before you set the symbol to projected tolerance zones, you set a
height value to specify the minimum projected tolerance zone.

Composite Tolerances: A composite tolerance consists of two tolerances that applied to the same geometric characteristic of a
feature or for features that have different datum requirements. Before you create a dimension and add a composite tolerance for
a drawing, you have to specify the first line of a feature control frame and then choose the same geometric characteristic
symbol for the second line of the feature control frame. The specified geometric symbol compartment is extended over both
lines. Then you can create a second line of tolerance symbols.

To add a geometric tolerance:

1.Choose Dimension > Tolerance from the main menu.

2.In the Geometric Tolerance dialog box, click the first square under Sym and select a symbol to insert.
3.Under Tolerance 1, click the first black box to insert a diameter symbol.

4 In the Text box, type the first tolerance value.

5.To add a material condition, click the second black box and click a symbol to insert it.
6.Under Tolerance 2, repeat steps 3 through 5 to add a second tolerance value.

7.Under Datum 1, Datum 2 and Datum 3, enter the datum reference letter.

8.Click the black box to insert a material condition symbol for each datum reference.
9.In the Height box, type a projected tolerance zone height value, if appropriate.

10.To insert a projected tolerance zone symbol, click the Projected Tolerance Zone box.
11.In the Datum Identifier box, add a datum value and then click OK.

12.In the drawing, specify the location of the feature frame.

GEOMETRIC TOLERANCE SAMPLE DRAWING.dwg b

4Xd5,5
+gss@|gs2[als[c]
46.590 0,3
ABC
—-{l14,300 28,500
8 j {F Geometric Tolerance =23 |
2- J Sym  Tolerance 1 Tolerance 2 Datum1  Datum2  Detum3
o D == O B BEE: @BH: H:0:HcH
I HE Hn | | | |
s
S g 77777 Height: 03 Projected Tolerance Zone
® C—B o Datum dentifier: 'ABC
oK | Cancel |[ el |

10,970

57,010 8834

= {
LX =2 [ -A- ]

4 4 » M “Model / Layoutl / Layout2
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Chapter 10_ Blocks, Attribute and Xrefs

Blocks, Attribute and Xrefs

Create and Insert Blocks

Usually, blocks are several objects combined into one that you can insert into a drawing and manipulate as a single object.
Blocks can help you better organize your work, quickly create and revise drawings, and reduce drawing file size.

Create Blocks: Usually, blocks are several objects combined into one that you can insert into a drawing and manipulate as a
single object. A block can consist of visible objects such as lines, arcs, and circles, as well as visible or invisible data called
attributes. Blocks are stored as part of the drawing file. You can use several methods to create blocks:

-Combine objects to create a block definition in your current ’ _
draWing, {F Block Definition =

Tame 1
\ -

Base point Objects

-Create a drawing file and later insert it as a block in other

Behavior

dranngS [T Specify On-screen [7] Specify On-screen [[] Annetative
X 0 :;Saamm o [l Scale ur\:fmmry
To create a block for use within a current drawing: r oo . [S—
o 3 objects selected
. Settings Description
1.Choose Draw>Block> Make from the main menu. Blockunt
2.In the Block Definition dialog box, enter a block name in the
Name bOX. [7]Open in block editor 0K | [ Cancel | [ Hep
3.Click Pick point button to specify the insertion point for the
block in the drawing area. T
4.Click Select objects button to select the objects for the block, “ . “ iioom
. . Y _.' : Objects to Block "‘ “‘
then press Enter after selection. Then click OK button. g .
!_‘f:,...;:._.. ________________
A a

Create Nested Blocks: You can define blocks and other blocks as nested blocks so as to simplify the organization of
complicated blocks. With nested blocks, you can build a single block out of several components. But you should notice that
blocks that reference themselves cannot be inserted.

---------------------------------

--------------------------------
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Create Drawing Files for Use as Blocks: You can create a block as a separate drawing file that you can insert into other

drawings.
To save a block as a separate drawing file:

1.0n the command line, type WBLOCK.
2. Under Source area, choose one of the following:

-Block: Saves existing block object to a separate drawing file.
-Entire drawing: Saves the entire drawing to a separate drawing file.
-Objects: Saves those objects you select to a separate drawing file.

3. Under Destination area, type the name of the drawing file you want to

create and choose the saved path, click OK to save.

{F Write Block (=
Source
@) Block
() Entire drawing|
@ Objects
Base point Objects
(_';h Pick point [ | Select objects I8
X 0 (@) Retain
() Convert to block
Y 0 _
() Delete from drawing
]
= & No object selected
Destination
File name and path:
- [2)
Insert units: [Millirneter - ]
[ ok ][ cancel |[ Heb |

Change the Base Point of Drawings to Be Used as Blocks: When inserting a drawing file into another drawing as a block, by
default, system uses the origin (0,0,0) of WCS as the base insertion point. To specify different insertion point, you can use
BASE command. Next time you insert the same block, system uses the new insertion point by default.

Update Changes in the Original Drawing: Once the drawing file has been inserted into another drawing as a block, the original

drawing changes as well. But the block having been inserted will not change. If the block happens to change along with the
original drawing, you should attach it as external reference but not as a block.

Use Paper Space Objects in Blocks: Objects created in paper space are not contained in the block when it is being inserted into
the drawing. You can convert the objects in paper space as block or save as an individual drawing file before inserting into

other drawings.

Insert Blocks: You can insert blocks and other drawings into the current drawing. When you insert a block, it is treated as a

single object. When you insert a drawing, it is added to the current drawing as a block. You can then insert multiple instances

of the block without reloading the original drawing file. If you change the original drawing file, those changes have no effect on
the current drawing unless you redefine the block by reinserting the changed drawing.

To insert a block;

1.Choose Insert > Block from the main menu.

2.In the Insert Block dialog box, under Insert, click Block
Name.

3.In the Name box, select the name of the block you want
to insert.

4 If you want to use the pointing device to specify the
insertion point, scale, and rotation, select Specify
On-Screen. Otherwise, enter values in the Insertion Point,
Scale, and Rotation boxes.

5. Click OK to insert.

{3 Insert @
[ime ] O
Path
Locate using Geographic Data
Insertion Point Scale Rotation
Specify On-screen [7] Specify On-screen [~ Specify On-screen
0 X1 Angle i}
Y. 1
Block Unit
zZ 1 Unit: Milimeters
[C] Uniform Scale Fackas |
Explode [ ok ][ Caed ][ Heb
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To insert an entire drawing into the current drawing:

1.Choose Insert > Block from the main menu.

2.Click Browse to specify the file from the Insert Block dialog
box.

3.You can use the default insertion point, scale, and rotation
or select Specify On-Screen and enter values in the Insertion
Point, Scale, and Rotation boxes.

4.1f you want the objects in the block to be inserted as
individual objects instead of as a single block, select Explode.
Precondition is the block you created is allowed to explode.
5.Click OK to insert.

o Insert @
. - [ Q
Path
Locate using Geographic Data
Insertion Point Scale Rotation
[7] Specify On-screen [ Specify On-screen [ Specify On-screen
X 0 ® o Angle: 0
-1
ro 1t Block Unit
Z 0 z 1 Uriit Millimeters
[ Uniform Scale Factor 1
o) o] (8

Modify a Block Definition: You can redefine all instances of a block within the current drawing. To redefine a block that was
created in the current drawing, you create a new block using the same name. You can update all the blocks in the current
drawing by redefining the block. If the block was inserted from a separate drawing file that was subsequently updated, reinsert

that block to update all other instances in the current drawing.

To redefine a block in the current drawing:

1.Choose Draw > Block > Make from the main menu.

2.In the Block Definition dialog box, type the name of the block
you want to redefine in the Name box.

3.Click Pick point button to specify a point as the insertion
point for the block in the drawing area.

4.Click Select objects button to select the objects for the block,
and then press Enter after selection.

5.Click OK.

6.Click Yes in the prompt box that displays to redefine the
block in the current drawing.

Remove Block Definitions: Too many block definitions in a
drawing file may affect the drawing size. To reduce the size
of a drawing, you can remove unused block definitions.
Erasing a block reference from a drawing may delete the
block reference but retain the block definitions in the block
definition table. Using PURGE command can help
removing unused block references from your drawing in
order to reduce the drawing size. You should erase all
references from a block before you can purge the block
definition.

& Block Definition

Mame:

: =

Base point Objects Behavior

{F Block - Redefine Block

| "g"is already defined as a block. What do you want te do 7

Number of q block reference in the drawing:1
YYes: Redsfine block, Mo: Dont redefine block

EX5)

N e

OOjECts selected

Settings
Block unit

!

[ Open in block editor 0K

Description

Confirm each item to be purged

[]Purge nested items

Unnamed Objects

Purge Zero-ength geometry and empty text objects

puge | [ Pugeal | [ gose | [ Heb |
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Define and Use Block Attributes: An attribute is a particular object that you can save as part of a block definition. Attributes
consist of text-based data. You can use attributes to track such things as part numbers and prices. Attribute values are either
fixed or variable.

{5 Attribute Definition (==
To define an attribute: Mode Atrbute
[ Invisible Tag
] Constart Prompt:
1.Choose Draw>Block> Define Attributes from the main menu. [ verty '
. [] Preset Defautt: E
2.Under the Attribute, type the tag, prompt, and default text. ] Lok postion
3.Under Insertion Point, specify the location of the attribute, or [ Mutiple s o Seinss
click Specify on-screen to select a point in the drawing. e;‘:;f"y"::ﬁm Tetatis
4.Under Mode, select the optional attribute modes. v o Lless
, . Lo 2 - Teatt height: 30 (_';_i}
5.Under Text Settings, specify the text characteristics. v. [0 o . —q}
ion: &
6.To add the attribute to the drawing, do one of the following: z [o _ . =
Eoundary width: u (5&

-Click Define to add the attribute and keep the dialog box active =
. . [ Align below previous attribute definition
S0 you can define another attribute.

i ) ) ) [ ok | [ Cancal | [ Heb |
-Click Define and Exit to add the attribute and end the command.
To edit an attribute definition:

" it Attribute Definition (=)

1.0n the command line, type DDEDIT. Tag:
2.Select the attribute definition text to edit. Prompt: 80120
3.Modify the attribute tag, prompt and default in the Edit Attribute Defautt e
Definition that displays. ok ) [(cnes | [ Few

4.Click OK.

Modify Block Attributes: You can use the Block Attribute Manager
to modify attributes in block definitions. For example, you can

modify the following items:

Active Block: SF

Propeties

-Attributes of blocks can be displayed after modification.
-Text properties that define how attribute text is displayed in the

Mode Htioute
Invisble Tag: SOFA

Constant Frompt:  HOW MANY BODIES?

drawing. . g 0
-Properties that define the layer that the attribute is on and the —

attribute ling's color, weight, and type

R

Block name:SF

To edit an attribute attached to a block:

HOW MANY BODIES? 3 =]

1.0n the command line, type DDATTE.
2.Select the block to edit. The Edit Attributes dialog box displays all the
attributes attached to the block you select.

3.Edit the attribute values as necessary. Then click OK.
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Extract Block Attribute Data: Enter EATTEXT to start Attribute Extraction if the blocks [ & Atibsie Bssetion ==
in the drawing contain attributes. You can extract block information according to F';"m“: -
the wizard prompt and generate list so as to overview the attributes information of ©) Space Delmtd Fie (SOF)
the blocks. You can get guide information from the wizard until you accomplish DS
selecting drawings, blocks and block attributes. " eied Ot =] Found:0
Template File..
With the extract block attribute data function, you can easily create list using Drawing o
drawing data through extracting attribute information and export to external files. [ ok J[ Cancel | [ beb

Reference Other Drawing Files (Xrefs)

External references provide additional capabilities not available when you insert a drawing as a block. When you attach an
external reference, however, any changes you make to the original drawing file are reflected in the drawings that reference it.
External references are useful for assembling master drawings from component drawings. Use external references to coordinate
your work with others in a group. External references help reduce the drawing file size and ensure that you are always working
with the most recent version of a drawing.

Attach External References: When a drawing is attached to current drawing as external reference, it will be linked to the drawing,
any changes to the referenced drawing may affect the external reference in current drawing. External references are inserted into
the drawing as block definitions and used as single objects, but you should distinguish the external references and blocks.

To attach an external reference:

1.Choose Insert>External References from the main menu.

2.Click the DWG icon at the top left of the window.

3.In the Select Reference File dialog box, specify the drawing file to attach and then click Open.

4.In the External Reference dialog box, under Reference Type, choose how you want to insert the drawing:
-Attachment: Inserts a copy of the drawing and includes any other drawings references.

-Overlay: Lays a copy of a drawing over your original drawing

5.Make any additional selections and then click OK.

6.1f you marked Specify On-screen for any items, follow the prompts to attach the external reference.

External Reference %
ffffffffffffffffffffffffffffffffffffff s
Elo-
Name [BLocks 2 v [ Bowse | File References &)
-es Reference Name Status Size
B PREVIEW cale Path type T . -
Spaciy Ons M Drawing pene
1 Specty fh Blocks 2 Loaded 163,30 KB
x 100 Full paih h E® BLOCKS 2|DYNAMICBLOCKE  Notreferenced 0.00 KB
,,,,,,,, £ BLOCKS 2IDYNAMICBLOCKE  Unloaded
1.00
¥ Rotation
z 10 [7] Specty On-screen
External Reference R
« i ’
Color Bylaye [T Uniform Scale Angle: 0
Layer 0 nsettion Point i
Linetype Bylayer
ype Byt [F] Specify On-screen Block Unit Refere
Status
X 000
Reference Type Unit Undefined - Un size
16 Attachment ) Overay v, 000 Type
Factor: 1 DATE
z 000 Save path
Locate using Geographic C Found At
Show Detais oK | [ Canedl | [ Hep
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Control the Properties of Referenced Layers:
You can control the visibility, color,
linetype, and other properties of an xref's

e

layers and make these changes temporary
or permanent. If the VISRETAIN variable
is set to 0, these changes apply only to
the current drawing session. You can also
control the fade display

through XDWGFADECTL variable. In

»

§ e
BLOCKS 2-Copy ) ©F [
BLOCKS 2-Copy &) & [
BLOCKS 2-Copy ) L @' O Yelo
BLOCKS 2-Copy )
BLOCKS 2-Copy 8]
BLOCKS 2-Copy
BLOCKS 2-Copy )

Linetype Lineweight

uuuuuu

BLOCKS 2-Copy %) @ O Yelo. Continuous —— Defaut
BLOCKS 2-Copy ) CF @' [ Green Cortinuous Defaut
BLOCKS 2-Copy %) o me Continuous —— Defaut
BLOCKS2-Copy ) ¢ ' %4  Corfinuous Defaut
BLOCKS2-Copy ) 0 i W62  Continuous Defautt
BLOCKS2-Copy ) ¢ @' EWhie Continuous —— Defaut
BLOCKS2-Copy ) F ' MIWhts Contruous Defaut
BLOCKS2-Copy ) 0 @' M132  Confinuous —— Defaut
BLOCKS 2-Copy U % @' [ Yelo.. Contruous Defaut

addition you can control Xref layer

@~ Al Shows 34 layers, otal 3 layers

properties directly into the Layer Manager
Properties dialog box.

Xref Clipping Boundaries: You can control whether to display clipping boundary of xref through setting system variable

XCLIPFRAME. Also you can Clip Xrefs by selecting the option on the menu bar: Modify>C

Modity [T

XN

=

Offset
Array

Move
Rotate
Scale
Stretch
Lengthen

SNPHECe B

lip>Xref

Trim
Extend
Break
Join
Chamfer
Fillet

R R

3D Operations
Solid Editing

Change Space

#

Explode

Nest and Overlay External References: Xrefs can be nested in another xref and attached to current drawing. In the process of

attaching, you can select insertion position, scaling factor and rotation angle for xrefs.

External Reference x
Binding an Xref to a Drawing: To provide a copy of a drawing containing external & -
references to someone else, you must also provide all the external reference files.
Binding the external references makes them a permanent % e
. . L . . {F Bind Xrefs ‘ == ] Ope Not referenced 159
part of the drawing, which is similar to inserting a separate ... —— | |& Attach.. loaded 163,
. . Ef"‘ TWe Cox ] B Unioad Not referenced 001 |
drawing as a block. You can bind external references by o =l i Rl Mot 0.«
. . . . ) Insert ,:u Detach . . '
doing right click to the selected Xref file. | Bind..

Refresh Xrefs: You can refresh the Xref by clicking the refresh button located at the top of
the External Reference Dialog Box.

Ci\sers\asus|Desktop\for help documentation. .
Ci\Users\msus|Desktop\for help documentation. .

Reference ... for help documentation
Status Loaded

Size 56,10 KB

Type Overlay

DATE 20130516 10:34:11
Save path

Found At

Nested reference selected: Cannot change path, name. ortype.
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Hatches and Raster Images

Hatches

Define Hatch Boundary: To create a hatch, you should define hatch boundaries first by means of selecting objects to be hatched
or picking a point inside the desired object. A hatch boundary can be any combination of objects, such as lines, arcs, circles,

and polylines that forms an enclosed area.

Control the Hatching in Islands: You can specify methods of hatching objects in outermost boundary as normal, outer and
ignore. Normal is the default hatch pattern, besides, you can view hatching results of different types in the Islands area on Hatch

tab of the Hatch and Gradient dialog box.

|  Hatch and Gradient
[ Hatch | Gradient | Boundaries slands

Type and pattem Add: Pick points 9] lslnd detection
Normal: Hatch the pattern from the outer boundary to e R _
P . . Pattem: ANSI3T -] ;/6”/4‘ ;/@"/4 72X
inside. Hatching process will be stopped when encounter - T ) 52y KOy 677
inner crossing points, and continue hatching until second =
i i i Ang;and = Scal ] Retain boundaries
inner crossing point appears. . : . —

Dogble Tt D Aarotative Boundary set
. . 1 i;:j:mmm e

Outer: Hatch from the outer most layer of configuration, Comie ot
and keep the internal blank. e -

©) Speciied n;\gm nhet Propeties ® Use curent origin
lgnore: Ignore internal objects, only hatches outer ek
ObJeCtS Store as defauk origin

Previ K Help «

To select objects for hatching:

1.Choose Draw > Hatch from the main menu.
2.From the Hatch and Gradient dialog box, click the Island detection option, and then choose one of the following islands:
Normal, Outer, Ignore:

o)

OUTER ISLAND

NORMAL ISLAND IGNORE ISLAND

3.To keep any new objects that are created for drawing the boundary hatch, select the Retain Boundaries check box under Other
options. Existing objects are always retained.

4.In the Boundaries, click Select Objects button.

5.In the drawing, click the objects to be hatched individually, and then press Enter when done.

6.In the Hatch and Gradient dialog box, click OK.

93



Chapter 11_ Hatches and Raster Images

Select an area for hatching:

1.Choose Draw > Hatch from the main menu.

2.From the Hatch and Gradient dialog box, click the Island detection option, and then choose one of the following islands:

Normal, Outer or Ignore.

L

%

©

OUTER ISLAND

NORMAL ISLAND

1

_

IGNORE ISLAND

3.To keep any new objects that are created for drawing the boundary hatch, select the Retain Boundaries check box under Other

options. Existing objects are always retained.
4.In the Boundaries, click Pick Points button.

5.In the drawing, click inside the closed perimeter of a boundary. If desired, continue clicking inside additional closed

perimeters.
6.To complete the selection, press Enter. Then click OK button.

Choose and Define Hatch Patterns: Hatch pattern consists of a repeating
pattern of lines, dashes, and dots. You can select a hatch pattern from a set
of predefined patterns, or you can define a pattern of your own. The hatch
pattern you used most recently is the default pattern the next time you add
hatching. The program supplies predefined standard hatch patterns, which
are stored in the ICAD.pat and ICADISO.pat hatch pattern library files.

To specify a predefined hatch pattern:

1.Choose Draw > Hatch from the main menu.

2.In the Hatch and Gradient dialog box, click the Hatch tab.
3.Beside Type, click Predefined to apply a scale factor to make the pattern
larger or smaller than the default size.

4 Enter the scale factor as a percentage of the default.
5.Enter the angle in degrees (1-360). The default angle is
clockwise, you can change the angle of any hatch pattern by
entering a numerical value.

6.Enter the ISO pen width. This option is only available if you
select existing 1SO hatch pattern in the Pattern option.

Hatch | Gradient

Type and pattem

Type:
Pattem:

Swatch

Predefined -

150120100+ [

Angle and scals
Angle:
15 -

Double

150 pen width

Hatch origin
©) Use current origin
*) Specified origin

Store as defautt origin

Boundaries
Add: Pick points
Add: Select objects

Options

[C] Apnotative

[¥] Associative

[| Create separate hatches

Draw order.

Behind boundary. -

Inhert Propertiss

7.To copy the pattern properties from an existing hatch,

choose Inherit Properties.

8.To associate the hatch pattern to its boundary objects, under Other options, select the Associative check box. An associative

hatch updates automatically if you move any of its boundaries.

9.To continue, add a hatch by selecting objects or picking points to selected area or boundary you want to hatch.
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To specify a user-defined hatch pattern:

1.Choose Draw > Hatch from the main menu.

2.From the Hatch and Gradient dialog box, click the Hatch
3.Beside Type, in the Type list, click User Defined.

4.For Spacing, enter the line spacing for the pattern.

5.To copy the pattern properties from an existing hatch, choose Inherit
Properties, and select a hatch pattern from a hatched object in the drawing.
6.To associate the hatch pattern to its boundary objects, under Other options,
select the Associative check box. An associative hatch updates automatically

if you move any of its boundaries.

7. To continue, add a hatch by selecting objects or picking points to selected

area or boundary you want to hatch.

To use a predefined library pattern:

1.Choose Draw > Hatch from the main menu.

2.Click the Hatch tab.

3.Select a Predefined type.

4.To select a predefined pattern, do one of the following:
-In the Pattern list, click the pattern name.

-Click the graphical representation of the hatch pattern.

5. To continue, add a hatch by selecting objects or picking
points to selected area or boundary you want to hatch.

tab.

[ et | Gradent|
Type and pattem
-
ANSI31
Swatch:

Angle and scale

Angle: Scale:

15 AT -
Double Relative to paper spe
Spaging: 4
Hatch origin

@ Use curent origin
©) Speciied origin

Defaut to boundary extents
BL

Store as default origin

Boundaries

Add: Pick points
Add: Select objects

X

Options

[ Aonotative

Associative

|| Create separate hatches
Drayw order:

Behind boundary -

Inhet Propeies

Help »

Boundaries

Add: Pick poirs

[T3] Add: Select obiects

Hatch | Gradient

Type and pattem

Predefined =
ANSI31 <]

GCAD_ISO12W10 »
ANSI31

Type

Pattem:

Swatch:
ANSI | IS0

(ot

Other Predefined | Custom

SOLD
ANGLE
ANSI31
ANSI32
o ANsiE3
ANSI34
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Angle and scale
Angle:
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ANSI35
ANSI36
ANSI37
ANSI38
ARBBIE
AR-BBIEC
AR-B88
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() Specfiedorign ~ ARBRSTD
ARCONC
AR-HBONE
Default to bouncAR-PARQ1
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AR-B88
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R B
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=
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AR-RSHKE
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BRASS
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CLAY
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Solid: With the Plane tool, you can draw rectangular, triangular, or quadrilateral areas filled with a solid color. The default
method is to specify the comners of the plane. After you specify the first two corners, the plane is displayed as you specify the

remaining corners. The program
prompts you for the third point and
then the fourth point.

Modeling »

Line
Ray

Construction Line
Mulline

To draw a quadrilateral plane: e

FOORL 2%\

Arc 3

® H+B ¢0TOECHPR

1.Choose Draw > Modeling >
Meshes> 2D Solid

Circle 3

e

Donut
Spline

Ellipse »

Sphere
Cylinder
Torus
Pyramid
Exrude
Rotate
Sweep
Loft

Section Plane

Meshes

Setup

[P0 Dimension Modify Window Help Express

Command Line.

mmand: _SOLID
2D Solid(@)
30 Face

pecily third poirt:

Block »

2.5pecify the first, second, third and
fourth point.
6.Finish the command, press Enter.

Point 3
Hatch...

Gradient..
Boundary..
Region
Wipeout

on Cloud

owpuon ®

Revisi

Text »

3D Mesh pecify fourth poirt or <exdt>:
peciy third point:
peciy fourth poirt or <ext>:
peciy third point:
peciy fourth poirt or <ext>:
pecty third poit:

Revolved Mesh
Tabulated Mesh
Ruled Mesh

or® 4 ed

Command:
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Work with Raster Images

You can view and manipulate raster images and associated file paths in your drawings.

Attach, Scale, and Detach Raster Images:

Raster images consist of a rectangular grid of small
squares or dots known as pixels. Raster images can
be copied, moved, or clipped as well as a normal
object in the drawing. You can also adjust the
contrast, transparency, image quality and image
frame visibility. Additionally, when inserting raster
images, the file format depends on the content of
the file rather than the extension name. The
following table display all the image file formats
supported:

Attach Raster Images: Use IMAGEATTACH command to select and attach raster images, or bitonal, 8-bit gray, 8-bit color, or
24-bit color image files to a drawing. The image file can be inserted as blocks as many times as you like once attached to the
current drawing, you can clip the attached raster image and setup its lightness, contrast, fading and transparency.

To attach a raster image:

1.Choose Insert > Raster Image from the main menu.
2.Specify a file to attach, and then click OK.

3.In the Image dialog box, in the Insertion point and Scale, click
Specify on-screen. Specify an angle value in Rotation, and then
click OK.

4.Specify an insertion point.

5.Specify a scale.

Scale Raster Images: You can specify scale factor in the Image dialog box, otherwise to
attach it by its original size. The raster image will be scaled by the specified factor, the
scale factor is used without unit by default.

Detach Raster Images: Raster images can be detached if it no longer needs to use in
the drawing, a specified image detached from the drawing together with its multiple
copies, links and definitions, but the original image file will not be influgnced.

Modify and Manage Raster Images: Controls the properties such as displaying and clipping boundary of raster images. You can
view and manipulate attached raster image and change its saving path in Image Manager. Users can turn on/off image boundary
in current view using IMAGEFRAME command and setting up the values 0 (off) 1(on).
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Chapter 11_ Hatches and Raster Images

To turn image frames on or off for all images:

1.Choose Modify >0bject> Image> Frame

2.Do one of the following to toggle frames off and on:
-Type value 1 to display and print frames for all images
ina drawing.

-Type value 0 to hide all frames on the screen and

during printing.

To clip an image in the shape of a rectangle and polygon:

1.Choose Modify>Clip> Image

2.Select the edge of the image you want to clip.

3.Type N (New boundary) to create a new clipping boundary.

4 If you choose Rectangular:

-Define the first corner of the clipping rectangle.

-Define the second corner of the clipping rectangle. The selected

image is clipped so that only the interior of the rectangle is visible.

5.1 you choose Polygon:

-Select the points for the polygon, and then press Enter when the
polygon is complete. The selected image is clipped so only the
interior of the polygon is visible.

4

EFTS

EF1C 4 B8k

—
=

o
4

Properties
Match Properties
Object

Clip

Erase
Copy
Mirror
Offset
Armay

Move
Rotate
Scale
Stretch
Lengthen

- Trim

]

P
-

Ll
%

BExtend
Break
Jain
Chamfer
Fillet

3D Operations
Solid Editing

Change Space
Explode

[TFTTd Window Help Express

mmand: “Cancel®
mmand: IMAGEFRAME

Enter new value for IMAGEFRAME <03 1
mmand:

Image
By Xref
Viewport

Change Raster Image Brightness, Contrast, and Fade: Use IMAGEADJUST to adjust displaying result and lightness, contrast and

fade that are related to the display and plot effect when plotting drawings. IMAGEADJUST does not affect the original raster

image as well as other instances of the image.

Improve the Display Speed of Raster Images: You can adjust the display speed by setting the raster image quality. The image

Brightness

Brightness

Contrast
Low

Fade
Brightress [ |

0

49289214 _stadum_large_image

quality is sorted into high and draft levels, If the quality is set to draft, the image will be displayed with some granular materials,

however with faster display speed.
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Layout, Plot and Publish Drawings

Create Multiple-View Drawing Layouts

Overview of Layout: A layout represents a plotted page on which one or more model views are displayed. GstarCAD provides
two collateral working environments as Model and Layout tab. You can create thematic models on Model tab. Multiple slides of
the model can be set in Layout tab. Use these general steps to prepare your drawing for printing multiple layouts:

1. On the Model tab, create your drawing.
2. Create a new layout. You can use an existing Layout1 or Layout2 tab, or you can create a new Layout tab.

3. Create at least one layout viewport on the Layout tab. Use each viewport to help control New leyout

which portion of the drawing prints and at what scale. o empe:

4. Specify additional settings for the layout, such as the scale of the drawing, print area, print :Amcpy

style tables, and more. Select All Layouts

5. Print or plot your drawing. iii LE:‘T:“
Page Setup Manager...

You can right click on Layout tab and select "New layout" to create a new layout, and also Plot..

import layout from template. Options on Shortcut menu are listed: Hide Layout and Mode tzbs

Layoutl 7 rayoute

Work with Model Space and Paper Space: Model space is generally
used for creating and editing drawings. Preparations for plotting are
usually working on paper space for the drawings on layouts are close
to the plotting effects. P ";:\

Bl gt e

POV
e

Model space is an area in which you create two dimensional and PN (e D)
three dimensional objects based on either the World Coordinate )
System (WCS) or a user coordinate system (UCS). The contents of
paper space represent the paper layout of your drawing. In this work
area, you can create and arrange different views of your model similar to the way you arrange detail drawings or orthogonal
views of a model on a sheet of paper.

Layout tab is enabled to make relevant plot settings. Paper space is e -
provided in each layout option, and you are allowed to create
viewports and specify page setup such as paper size, orientation
and location that can be saved together with the layout.

when setting pages. You can also create new layouts using existing
layout template file (DWT or DWG).

| |
| |
| |
| |
| |
| |
| |
You can save and name the page setup and apply it to other layouts } f 1 :
| |
| |
| |
| |
| |

Click on the Model tab, you can view and edit objects in model
space.
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Specify Layout Settings: Once created a drawing in Model tab, you can

toggle to Layout tab and setup the layout for plotting, such as paper size,

drawing orientation and so on. You can right click on the Layout tab to
create new layouts or import from template files, and then click Modify
button on the Page Setup Manager dialog box to set the page.

Select a Paper Size for a Layout:

of the drawing. When you start Plot dialog box in Layout tab, you can
assign the paper type from pull down list of the Paper Size text box. The

The paper size here refers to the size

Paper size is directly previewed from the sketch with its size and units.
The available paper types provided in the pull down list are decided by

the current configuration. If you want to configure plotters to export raster

images, you must specify output size by pixels. The paper size can be

customized in the Plotter Configuration Editor.

Determine the Drawing Orientation of a Layout:

The drawing orientation is sorted into Landscape and
Portrait, which decide the plotting orientation of the
drawing to be seen on a paper. Once specified the
drawing orientation, you can control whether to plot the
top or the bottom of the drawing by selecting Plot
Upsize-down option. The changes setup in Page Setup
dialog box are still saved in layouts. Certain page
settings can be replaced by customized plot settings,
but the settings will not be saved in the layout unless
you click Apply to Layout option.

{F Page Setup Manager \EI
@ Current layout Layout3
Page setups
Cument page setup: <MNone>
“Layout1® Set Cument
“Layout2”
“Layoutd” New
Import
Selected page setup details
Device name <None>
Plotter: <None>
Plot size: 210.00x 257.00 Milimeters {Landscape)
Location: Mot applicabls
Description: The layout will not be plotted unless a new plotter
configuration name is selected
[] Display when creatin Help
{F Page Setup - Layout3 ==
Page Setup Plot style table {pen assignments)
rm
Name:  Nore> o
[] Display plot styles
Printer/Plotter
N
lame: Mone Shaded viewport options
Plotter: None As displayed
Locatior Not applicable
st
Desaription:  The layout will not be plotted urless a new plotter
corfiguration name is selected
Paper size Plot options
[150_a4_(210.00 x_257.00_MM) = Plot object lineweights
Plot with plot styles
Plot area Plot scale o
What to plot Fit to paper
[T Hide paperspace objects
Plot offset (origin set to printable area) 1.0000 ’ Drawing orientation
Portrait
X 00000 Milmeters [ ] Certerthe plot 1.0000 - b
: urits @ Landscape
v
0.0000 Milmeters [] Scale inewsights e

oK | [ Cancel | [ Hep

J

Adjust the Plot Offset of a Layout: You can offset the geometry on the paper by entering a positive or negative value in the X and
Y Offset boxes. Changing the plotting origin may change the position of drawing on papers. The plot origin locates at the left
lower corner of plotting area with offset value of 0 relative to X and Y direction. Select Center on Paper if the specified plot area
is part of the drawing rather than the whole layout, which changes the position of plot origin.

Plot with origin (0,0)

)

Plot with origin (10,10)
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Set the Plot Area of a Layout: You can set the area to be plotted in Plot dialog box. When creating new layouts, the default plot
option is drawing limits which means plotting all the objects within the drawing paper. The plot origin is (0,0), located at the

left lower corner of the page. Do the following methods to select a

plot area:

-Layout: Plots all the objects within the drawing paper.

-Window: Set the Plot Scale for a Layout, Plots any portion of the
drawing you specify within the rectangle window. Click the Window
button to use a pointing device to specify opposite corners of the

area to be plotted, and then return to the Plot dialog box.

-Extents: Plots the portion of the current space of the drawing that

contains objects.
-Display: Plots the contents displayed in current view.

Page Setup Plot sy tabl (pen assignmerts)

Nare ][ da. ] Nene ==
Priker/Pltter Shaded viewpot optons

Name: Shoderlt  As deplayed

P awty
Locat Not appicable:

Descrption: T layout willnct be potted unless a new ploter

corfguraton name i selected. Pit options
PR [T Plotin background
—— o Plot et Ineweights
[150_A4_@10.00 x_257.00 wy =) i PRI
Plot paperspace last

Plot area Plot scale Hide paperspace objects

What to piot Fit to paper [T Plot stamp o
f5ters | P—— 00 S

oW v Milimeters ] Centerthe plot 1317 wis e

- ) Landscape @
36800 Ml 5
Y. imeters pEmp— 77 Pt upside down
TP v | == [ [

Set the Plot and Lineweight Scale for a Layout: When you specify a scale to output your drawing, you can choose Fit to Paper to
scale the drawing to fit onto the selected paper size. Usually, the objects in model space are displayed at the scale set in layout
viewports. To plot the objects in model space with the scale specified in layouts, you assign the scale to 1:1. Even if plot scale
of layouts is assigned, it's enabled to scale the lineweight at a certain scale. Scaling the lineweight is nothing to do with the
plot scale when plotting drawings, which is mainly used for the lines included in the objects to be plotted.

Move and Copy Layouts: You can right click on the
Layout tab to select Move or Copy option, on the
Move or Copy dialog box, you can select a layout
which you want to place after the current layout. To
Create a Copy of current layout, you can select a
layout and check Create a Copy, the copied layout
will place before the layout you selected. You should
notice that Model tab can't be moved or copied.

New layout
From template...
Delete

Rename

Move or Copy...

Select All Layouts

Activate Previous Layout

Activate Model Tab

Page Setup Manager...
Plot...

Hide Layout and Mode tabs

T 7 Ay Ot

{F Move or Copy

Move or copy selected layouts

Before layout:

Layout2
{mave to end)

[T create a copy

Create Layout from Template: Right click on the Layout tab to select from template option to import DWG or DWT file directly,
using information of existing template to create new layouts. System provides template file with extension name as .dwt. Layout

templates from any drawing templates can be imported into the current drawing.

To create a new layout from an existing file:

1. Choose Insert>Layout>Layout from
Template

2. In the dialog box, select the desired
template file, and then click Open.

In the Insert Layout(s) dialog box, select the
layout(s) you want to insert, and then click

OK. You can choose multiple layouts by holding down Ctrl while selecting layout names.

& Block..

[y DWG Reference.

[#® DWF Underlay...
Raster Image Reference...
Field...

B 30 Studio...

Zl ACIS File...

& Drawing Exchange Binary...
2 Windows Metafile...

[ OLE Object...

[ Edernal References...

% Hyperlink...

Jited Format Tools Draw Dimension Modify Window Help Express

CTRL+K

Export
2 | B RE¥E YR

3% {|]9 % ocf'm o
& @448 g

Hell Express
£ E Look in Templates

] New Layout

i Layout from Template

Create Layout Wizard

File name:

Files of type:

-

Standard Template("dwt)
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Create and Modify Layout Viewports: On a Layout tab, you must create at least one layout viewport to see your model. Each
layout viewport is created as a separate entity that you can move, copy, or delete. Any changes you make in one layout viewport
are immediately visible in the other viewports (if the other layout viewports are displaying that portion of the drawing). Zooming
or panning in the current viewport affects only that viewport.

Create layout viewports:

1. On the command line, type MVIEW.

2. Type F (Fit), or create 2, 3 or 4 viewports by entering 2, 3 or
4 separately, or specify two opposing corners to create a
custom viewport.

3. Choose the viewport arrangement, typing H (Horizontal) or V
(Vertical).

4. Do one of the following:

-To arrange the viewports to fill the current graphic area, type F
(Fit)o

-To fit the viewports within a bounding rectangle, specify the Comancs

corners of a I'eCtang|e, Viewports: [ON/OFF/Fit/Lock/2/3/4/Polygen/Object]<First corners:FIT [ |

O3
»

You can create a single layout viewport, or you can divide the graphic area into many viewports arranged
[Horizontal/Vertical/Above/Below/Left/Right].

To modify layout viewport properties:

Linetype CONTINUOUS  —
Linetype scale  |1.0000
Linewsigt BYLAYER

1. Click the border of the layout viewport whose
properties you want to modify.

2. Open the Properties palette through the menu option ey faas
"Tools > Palettes> Properties" or "Modify > Properties". E:EZ f;;?;

3. In the Properties palette, select Standard Scale, and
then select a new scale from the list. The scale you
choose is applied to the viewport.

Turn Layout Viewports On or Off;

1.Click the desired Layout tab.

2. Type MVIEW and then press Enter.

3. Type ON or OFF.

4. Select the edge of the layout viewport to turn on or off, then press Enter.

parts: [ON/OFF/Fit/Lock/2/3/4/Polygan/Object]<First corners:OFF

Create Non-rectangular layout viewports:

Use Object and Polygonal options of MVIEW to create irregular viewports,

Select Object option to convert objects created in paper space to viewports. While selecting
Polygonal option to draw irregular polylines including arcs and lines which are enabled to
either intersect or three vertexes at least, the polyline will be closed automatically.
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Plot Drawings

When a drawing is completed, you can output it using several methods. You can plot the drawing on paper or create a file for
use with another application.

Plot Settings: When you create a drawing, you do most of your e =
Page Setup Plot style table (pen assignments)
work on the Model tab. At any time you can print your drawing to e (@ s || ]
see how it looks on paper. It's easy to startup printing, and then o N
later create layouts and custom print settings to enhance your o o se -
printed output. g O e s
PT:; s:qm 00_x_297.00_MM) - 1 :: :T::::;:‘: -
To start printing:
What to plot. Fit to paper [] Plet stamp on
Scale: | User define [ Save changes to layout
. ) Plot offset forigin set to printable area) 1.0000 = Drawing orientation
1. Choose File > Plot from the main menu. % 10| Ml [Cetrte it ETES S (4]
. . Yo [ 136500 | Mlimetz=s [ Plot upside-down
2. Set the printer and relevant parameters, and then click OK. —_—

Set Paper Size: You can assign the paper type from pull down list of the Paper Size text box. If you want to setup paper size, you
should configure plotters first, all the available plotters are both system plotters of Windows configured and non-system driven.

. 1SO_A0_(1189.00_x_841.00_MM) -
: 0 o iocel I =015
To select a printer or plotter: R 0N 00 TS
ISO_A1_(594.00_x_841.00_MM)
Page Set 1SO_AZ_(594.00 x_420.00_MM)
gusss |1S0_A2_(420 00 _554 00_MM)
1SO_A3_(420.00 x_297.00_MM)

1. Choose File > Plot from the main menu. e (e N e —

1SO_A4_(210.00 x_297.00_MM)
ot D P AT 0000 e
2. From the Name list in Printer/Plotter area, select a Neme:  [None SCHE HB.00535 00 o)
ARCH_E_(36.00 x_48.00_Inches)
Plotter: None ARCH_D_(36.00_x_24.00_inches)

i i ARCH_D_(24.00_x_36.00_inches
printer or plotter you want to use, and then click OK. D 2o )
Location: Not applicable AR e 80028 00 )
Description: The IayoLtt will not be plotted unless 2 new plotter mg},g{g %"ﬂ %:”ﬁ“]
corfiguration name is selected NSl o4 00 500 e}
Plot to Fle ANSI_D_(22.00_x_34 00_Inches)
ANSIC_(22.00_x_17.00_Inches)
ANSI|C_(17.00_x_22.00_Inches)
Paper size ANSI_B_(17.00__11.00_Inches)
_ _ ANSI_B_(11.00__17.00_Inches)
150 A4_{257.00_x_210,00_Mb] ANSI”A(11.00 8 50_inches}
ANSI_A_(8.50_x_11.00_inches)
Legal_(3.50_x_12.0_inches) L4
Letter_(8.50__11.00_inches) -

m

Position the Drawing on the Paper: You can adjust the position of the drawing to be plotted on a paper before plotting.
To specify the print area origin;

1. If necessary, click the desired Layout tab or the Model tab.

2. Choose File > Plot from the main menu. PR ————— [ e B —
3. Do one of the following in the Plot Offset area: XU e e axslEn e
-To center the specified print area on the printed
page, select Center the Plot check box.

-To specify an origin for the print area, type the X and Y coordinates.
4. Select OK, and then click Apply to Layout.

v 0.0000 Millimeters Scale lineweights [] Plet upside-down

Preview | oobtotmon |[ ok J[ cancsl |[ mep | &)

Saves changes that you make in the "Plot dialog box' to the
layout.
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Set Drawing Orientation: The drawing orientation determines whether to plot a drawing
portrait or landscape. If you select Landscape, plots the drawing using the length edge as
horizontal. While selecting Portrait to plot the drawing using its minor edge as horizontal

1=}

alty

Plot options
[7] Plot in background

Flot cbject ineweights

1 Plot with plot styles

Changing, the drawing orientation just like rotating the paper under the drawing.
Meanwhile, selecting Plot upsize-down to control whether to locate the drawing
upsize-down on paper.

Set Plot Scale: Plot scale of the drawing can be specified directly from the Scale
pull-down list in Plot Scale area of Plot dialog box. You can also choose
User define to set desired plot scale, or choose Fit to Paper to scale the
drawing to fit onto the selected paper size. The plot scale together with plot
unit and drawing unit must be specified before plotting. For example, if you
select the paper size to mm, entering 1 under mm and 10 under Units
blank produces a plotted drawing with each plotted unit represents 10
actual millimeters.

Plot scz

Scale:

To automatically scale the drawing for printing:

ale

[] Fit to paper

User define -

Plot paperspace last
Hide paperspace objects
[”] Plot stamp on.
[] Save changes to layout

Drawing oriertation
) Portrait

Mil H
it: _ N
b= @ Landscape
new

[C] Piot upside-down

| o ) e )@

iytalayod | [ OK

Hide paperspace objects
] Plot stamp on
[] Save changes to layout

efines the exact scale for the plot. Custom defines a user-
efined scale. You can create a custom scale by entering the
umber of inches (or millimeters) equal to the number of
rawing units.

] Plot upside-down

o)

Help @

I - ::e ::,::r::ﬁca objects
1. If necessary, click the desired Layout tab or the Model tab. Seae: [ Ueercone [ Seechanges o oyt
. . 1.0000 = Drawing orientation
2. Choose File > Plf)t from.the main menu. | o — Oromt
3. To scale the drawing to fit on one printed page, in Plot Scale, click Fit to Paper. Seclo frenigt [ElPet upsdesiomn
4. Select Apply to Layout and click OK. e [ e
Set Plot Options: The following options show plot patterns with instructions on how to plot objects.
-Plot in Background. Specifies that the plot is processed in background.
-Plot Object Lineweights. Specifies that lineweights assigned to objects and Quaity
layers are plotted.
-Plot with Plot Styles. Plots a drawing with specified plot styles. Plots e
lineweights automatically once selecting this option automatically. If you do not Humberof copies :°‘°‘“':°““”Zf‘g'“
- 1 lot with plot styles
select this option, objects are plotted with their assigned properties and not Plot peperspace lat
with the plot style overrides. . —
-Plot Paperspace Last. Plots model space geometry first. Paper space geometry i -]
is usually plotted before model space geometry. ;T;ﬁ : B
-Hide Paperspace Objects. Suppresses the plotting of objects that are located e v e
behind other objects regardless of how it's displayed on screen. This option is 4 0ies 11 o [ s || e @

only available in the Layout tabs.

-Plot Stamp on. Horizontally or vertically placed the plot stamp information on a specified corner of drawing. The plot stamp

settings can be saved to log file, also cannot be saved.

-Save Changes to Layout. All the changes you make in the Plot dialog box will be saved to the layout if you click OK.
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Specify the Area to Plot: To specify a portion of the drawing to print, if necessary, click the desired Layout tab or the Model tab.

1. Choose File > Plot from the main menu. —

2. Under Print Area, click one of the following: o = S Pﬁ:mmmmilw
-Display — Plots the current view on the screen. i — - e
-Extents — Plots the contents within the specified drawing extents. o
-Limits/Layout — Plots the contents within the specified drawing S T et

limits or entities in the printable area. — 5 g wn
-Window — Plots the portion of the drawing contained in the e S S
specified window. Click the Window button to use a pointing device MD. DSZM

to specify opposite corners of the area to be plotted, and then return | e Sl (4]
to the Plot dialog box. e [Co )G [ 1@

3. Select Apply to Layout and click OK.

{ Plot-Model

Preview a Plot: Viewing a drawing before printing gives you a

Page Setup Plot styte table: (pen assignments)

preview of what your drawing will look like when it is printed. s o B[ =
- =

To preview a drawing before printing: S

1. If necessary, click the desired Layout tab or the Model tab. — 5 e

2. Choose File > Plot Preview from the main menu. s o D

3. Do one of the following: e = e

-To print the drawing, click preview and click Plot on the top left | = Dm

corner of print preview. (oot ] (oK [ Gaes |10 ) ®

-To return to the drawing, click the off button or press Esc.

Use Plot Styles: Plot styles help you control what your drawing looks like when it is printed. Because plot styles are saved in
plot style tables, which are files located on your computer, you can reuse them to help eliminate the need to reconfigure your
print settings each time you print a drawing. A drawing can use one type of plot style table at a time. There are two types of plot
style tables:

-Color-dependent plot style tables (CTB) contain a collection of plot styles based on each of the 255 index colors available in a
drawing.

-Named plot style tables (STB) contain a collection of plot styles that you define. They can vary regardless of color.

To assign plot style tables:

. =
1. If necessary, click the desired Layout tab, or click the Model tab. A S S
, . =
2. Choose File > Plot from the main menu. Nare

acad.db
3. Under Plot Style Table (pen assignments), select a plot style table in the one of the following: SR Fatema

gead.cth
-None: Applies no plot style table. Objects plot according to their own properties. Smocrererih

Sereening 100% cth
-Monochrome: Plots all colors as black. S 0 b

Screening 75%.cth
-New: Creates a new plot style table.

Plot in background
4. Select Save Changes to Layout, and then click Apply to Layout.
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To Modify plot style tables:

1. Choose File > Plot from the main menu.

2. Under Plot Style Table (pen assignments), click the plot style table you want
to modify, and then click the button to display “Plot Style Table Editor”.

3. Click the General tab on Plot Style Table Editor, and then do any of the
following:

-Enter a new plot style description.

-Select Apply global scale factor to non-ISO linetypes to apply the scale factor
-Enter a scale factor to apply to non-ISO linetypes used for any plot style in the
current plot style table.

4. Click the Form View tab, and then do any of the following:

-Make changes to a color-dependent plot style by selecting it in the Plot list,
and then make color, linetype, or lineweight changes for the plot style in
Properties area. Your changes are saved automatically for the selected plot
style.

-Make changes to a named plot style by selecting it in the Plot list, and then
make color, linetype, or lineweight changes for the plot style in Properties area.
Your changes are saved automatically for the selected plot style.

-Add a new plot style by clicking Add Style. Enter a new name, and then click
OK. Select the options for the plot style. (Available for named plot styles only.)
-Delete a plot style by selecting it in the Plot list, and then click Delete Style.
(Available for named plot styles only.)

5. Click OK.

{F Plot Style Table Editor - DWF Virtual Pens.ctb (=)
Fom View
Plot styles: Fropertics
= Color: MRed -
o
n oo
Penst 1 =
Vitualpen# 1
Screening: 100
Linstype: Use object Inetype -
i
o Lineweight 050 -
Description Lne €0 4S! s object end s~
Line join stle: " | biectjon style
Fillsyle: £ srte -
Edi Lneweights.. | | Saveas.. |
Add Style Delete Style
[ SavedCose | [ Cancd | [ b |
3 Plot Style Table Editor - DWF Virtual Pens.cth (=30l

{ General }| Fom View

—. Plot style table fie name:
= DWF Virual Pens b

Description

File Information

Number of styles: 255

Path: C:\Users\OVS'\AppData‘Roaming\Gstarsoft \GstarCA_ \DWF Vitual Pens ctb
Version1.0

Lagacy (can b used to import old DWGs)

=] Apply global scale factor to nonSO linetypes

7 Scale factor

[ savedCiose | [ Cancel | [ Hep

Plot Files to Other Formats: Plot files have various formats. You can output drawings in any image formats with unique plotter

driver.

Page Setup Flot style table (pen assignmens)
Name [ <hione> <[ A, ] [Nene B
Printer/Plott Shaded viewport options
Mame: [Nore 7] Propertes | Shage plot As displayed -
None ] el PR
Send To OneNote 2013 —
Location: | Wicrosoft XPS Document Writer
g | Fax
eSCPUAN: | Canon iR2318/2320 UFRII LT
fedobe PDF Flot options
Flat to EIf DWFE ePlct pc3 [E] Pt in background
Papersize Plot object inewsights
| Publish ToWeb PNG.pc3 Flot with plot styles
150_A4 2K 73 Protter,
Manizge Plotter.. Flot paperspace last

Plot area Plet scale Hide paperspace objects

What to plot Fitto paper [ Plot stamp on

Scale: | User define 7] Save changes to layout
Plot offset {onigin set to prntable area) 1.0000 = Drawing orisntation

x 115500 Milimetors 7] Centerthe plot 25040 s (IGEEE

u © Landecape @

y. 136500 Milmeters Scale neweights ] Plot upsideiown

Preview.. feytolops | [0k ][ coned | [ e ®
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Publish Drawings: Specifies drawing sheets that you can assemble, reorder, rename, copy, and save for publishing as a
multi-sheet drawing set. You can publish the drawing set to a DWF, DWFx, or PDF file or send it to the plotter named in the
page setup for hardcopy output or as a plot file. The following options are displayed in the Publish Dialog Box:

1. Load Sheet List Button: Displays
the Load Sheet List dialog box, in
which you can select a DSD file or a
BP3 (Batch Plot) file to load.

2. Save Sheet List Button: Displays
the Save List As dialog box, in which
you can save the current list of
drawings as a DSD file.

3. Sheet List: Displays the current
drawing set (DSD) or batch plot (BP3)
file.

4. Publish to: Defines how to publish
the list of sheets. You can publish to
gither a multi-sheet DWF, DWFx, or
PDF file.

5. Automatically load all open
drawings: When selected, the
contents of all open documents are
automatically loaded in the publish
list.

6. Add Sheets Button: Displays the
Select Drawings dialog box, in which
you can select drawings to add to the
list of drawing sheets.

7. Remove Sheets Button: Deletes the
selected drawing sheets from the list
of sheets.

8. Move Sheet Up Button: Moves the
selected drawing sheets up one
position in the list.

9. Move Sheet Down Button: Moves
the selected drawing sheets down one
position in the list.

10. Preview Button: Displays the
drawing as it will appear when plotted
on paper by executing

the PREVIEW command.

11. Sheet Name: Combines the

drawing name and the layout name
with a dash (-).

12. Page Setup/3D DWF: Displays
the named page setup for the sheet.
You can change the page setup by
clicking the page setup name and
selecting another page setup from
the list

13. Status: Displays the status of the
sheet when it is loaded to the list of
sheets.

14/15. Show and select sheet details:
Displays and hides the Selected
Sheet Information and Selected
Page Setup Information areas.

16. Publish Options: Opens

the Publish Options dialog box, in
which you can specify options for
publishing.

17. Number of Copies: Specifies the
number of copies to publish.

18. Precision: Optimizes the dpi of
DWF, DWFx, and PDF files for your
field: manufacturing, architecture or

civil engineering.

19. Include Plot Stamp: Places a plot
stamp on a specified corner of each
drawing and logs it to a file.

20. Plot Stamp Settings: Displays
the Plot Stamp Dialog BoxPlot
Stamp Settings Dialog Box, in which
you can specify the information,
such as drawing name and plot
scale that you want applied to the
plot stamp.

21. Publish in Background: Toggles
background publishing for the
selected sheets.

22. Send the Sheets to the Plotter in
Reverse Order: When selected, sends
sheets to the plotter in reverse of
default order. This option is
available only if the Plotter Named
in Page Setup option is selected.
23. Open in Viewer when Done: When
publishing completes, the DWF,
DWFx or PDF file will open in a
viewer application.

I )

sheetust: 3 1 2 pien Optons kfomton
(Nore - . Locaion. DA
Image:  Singlesheet file
Naming: N/A
[¥] Atomatically load all open drawings 5 mm Dont include
Inconorate  Line overwrite
6 7 8 9 10 Contro:
B e B TiRrrer—
Sheet Name 11 NNWF 12  Page Sehin 13 St
UnsavedDrawng |-Layout | &% <Default None> + No enors
UnsavedDrawing 1-Layout2 & <Defautt None> + No enors
A UnsavedDrawng1-Model | <Defaut None> + No enors
BLOCKS 2 - Copy-BENEHI IS &4 <Vetautt None> + No enors
B n10CKS 2 - Capy-Madel = Defmit Nones «” No annes

Publish Outpit

Selected Sheet Detaile 15 P

D,aw-,‘:l:':: Mumbor of copica: 17 [ Inclds plot etamp 19 20
Layout Name (= A )
Plot device 7 [¥] Publsh in background 21 22
Plot size Precision: 18 s s
Flot scale Hove [7]Open in viewer whon done 23
Page setup de..

Hide Detais 14 [ Publish ] l C J { o ]



file:///D:/WS1a9193826455f5ffa23ce210c4a30acaf-4893.htm%23WSc30cd3d5faa8f6d81bca5f1ffc2d6150d-7f67
file:///D:/WS1a9193826455f5ffa23ce210c4a30acaf-4879.htm%23WSc30cd3d5faa8f6d81bca5f1ffc2d6150d-7f43
file:///D:/WS1a9193826455f5ffa23ce210c4a30acaf-48ce.htm%23WSc30cd3d5faa8f6d81bca5f1ffc2d6150d-7f98
file:///D:/WS1a9193826455f5ffa23ce210c4a30acaf-48ce.htm%23WSc30cd3d5faa8f6d81bca5f1ffc2d6150d-7f98

Chapter 13 Create and Edit Dynamic Blocks

Create and Edit Dynamic Blocks

In GstarCADS, you can create and edit Dynamic Blocks. Dynamic block references contain grips or custom properties that
change the way the reference is displayed in the drawing after it is inserted. Dynamic blocks allow you to insert one block that
can change shape, size, or configuration, instead of inserting one of many static block definitions.

Some dynamic blocks are defined so that geometry within the block can only be edited to certain sizes specified in the block
definition. When you use a grip to edit the block reference, tick marks are displayed at the locations of valid values for the block
reference. If you change a block property value to a value other than one specified in the definition, the parameter will adjust to
the closest valid value.

Dynamic Block Editor: You can access the Block Editor by typing the edit command or by double-clicking the block without
attribute. The Block Editor ribbon interface will show as below, the black arrows mark the stand for parameters, while the yellow
lighting is the symbol for action. It will pop-up toolbars in a classic interface.

(e ) BREOEBSRRw-»- ¢ Block Bditer | GstarCAD 2012 Profsssional(Trial)Trial pericd is expired, Some functions will be restricted - (G:\/BE2012\M... - = X
Nome  Tnxert  Amsotate 30 Vier  Mamage  Outpnt  Block Editer | Melp  Epress Style = = = X
ngs %': I% IR .’Z//’f‘EﬁB‘BﬂﬁUL’Q{- |é % O % x
C,_ﬁ"m B[S ST W ONE NN S « z
Define Update | Parsmeter Action g Visibility Close Block
Sk Attribute M|+ 8 L4 o E State Editor
Nunage Tool Paraseter Action Farsmeter Sets Visibility Close
Properties
{l dection Ml ‘Llljj
stretch 2
[Layer o
Color W Sylayer
Linetype ByLayer
Linetype scale 1
stretch 1 Linevsicht  BTLATER
|Thi chness 0
Conter-X
TextFlip 2 tec
] v Conter-z
Hoi ght
% é; stretch BT
FlipState IS icon on Moz
§<+ x e
E{> scale (Snap on ¥o
visiblity G -
oot PP -
i; istance Block nme  |icor
TextFlip 3 Scale wnifealy ¥o
Fliwm‘ﬂ l Allov expleding Tes
Uni t Millimeter
¢ Description
%[elect objects: ~
p[Ppposite corner:Find out 2, total 2
elect objects:
Furrent settangs: Copy mode = Multiple
Specify base poirt oF. Displacenent/aode] Displacensnts:
ecify second point or <use first point as di : vl
ommand: < >
15842007, ~384.0815,0 SWAP  GAID ORTWD | FOLAR | OSNAP | OTRACK | L¥T | DI | MODEL $ sy

Dynamic Block Editor Tool Panels: Using the tools in this Tool Panel to define, edit and modify dynamic blocks definitions ,
makes it very convenient and fast.

Manage Tool
Save or Save as the default block; Create or edit another Define, edit or update the block attribute.
block. A
: L%
a5 > B
EO c Def_ine Update
Save Attribute
Elack
Memere Tool
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Parameter

You can add parameters for Dynamic Blocks on this panel.

14
= o

Ion

i

Parameter

£ 8 T
4
Farameter
Action
You can add actions for Dynamic Blocks on this panel.
L& % B[R
7 e w
B =

Aotion

Aotion

Parameter Sets
You can add the parameter set on this panel.

aF 9 4F 4F 4 8 8
IElh—olh—-lh—-ll-—-ll-—-l"%;,“

m dp dp Iop Tng Ine Xpn Inp
2 g
i3

£ Ei

arameter Sets

Visibility
This panel is specially used for Visibility editing.

% O b

E 45E -
¥izibility

State

Vizibility

Close

Itis used to exit the Block Editor. Before exiting, some
commands like save or open etc. might not work.

X

Close Block
Editor

Close

Parameters: Define custom properties for the dynamic block by specifying positions, distances, and angles for geometry in the
block. You add parameters to a dynamic block definition in the Block Editor. In the Block Editor, parameters have an appearance
similar to dimensions. Parameters define custom properties for the block. Parameters also specify positions, distances, and
angles for geometry in the block reference. When you add a parameter to a dynamic block definition, the parameter defines one
or more custom properties for the block.

A dynamic block definition must contain at least one parameter. When a parameter is added to a dynamic block definition, grips
associated with key points of the parameter are automatically added. You must then add an action to the block definition and
associate the action with a parameter.

Parameters also define and constrain values that affect the dynamic block reference's behavior in a drawing. Some parameters
can have a fixed set of values, minimum and maximum values, or increment values. For example, a linear parameter used in a
window block may have the following fixed set of values: 10, 20, 30, and 40. When the block reference is inserted in a drawing,
you can only change the window to one of these values. Adding a value set to a parameter allows you to limit how the block
reference is manipulated in a drawing.

Point Parameter

lcon: Lﬁ

Command: BParameter—0
Definesan X and Y location in the drawing. A point

parameter can be associated with a move or stretch action.

Linear Parameter

4 [
Icon;

Command: BParameter—L

Shows the distance between two anchor points. Constrains
grip movement along a preset angle. A linear parameter can
be associated with a move, stretch, scale or array action.
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Polar Parameter
Icon: e
Command: BParameter—P

Shows the distance between two anchor points and displays
an angle value. You can use both grips and the Properties
palette to change both the distance value and the angle. A
polar parameter can be associated with a move, scale,
stretch, polar stretch, or array action.

XY Parameter

Command: BParameter—X

Shows the X and Y distances from the base point of the
parameter. It can be associated with a move, scale, stretch,
or array action.

Rotation Parameter

Iconzﬁ\n

Command: BParameter—R
Defines an angle. The rotation angle can be in any value, or
be defined in a range or a specified value.

Alignment Parameter

lcon; *=

Command: BParameter—A

Definesan X and Y location and an angle. An alignment
parameter always applies to the entire block and needs no
action associated with it. An alignment parameter allows the
block reference to automatically rotate around a point to
align with another object in the drawing. An alignment
parameter affects the rotation property of the block.

Flip Parameter

g
Icon:
Command: BParameter—F
Aflip parameter flips objects. You can associate a flip
parameter with a flip action.

Visibility Parameter

i

lcon: E

Command: BParameter—V

Controls the visibility of objects in the block. A visibility
parameter always applies to the entire block and needs no
action associated with it. In a drawing, you click the grip to
display a list of visibility states available for the block
reference.

Lookup Parameter

lcon: Ij

Command: BParameter—K

Defines a custom property that you can specify or set to
evaluate a value from a list or table you define. It can be
associated with a single lookup grip. In the block reference,
you click the grip to display a list of available values. You
can associate a lookup parameter with a lookup action.

Base Point Parameter

+

lcon:

Command: BParameter—B

Defines a base point for the dynamic block reference relative
to the geometry in the block. Cannot be associated with any
actions, but can belong to an action's selection set.
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Actions: Actions define how the geometry of a dynamic block reference will move or change when the custom properties of the

block reference are manipulated in a drawing.

Move %

ICommand: BActionTool—M

A move action causes objects to move a specified distance
and angle such as a point, a linear, a polar, an XY parameter,
etc, moves all objects in a selection set in a/any direction.

Scale &

Command: BActionTool—S

A scale action such as a linear, a polar, an XY parameter, and
S0 on, scales the selected objects in the direction of the
parameter. Users can manipulate the grips in different way
by changing the properties and values in the Properties
palette.

Stretch [+

Command: BActionTool—T

A stretch action causes objects to move and stretch a
specified distance in a specified location. A stretch action
associated with a point, a linear, a polar, an XY parameter,
gtc.

Polar Stretch [+
Command: BParameter—PIn
A polar stretch action rotates, moves, and stretches objects a

specified angle and distance when the key point on the
associated polar parameter is changed through a grip or the
Properties palette. A polar stretch action can only be applied
to a polar parameter.

Rotate (%

Command: BActionTool—P

A rotate action is always associated with a rotate parameter.
Selectéﬂ%bjects can be rotated freely, or the way the grips
are manipulated is different in the Properties palette.

Flip
Command: BActionTool—F
A flip action is always associated with a flip parameter.

Armay 55

Command: BActionTool—A

An array action is associated with a linear, a polar, an XY
parameter, etc, copies and arrays selected objects in
different way.

Lookup [Ei

Command: BActionTool—L

A Tookup action can only be associated with a lookup
parameter.

The General Steps of Creating a Dynamic Block Definition: In order to get a Dynamic Block Definition, improve block editing
efficiency and avoid repeating modifications, we can create Dynamic Block by the following steps.

Step1: Planning

Before creating Dynamic Block, it is
essential to plan Dynamic Block, plan
the functions, appearance, the method
of drawing and required Parameter(s)
and Action(s) which are needed to
achieve prospective functions.

Step2: Draw geometric figure

The included basic pixel during
Dynamic drawing, of course, you can
draw these pixel in Block Editor.

Step3: Add Parameter and Action

This is the most pivotal step when
creating Dynamic Block. When editing
the Parameter and Action, you not
only consider the achievement of
Parameter and Action, but also
consider the readability of Dynamic
Block and the convenience of
Modification, let the action point of
the Parameter attach on the
corresponding pixel as far as possible,
and put the Action near to its relevant

parameter, if there are more
Parameters and Actions, they still

need to be renamed for understanding,
editing and Modification.

Step4: Test Dynamic Block

Save and Exit Block Editor, start the
Dynamic Block test to check if it
reaches to the prospective effect.
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Dynamic Blocks Creation Samples

See what you are able to do within the Dynamic Block Editor, and get the most out of your design. See the follow samples:

Base Point Parameter: Although the majority of parameters only taken into effect when operations are matched with actions,
there are exceptions, base point parameter is one of them.

1. Define blocks: Define block and draw a circle in the block editor, as shown. gy [ T BT, T4
Visibility b Close Block

State Editor

Visibility Close

2. Add base point: Click "base point" parameter on the parameter panel, put the parameter on
the center of the circle according to system prompt, as shown in the below illustration.

I% AR 7/ I% T b S
: & E e T i 2 HiE 8T
arameter Action Parameter

B 4 BY B+

Parand A Parameter

3. Insert block: Save and exit block editor, insert the block in the model. You
can realize, base point becomes the insert point of the block after adding the
base point parameter. Please note, if you set an insert point via the block define
dialog box, and add a base point parameter as well, the base point is the default
insert point.

‘ [Epecify insertion point or 3|\ eNEED |< 28" |

Visibility: Using the Visibility Parameter function, you can control the display and hide a certain view in Dynamic Block.

1. Prepare view: Prepare a three cars view and define as block.

111



Chapter 13 Create and Edit Dynamic Blocks

2. Add Parameter of Visibility: Enter into Block Editor by Double-clicking the clock or right- click the menu, click the button
Visibility of Parameter in the Parameter panel, appoint the position of the Parameter according to the system prompt, as shown

below.
v
!
WVisibility &

3. Edit the states of Visibility: Double click the button Visibility, the " Visibility States 3]
Visibility States dialog box will be displayed. In the dialog box, you can ‘%7 —
rename, new and remove the Visibility States. In order to control the e
visibility of the three cars view in this example, we click on new for the
three Visibility States as shown in the following picture. e
Click the following button as shown in the picture and choose roadster
in the pull down menu.

[ ok ][ cancel |[ Hept) |

I % & 5%

' Roadster T
Visibility \

State Roadster

Vi SarE k
Truck

H 1 falhilihg? H etk =8
Click the “Invisibility” button in the Visibility tool panel, select truck and car, make them 5 :E‘t\\% X
invisible in the “roadster” state, as shown in the following picture, after selecting, press b e Sl

¥isibility Close

enter to confirm. For the state of “Car” and “Truck”, set them in the same way. ~

[ER Make Invisible

4, Move and Adjust: After finishing the editing of the Visibility States, move the three cars
view to make them overlap as shown in the picture bellow.

1%ibTlity
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5. Test Dynamic Block: Insert the edited Dynamic Block into a drawing, select Dynamic Block and click the grip of Visibility
Parameter, choose one item in the pop-up pull-down list, Dynamic Block will change the display state automatically, as shown
in the following picture.

Alignment: Alignment Parameter can give dynamic blocks the function of alignment automatically, which can save the step of
rotating the blocks.

/

7
1. Add an alignment parameter for a roughness symbol: Draw a roughness symbol in the Block Editor.
Select the icon of the alignment parameter. Specify the location and the aligned orientation of the \
parameter following what the computer asked as shown in the picture, the dotted line is the align N )

i ~
orientation. II/
X

g
Roughness

2. Test the dynamic block: Insert the roughness dynamic w5 ” N7z
blocks, move the align grips, the symbol will align with the V : “ / : :
interface of the dimensions, as shown pin the picture | [> I
below. 1 ‘ 1

Flip: When you use the "roughness symbol block" to label the spare parts, the symbol is sometimes already in the right position,
however, the characters' direction is not right. We need to add the "character flip" function to receive the correct label.

1. Add flip parameter: Click the "flip" parameter button, add the flip parameter Visiblity
. . . H
according to prompt, as shown in the picture. s Roug ess
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2. Add flip action: Click the flip action button on the action panel, match parameter and object for the action. Herein, we choose
‘roughness" as the object, and position the action button, as shown in below picture.

-

v"isihlity % i FlipState 1
£lip 2
Use the same method to add a <}:
Rk Rou e b eSS : )
L g pair of flip parameter and action  pyypstate 4 Roughness ﬁ flip 1
flip 1 :
% i of the vertical direction, as )

shown: -

VVisiblity

X X
Point Movement:
| S SR |
1. Draw a drawing: Draw a drawing and define it as a block. -
g ﬁMove
2. Add point parameter: Click point parameter on the tool bar, define the parameter
position according to prompt, as shown in the picture.
3. Add move action: Click move action button on action 7 f‘
panel, match parameter and object for the action, and J‘;/— i —
I 1 —a
define the position. The position of action label does not F # - - = — - |

affect the effect of the dynamic block, however, for the
sake of beauty& convenience, try to put the label near the
related parameter. % ngue

— _—

Select Objects

]

Placed action

4., Test dynamic block: Insert the dynamic block, drag the blue grip, then move the S
keyway to the right accordingly, as shown in below picture. Obviously, the dynamic B S §
block can achieve the expected results. Please pay attention, if it is not run with ortho -8

constraint, the keyway can move towards every direction because the direction of the Point
. . Movement
point parameter is random, the

characteristic of the parameter
decides the characteristic of action.

- - ﬁ__

114



Chapter 13 Create and Edit Dynamic Blocks

Linear Movement: Actually, limited to the demand of the material mechanics characteristics, keyway is only allowed to be
placed on the central line. So, a horizontal movement is enough for keyway and the movement to other direction is not
meaningful. Next we will take advantage of the linear parameter to define the keyway’s movement direction on the central line of
the step shaft.

1. Draw: Draw the follow drawing and define it as a block. - = - -
Distance

2. Add linear parameter: The way of adding a linear parameter is similar to T

dimension, both try to put the absorption point of the parameter on the central \%> _ _

line of the step shaft.

Distance

3. Add Move Action: Different from the point move, after specifying the *‘
parameter, the system will prompt: Specify parameter that is related to
movement. Select right grip of parameter as “Related parameter point”, as __43%@:/ _ _

Related parameter point

shown in the following picture.

The parameter point we mentioned corresponds to the operate point of Move. Distance
After exiting Block Editor you can drag this point to make dynamic block

change correspondingly. After selecting the related parameter point you can )
specify the move objects for action, as shown in the following picture. Place e B -
action label, save and exit dynamic block.

4 Testing Dynamic Block: Select dynamic block and drag the right grip of the
parameter. Meanwhile, no matter how the cursor moves, the keyway is limited to . _ ==
the central line of the step shaft. That is to say with the limitation of the linear

parameter, the dynamic block can only move along the direction specified by the x
linear parameter. :

intance Distance 0.8001

Number of Grips: In the Block Editor, select the linear e W e hncle
parameters, change the number of grips to “1” in the - %

Dist type None

: t: Dist minimun 0

properties panel. 1 < _ _

Dist maximum

Save and exit the Block Editor, choose the Dynamic Block, you will
find that one grip has disappeared. In fact, after changing the number
of grips from “2” to “1”, the first thing that disappeared was the basic
grip of parameters, namely the first point when adding parameters.
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Angle Offset: Open Block Editor, choose the Angle offset . FoamX i
from 0°to 30°in the action property, save and exit the block Distance ™ Move
p———— iz Distance muttiplier |1
editor Andeofiset |30
_4 = == Action name Move
-1 Action type Move
Selection set 11 Object

—
Select the Dynamic Block and then move the right side grip. You will find it =
can only move in the direction of 30°as it is shown in the follow picture. The
direction of action can change according to the Angle Offset. ':/ B 3

Linear Stretch: During a mechanical design, we often need to change the position as well as the dimension of the keyway. In
this section, we will add Linear Tensile function for the keyway on the step shaft.

Distance

1. Add linear parameter;

2. Add stretch action: Click the stretch action button on the action Frsiroicn e
panel, choose parameter according to prompt and define right .  Diatanse v
grip as key parameter point, as shown in below picture. The black

object is the operational object of the action, the broken line 1 —
frame is the stretch frame, objects intersect with stretch frame will e
be stretched, objects which will be selected by the stretch frame

will move.

3. Test dynamic block: Exit from block editor, drag stretch grip to stretch %%4:% _ _ \
the keyway, as shown in the picture. ‘

Parameter Value Set: For mechanical designs, we often need to stretch the keyway to a certain length. Now, let us see how to
realize an accurate stretch. Pick linear parameter in block editor, click entry frame which is on the right side of" distance type"
on the Properties panel, a drop-down menu will pop up.

Start-X 56.6813
Therein, none is the default option, which means it ﬁsmtd‘ placr i
End-X 57. 4514
can stretch optionally. With the other two options, g W e
you can define the maximum and minimum number e

respectively.

Base Location Start Point

Show Properties Tes
Chain Actions Mo
| amber of Grips|i
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"Increment" means stretch increasingly, a Value set appears as shown
. . T Dist type Increment Dist type st
below after selecting increment. If you choose "list", a Value set appears 4o imweren o P |
Dist walue list |0 8001
as shown in below picture, the dynamic block can only be stretched ' '
according to the number in the list.

Dist minimum |0

Dist maximum

" Add Distance Value RIx
Click the text frame which is on the right side of the Distances o add:

"distance value list", one button with ellipsis on it will :
appear. Click this button, a "Add distance" dialog box will !
be displayed. Add three numbers “1”.“1.5”.“2” in the

dialogue box, as shown in below picture. ;';m
Exit from block editor and stretch the right grip, you will

see several gray lines appearing on the right side of the

keyway, and the keyway can only be stretched to the gray

line position, as shown in below picture. Obviously, by value list, you can define certain numbers of the stretch, to realize an
accurate stretch.

=t —-

Symmetrical Stretch: There is an easy way to realize the two-way stretch which is adding two actions of stretch. Though it can
realize a two-way stretch, the action of stretch is independent. The parameter needs some additional setup to realize the
two-way symmetrical stretch.

%Left(Stretch) ﬁRight(Stretch)
-First, add two stretch actions for parameter, and select the two grips
of the two parameters as the relevant point of each action. ﬂ
-Second, in the misc, modify the base location from "Start Point" to _% = =
"Mid Point", like shown in the picture below. Save and exit the block
editor.

LinearParameter

For the convenience of watching the effect, we drew a vertical center line in the middle of ‘@
the keyway, and then stretched the grip to the left side of the keyway or the right side, as 9
shown in the picture below. As the grips are moving, the two-way symmetrical stretch is
realized.

Distance Multiplier: Take the step shaft as an example, if we stretch the left part of the E y "
step shaft and the keyway still is at the center point of the smaller diameter shaft after

stretching. Then, we use the “Distance Multiplier” property of action to achieve the aim. @
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1. Add linear parameter and stretch action for step shaft: ,.

Hels]

s LinearParameter

Hide the right grip of the parameter point, the action stretch

box is as in the following picture, the bolded object is the =
action operation object. :

2. Add Move Action for keyway: Select the left grip of the linear ﬁ =

parameter when moving, stretching the related parameter points.
Move the objects of action and select the whole keyway, as in
the following picture.

3. Modify distance multiplier of action: Select Move LinsarParanster

Stretch

Action and modify the default value from 1 to 0.5 in the
property of the distance multiplier, save and exit the block
editor.

o Hove

e

4 Test Dynamic Block: Stretch leftwards grip and with the grip moving leftwards,
the smaller diameter shaft will appear with a stretch effect, the keyway will also

move leftwards accordingly, meanwhile, the keyway is in the center of the

smaller diameter shaft of the step shaft all the time. Although Stretch and Move

have a common parameter, when the Distance Multiplier of Move is modified to
0.5, the displacement of Move can only stretch 0.5 times of the displacement.

Chain Action: If you want to realize a symmetric stretch without changing the keyway center and the length of smaller diameter

shaft changes with the stretch at the same time, how can you realize that?

1. Add stretch for Step Shaft: Add stretch parameter and action for step
shaft as the following picture shows. There into, the bolded objects
indicate the operation object of action. Because the follow-up operation
will not stretch the step shaft by grips of this linear parameter, the grip’s
number of the linear parameter can be modified to “0”.

% Stretch
L

W Streten
#  LinearParameter

inearParamster

2. Add linear parameter for keyways: Set the base point
position of the line parameter as “Center” in order to

realize the symmetric stretch function. #EEF

aaaaaa

PRNTEN
ST.4814
241734
1.3798
0.8001
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3.Add the stretch rightwards action for the keyway and realize chain action: Select the “Distance” linear parameter and modify
the chain action of prosperity from “NO” to “Yes” as the following picture shows:

% Stretch

End-X 55.57T5
End-Y 24173

_l:inea:rParamet er ]]:-bel “ieeet jzazgz
= Distanr:e" Angle
%Streh- Right) s ¥
l _ Dist maximum
< — — 1
%Stretch

Add the Stretch Leftwards action for keyway as the following picture shows. Lire s wanerer
Special Note: Do elect “Distance” for the linear parameter to stretch fuo] /gm »
leftwards the operation objects set. This is a necessary procedure of the
chain operation. = - -

4.Test Dynamic Block: After dragging the left grip, not only the keyway will
stretch bi-directionally and symmetrically but also the smaller diameter shaft of
the step shaft will stretch automatically. This is a chain action. The realization of .
a chain action has two important procedures: First, modify the property value of sy

the parameter that need to happen as linkage and modify the property of “chain TR

action” from “NO” to “YES”. Second, elect the parameter of objects that are —

elected to linkage action to set. - I ] _"\/

Scale Action: Scale Action can be matched with the Linear Parameter, Polar and XY Parameter to achieve various Dynamic
effects.

Linear Scale

1. Draw: Finish drawing an access hole in a model space and define it as a block, as shown in the
following picture.

Start-¥ o
2. Add Linear Parameter: Enter into Block Editor to add a . :
linear parameter. The start point of the Linear Parameter is ;j:in:jf“‘ ;;5 e
the center of the circle, and choose the number of grip as pazle
“1”as shown in the following picture. Dist type [Nene
T
“ﬂ—-.--ﬁw—-: Base Location |[Start Foint

Show Properties|Tes

Chain Actions |No

2 o Grios =

i
i

b
Humber of Grips k
| Humber of grips asscciated to
Fl 5 ohject

119



Chapter 13 Create and Edit Dynamic Blocks

3. Add Action: Click the Scale icon on the Action Panel, appoint c ® 5

parameter for Action and box the whole access hole as Action Object, o/ { \@

as shown in the following picture. ’O I OU'
&% © =

4, Test Dynamic Block: Exit from Block Editor and insert the Dynamic block,
after pitching up the Dynamic Block, drag the triangle grip, the objects (nuts)
will scale with it.

Polar Scale

When we move the Scale Grip of the Access Hole on the left of circle center, namely move the
base point of the Linear Parameter to the left of the circle center, we will find that the block does
not have a corresponding Scale, as shown in the following picture.

The reason for this is that the Endpoint of the Linear Parameter cannot cross its base point, so
we change the Linear Parameter to be a Polar Parameter, we do not change any other
operations, as shown in the following picture.

Exit from Block Editor, Drag the grips of the Access hole Block again,
you can see, that after the change from Linear Parameter to Polar
Parameter, we can drag the grip to scale the dynamic block in any
direction.

Scale Character: In this section, we will explain some Scale characters using XY Parameter and Scale Action in a paired
example.

1. Drawing graphics: Draw the graphics which need a dynamic block and define them as a block as below:

O
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2. Add XY Parameter: Entry Block Editor, add XY Parameter. Parameter adding is similar to Linear Parameter. Pick the first point
of the parameter from the left bottom corner of the rectangle as the base point, the second point from the top right corner and
change the Number of Grips to “1”. Then add Scale Action, as shown below.

%Scale
@ Y Distance

o
=

X Distance

3. Test the Dynamic Block: After exiting the Block Editor, drag the grip of the top right { _______________________________
corner of the rectangle, you can see the whole dynamic block is scaling as the grip is Q
moving. It is easy to find that both the circle and the rectangle scale by the base point A

of the XY Parameter.

5. Modify Action Base: Modify Base type: go back to Editor, select Scale Action and change the default “Dependent” to
“Independent”.

[Scale type  [UT Scale

‘B Scale
i Baze-f

3
¥ ‘ %
g [pase-y [
o Y Distance :
Jction nane  [Sede

Selection set |3 Object

Eae
o

X Distance

+

Specify new base: Single click the right input box of “Base-X" and jf,-!"Sra% =
“Base-Y”, you can manually input the coordinate value or you can Y :i)istance :
single click the small button with ellipsis dots on the right of the
input box and snap the base point, as shown: r %
X Distance
Specify the base point by crosshair and the circle center as base point. After et
exiting Block Editor, scale the dynamic block. After modifying Base type and ./
position, the scale center of the dynamic block changes from the XY Parameter
base point to the new specified base point (center of the circle).
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6. Scale Type: There is “Scale Type” in the Scale Action

3 =
Properties. The default value is “XY Scale”. If you choose ‘;’,,,!' Sca?%‘ T
“XY Scale”, the dynamic block scales whenever the scale { Distance I
grip moves to X axis or Y axis. If you choose “X Scale”, it

scales only when the grip of the scale moves to X axis. =
Same, when you choose “Y Scale”.

X Distance

Rotation: In this section, we are going to use a rotation parameter and rotate action to add a dynamic rotate function to view
index symbols (English system) which are frequently used in architectural drawings.

1. Draw a drawing: Draw a view index symbol and define as a block, as shown in below picture. Please n

define view number and drawing number as attribute text, so as to revise whenever you want. w

2. Add rotation parameter: Pick the center of the circle as the first point of the parameter, system default it as the rotation point,
setangle type as "increment", and define its number as 15 degree, as shown below.

3. Add rotate action: Click the rotation action
button on the action panel, match parameter,
object and position for the action and select the
whole index symbol as the object of the action.

4., Test dynamic block; Exit from block editor and insert the block, drag f><

rotation grip to reach the effect of rotation, as shown in below picture. 101 101

Rotation

Polar Stretch: We use the Polar Stretch function of Dynamic Blocks to draw the section symbol in this section.

1. Draw, Mirror and Define as a Block: The follow drawing includes the attribute text which can be modified as you need. Then
mirror this drawing and define the mirrored object as a block.

da oAl T A
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2. Add action and parameter for the attribute text: Add Point
Parameter and Move Action for text and change the Chain
Action to “Yes” .It is ready for next step to create Chain
Action for Polar Stretch Action.

3. Add Polar Parameter and Action: Add Polar Parameter whose first point
should be the center of the section symbol. This point will be the rotation center
of the Polar Parameter. Follow the instructions below:

v
A Distance ﬁPolarStretch

= X

gition
Move

1. Pick the right grip of the Polar Parameter as an associated parameter point and specify the Stretch box (Fig. 3.1).
2. Select objects to stretch and the “position” Point Parameter together, which can accomplish that the text and section symbol

are moving together (Fig. 3.2).
3. Specify objects which rotate only for Polar Stretch Action (Fig 3.3).
4. Specify Action symbol location (Fig 3.4)

5. Repeat the above steps to add the same parameter and action order for the left part.

Distance

Distance

5 = L

Fig 3.1

é—/posit
— § Movs

Distance

#qi—J/rposl1
;[,; Move

Fig 3.3

Fig 3.2
Distance
.—f'.l - ¥ bt
é_/posn
==
Fig 3.4

It is better if you hide the grips which are not associated with the Polar Stretch Parameter as below:

Y
jE;PolarStretchl BreEasEE] Piy Disitatice PolarStretch

——

——t> X

positionl

Frun B

osition
Move
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4. Test Dynamic Block:

Open the graphic which needs to be dimensioned
and insert the completed dynamic block (Fig 4.1).
Drag the grip of the dynamic block, the section

symbol can be stretched outward and rotated .
around the center, and you finish the section | |
symbol mark (Fig 4.2). ‘ |

Fig 4.1 Fig 4.2
Polar Stretch Action Characteristics: Modify the grips’ number of the polar parameter Before modification
in the section symbol dynamic block in the last example to display both of the two A I’_ - _1 A

grips of the polar parameter. From the following picture we can see that the central
grip is clearly different before and after. Before modifying, the central point was
actually the base point of the block, and this was the insert point. But after modifying, A I— w .I A
the center point of block is the base point of the polar parameter.

Modified

Clicking central grip can move the grip to any direction. Meanwhile, the dark blue insert point of block will appear again, as
shown in the following picture. Obviously, the insert point is only covered by the base point of the polar parameter. The base
point of the polar parameter can move arbitrarily, but for the block it seems that no ——

change is happening. But is it true? A I_ = —] A

’\A

\

In order to confirm if the block changes or not, we move the grips on AI_ +.//_1A E> Ar
both terminals and we can find that the section symbol does not center

on the dark blue base point when changing but it takes the base point of P A r
the polar parameter as a rotate center, as shown in the following picture. Ar g '] A E:>

Enter block editor, move up the parameter and the other settings do not change.

Distance

| )
% & PolarStretch
%PolarStretlchl Distancel % olarctretc.

—fB——r %
pomtlonlM ’ osition
%Movel Move

Exit block editor, move the right grip and you can see that rotate center moves up along with the parameter. From the examples
above it is difficult to understand that the polar parameter cannot move arbitrarily like the point parameter and linear parameter,
the reason is that the base point of the polar parameter .
specifies the rotate center of the object, once the parameter is " " T—
moved, the rotate center will move accordingly. That the rotate Ar ol -iﬁ :> A

Na

> .
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parameter cannot move arbitrarily has the same reason.
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Array: For the Array function of Dynamic Block we need to use Array Action, we use Array Action to match with Linear Parameter,
Polar Parameter, XY Parameter to achieve various Arrays.

Linear Array

No. Name Number | Materials Horm Note

1. Draw: Draw a parts list and define it as a block.

2. Add Linear Parameter: After adding Array Action, we can drag the two grips of the Parameter to make a list array, but
obviously, we hope just to achieve an up array of the blank bar, not a down array, so to avoid a mistakes, we should hide the
grip under the Parameter, as in the following picture.

L!fé Array, 1&%%%%Array

No. Name Number | Materials Norm Note

=5} 2 X

3. Add Array Action: During the add Array Action, the system will require to appoint space between columns. The space
between columns is the distance between the objects that the array created. Here, the line width is 7mm, for the line between
the lines a close up array can be chosen, we appoint that the space between the columns is 7mm.

ArrayD/i stance

O L.
‘B Tablebrray
v

No. Name Number | Materials Norm Note —f ‘
£ = X

4. Test Dynamic Block: Insert Dynamic Block, drag the top right corner grip upwards, the line number of the part list will be
added automatically, as in the following picture.

No. Name Number | Materials Norm Note

=Y
XY Array .
Compared with Linear Array, XY Array 1 | :
has a vertical direction Array. I "L/, = 11
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Polar Array

We see a Dynamic Block example as follows, after
dragging grip, the effect will be as in the following
picture. You can see, not only can we stretch the fence,
but we can also rotate the direction casually, this is the
effect combining Polar Stretch with Polar Array.

Enter into Block Editor, Stretch, the ways of adding Array T [
Action as in the following picture, the bold object expresses il
the relevance with the selected action. The Polar Parameter 3
determines the way of Array directly, the Polar Array will regard

the direction of the Polar Parameter as Array direction,

achieving Array functions in any direction. Y ﬁ"‘“’a"

? %Stretch ? W Sireich

= X
Distance Distance

_(
i
=]
8
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